hMailServer 4.0 - Build 86 (Alpha)

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Post Reply
User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

hMailServer 4.0 - Build 86 (Alpha)

Post by martin » 2005-03-06 20:48

New build available:
http://dev.hmailserver.com/hMailServer-4.0-Build-86.exe

Changes since previous build:

* When moving a message to an IMAP folder, it is now possible the message to sub folders. More information on the documentation page.

* If a database error occurs when executing a select-statement, hMailServer could in previous versions hang and try to read from the recordset in an endless loop, eventhough it did not contain any data. This is now fixed.

* The server should now work on NT4.
Last edited by martin on 2005-03-07 23:30, edited 1 time in total.

edwardtfn
Normal user
Normal user
Posts: 37
Joined: 2004-06-16 21:30
Location: Campinas, SP, Brazil

Post by edwardtfn » 2005-03-07 02:47

Dear Martin,

I've downloaded this version and it works propertly except at reboot, because the hMailServer service don't start automaticaly.

Event Viewer reported an timeout for response from service...

I tryed it N times...

I'm using Windows 2000 Server PT-BR With Service pack 4
hMailServer v4.0 B86 with internal MySQL

Regards,

Edward Firmo

User avatar
layer
Normal user
Normal user
Posts: 55
Joined: 2004-09-12 14:19
Location: Portugal

Post by layer » 2005-03-07 16:42

edwardtfn wrote:Dear Martin,

I've downloaded this version and it works propertly except at reboot, because the hMailServer service don't start automaticaly.

Event Viewer reported an timeout for response from service...

I tryed it N times...

I'm using Windows 2000 Server PT-BR With Service pack 4
hMailServer v4.0 B86 with internal MySQL

Regards,

Edward Firmo
if u serach the forum... but in you instalation directory you have a "addons", in that folder u will find another folder "Service dependencies", just a ckick on "MySQL Internal.reg" and voalá :)

edwardtfn
Normal user
Normal user
Posts: 37
Joined: 2004-06-16 21:30
Location: Campinas, SP, Brazil

Post by edwardtfn » 2005-03-07 16:52

I've tryed it before install B85... I will try it again with this new version...

I will wait for lunch to reboot the server...

Regards,
Edward Firmo

edwardtfn
Normal user
Normal user
Posts: 37
Joined: 2004-06-16 21:30
Location: Campinas, SP, Brazil

Post by edwardtfn » 2005-03-08 00:43

Dear Martin, it don't works...
Edward Firmo

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2005-03-08 00:47

Which of the .reg files did you run?

Open up the the propertes for Control Panel->Administrative tools->Services->hMailServer. Then click on "Dependices". Are there any services in the list?

What's the value of the registry key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\hMailServer\hMailServerMySQL

What's the exact error message in the event viewer?

Post Reply