Page 1 of 1

Greylisting bug or feature?

Posted: 2009-02-10 07:37
by PeterK2003
i have been receiving a significant amount of spam that is address to me@mydomain.com and it also has a sender address of me@mydomain.com. Normally SA and/or hMail's spam protection catches it and it is dumped into my spam folder. But i got curious as to why so much was getting past the gray list. I picked a few messages and went to look up their IP in the gray list table and to my surprise there wasn't an entry for them. Upon further inspection I discover that there was no entries where glsenderaddress was set to mydomain.com.

So is this behaivor expected or is it a bug? It seems like a bug to me...at least i can't think of a reason that it should do this.

Thanks
Peter

Re: Greylisting bug or feature?

Posted: 2009-02-10 07:57
by mattg
Peter,

Have you upgraded to Ver 5 yet?

I think that this was related to the way that mail with a local from address bypassed the ANTI-SPAM tests. I believe that this is amended in the way that Ver 5 handles these connections.

You could also look at the first script here, to force those with a local from address authenticate - http://www.hmailserver.com/documentatio ... eptmessage

Matt

Re: Greylisting bug or feature?

Posted: 2009-02-10 08:04
by PeterK2003
mattg wrote:
Have you upgraded to Ver 5 yet?

I think that this was related to the way that mail with a local from address bypassed the ANTI-SPAM tests. I believe that this is amended in the way that Ver 5 handles these connections.
Yes i am on the latest 5.0 build
mattg wrote: You could also look at the first script here, to force those with a local from address authenticate - http://www.hmailserver.com/documentatio ... eptmessage
Although this would probably fix the issue it doesn't explain the gray list behavior.

Re: Greylisting bug or feature?

Posted: 2009-02-10 08:05
by mattg
What do you have set in your IP ranges?

Re: Greylisting bug or feature?

Posted: 2009-02-10 08:11
by PeterK2003
i have one range for the internet and one for my lan--this is not the issue--all the mail in question would get included in the internet category which i know is gray listing other mail correctly.

Re: Greylisting bug or feature?

Posted: 2009-02-10 08:23
by mattg
So is your domain in the whitelist or even the greylist...whitelist

Re: Greylisting bug or feature?

Posted: 2009-02-10 15:31
by PeterK2003
neither

Re: Greylisting bug or feature?

Posted: 2009-02-10 16:10
by martin
In hMailServer 5.0 grey listing isn't applied on local senders. Not sure why it was implemented this way (it was deliberate but ..) so it has been changed in v5.1 to always be done unless the sender is authenticated. (It's changed in the 5.1 alphas already available)

Re: Greylisting bug or feature?

Posted: 2009-02-10 16:47
by PeterK2003
k thanks

i don't really want to run an alpha release maybe when it goes to beta