hMailServer 5.0, build 281 (Alpha)

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Post Reply
User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

hMailServer 5.0, build 281 (Alpha)

Post by martin » 2008-01-14 00:55

A new 5.0 alpha is now available:
http://download.hmailserver.com/dev/hMa ... 0-B281.exe

Only small changes compare to previous build. I'm working on redesigning hMailServer Administrator, but the new version of that one isn't included in this build (since it does not work yet)

This build can only be used for testing purposes, and you should absolutely not upgrade an existing production installation to this build.

The following changes have been made:
  • Anti-Spam: If delete threshold is reached, hMailServer no longer continues with other spam protection tests
  • Installation: Some files longer valid for 5.0 were removed from the installation (issue 110).
  • API: A fix was made to Copy method of the hMailServer.Message object. Previosuly it didn't work with some specific development environment.

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Post by Kaan1983 » 2008-01-14 03:37

I waited for the whole week-end and it came at Sunday 23:55 :D still week-end though.

Thanks Martin...

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Post by Kaan1983 » 2008-01-14 16:32

I just installed and it just works great in 2 minutes.
The Database Upgrade utility is great :)

It simply works fine on XP with SQL 2005

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Post by Kaan1983 » 2008-01-14 16:33

WOOAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA:...

Unicode Support WOOOOOOOORRRKKKSSSS :D

I love you Martiiiiinn I love you Martiin :D

Man my interface used to look like sh*t, but now it's greaaat...

God bless you :)

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-01-14 18:52

It may appear to work properly, but there's still some quirks. Suspect that I need to change the encoding for it to work properly in all cases but I agree that it's better than before. :)

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Post by Kaan1983 » 2008-01-14 22:07

Man you can't believe how much coding you saved me... and to others too... I just deleted 200 lines of code from my inbox code page.. I'm not counting the additional codes I was supposed to code...

You are number one. No discussion :)

Btw in one mail from gmail it didn't detect the html code, but it shows the body... I thought you might want to take a look at it; so I've send it to your mail.

jaz
New user
New user
Posts: 4
Joined: 2008-01-16 17:50
Location: Boston

Post by jaz » 2008-01-16 18:30

Just a quick question on upgrading...

I'm on 4.3.1, and I'd like to upgrade. Will this alpha, and subsequent alphas/betas/production versions be simple click-and-install upgrades?

Btw- My installation serves only myself, and I fetch mail from various other servers and then read via imap from hM. I also forward new mail to my phone -- therefore have to leave Thunderbird running to do my spam filtering (you can see how important 5.x is to me).

Thanks a million everybody--

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Post by Kaan1983 » 2008-01-16 19:10

Even though you better wait for at least a beta version to upgrade your production server, yes it automatically upgrades... that´s a great option:)

jlpatte2
New user
New user
Posts: 10
Joined: 2007-01-20 02:53

Post by jlpatte2 » 2008-01-25 17:24

Does the 5 series alphas irrecoverably change the DB or could I got back to the 4 series if I had to many problems with 5?

I just recently got a new phone which does IMAP, and something about 4 series cause the phone mail app (and thus the phone :( ) to crash, I'm thinking that perhaps the ssl support in 5 might sufficiently change things up to keep this from happening. I am the only user, so the server isn't mission critical or anything...

Thanks, Josh
Josh Patterson

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-01-25 17:55

> I just recently got a new phone which does IMAP, and something
> about 4 series cause the phone mail app (and thus the phone)
>to crash

I doubt it's the 4 series which causes your phone to crash, it's more likely that it's a bug in your phone which causes it.

I also doubt starting to use SSL will have any effect on it. If you want to test, you can use stunnel to achive SSL with version 4. :)

jlpatte2
New user
New user
Posts: 10
Joined: 2007-01-20 02:53

Post by jlpatte2 » 2008-01-25 21:05

I'm sure its not hMail, but it is equally an integration issue between hMail and the phone(since this doesn't happen with other imap servers)... I know I won't get any support or fix from the phone vendor, so I just hope that whatever the phone imap client doesn't like may have randomly changed between 4 and 5, and adding ssl on top ;)
No implied criticism of hMail here, really a phone issue, just know I won't be able to fix it from that end!
Josh
Josh Patterson

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-01-26 13:37

Okay. But you can use stunnel with version 5 if you want to try it with SSL. :)

abgar
Normal user
Normal user
Posts: 93
Joined: 2005-03-23 09:33
Location: Warsaw, Poland

Post by abgar » 2008-01-27 13:48

I got to use hmail 4 & IMAP with Sonyericsson phones for over a year and had never got any problem

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2008-01-27 16:54

My SE cybershot works perfectly well with hMail IMAP as well.

User avatar
bagu
Normal user
Normal user
Posts: 224
Joined: 2005-06-17 03:08
Location: France
Contact:

Post by bagu » 2008-01-28 21:48

Kaan1983 wrote:Even though you better wait for at least a beta version to upgrade your production server, yes it automatically upgrades... that´s a great option:)
Even if i use an external database ?

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-01-28 21:50

yes

Henry Sværke
Normal user
Normal user
Posts: 46
Joined: 2007-09-08 16:46

Post by Henry Sværke » 2008-02-03 11:47

Just dropped by to say...wow, great job!, even at this allegedly early state of development, 5.0-B281 has been running flawlessy on my computer for days, one of the rock-solidest alphas I have ever tried :)

slech
New user
New user
Posts: 20
Joined: 2008-02-09 18:12

Post by slech » 2008-02-09 22:11

I'm try to add domain
Image

slech
New user
New user
Posts: 20
Joined: 2008-02-09 18:12

Post by slech » 2008-02-09 22:17

Logging function not work in this beta wersion ?

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2008-02-09 22:22

It is not a Beta it is an Alpha version. Expect things to be broken :)

slech
New user
New user
Posts: 20
Joined: 2008-02-09 18:12

Post by slech » 2008-02-09 22:46

ups, sorry :oops:

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-09 23:36

A new version of hMailServer Administrator will be included in version 5 which is rewritten from scratch. So any problems in the current v5 build is not really relevant. :)
(It will look the same as before, just rewritten..)

phil54
Normal user
Normal user
Posts: 195
Joined: 2007-11-26 13:13
Location: UK :-)

Post by phil54 » 2008-02-25 19:20

I've just noticed a small error as well, thought i'd best let you know. I installed v5 just to see what it's like on my test server and then tried to restore a backup from v4, it didnt like too much and then crashed.

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-03-03 03:54

martin -- I was curious as to if this is going to be implemented into v5. I was not able to find a change log/new features for v5.

http://www.hmailserver.com/forum/viewtopic.php?t=11334

Where if you set the max file size to 10mb and someone tries to send 100mb file, it will stop downloading/sending it once it reaches the 10mb limit and not accept the entire 100mb then alert you that the file size is too large. This could cut down on quite a bit of bandwidth I believe.

This example is for clients (outlook/outlook express) that do not check the max file size before sending.

westdam
Senior user
Senior user
Posts: 728
Joined: 2006-08-01 21:24
Location: Padova, Italy
Contact:

Post by westdam » 2008-03-06 18:51

i believe the hmailserver support the SMTP SIZE parameter..isn't it?

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-03-06 23:42

westdam wrote:i believe the hmailserver support the SMTP SIZE parameter..isn't it?
This was discussed in the thread i posted above. Yes you can limit it, but the smtp connection will not be cut until the client has finished uploading the entire file in some cases. (outlook will do this) then it will reject it.

minsik
Normal user
Normal user
Posts: 92
Joined: 2006-08-03 13:08
Location: South Australia

alphas going very well. Backup seems dead!

Post by minsik » 2008-03-11 12:23

5 b 281 is an amazing alpha. Howvever a minor tampering rendered a problem. So I reinstall and use a backup.
then i discovered that backups were not working! Oh well so little to configure anyway.

The log file appears to have one ascii letter and then a null. For some reason my text edtor wont copy it!

Anyway the backup and restore seems dead.

Look forward the next release and thankyou to martin for the hard work

He is a legend.
Windows XP
hmailserver (latest beta allways) (except db versions)
test config, trying to convince the boss to use hmail!
ASSP - front end SPam killer

timb0311
Normal user
Normal user
Posts: 50
Joined: 2006-09-22 20:15

Post by timb0311 » 2008-03-13 00:22

Any new word on when the beta will be released? I want to plan some testing time for it in my schedule.

Carl
Normal user
Normal user
Posts: 111
Joined: 2008-03-18 17:33
Location: Utah, USA
Contact:

Re: hMailServer 5.0, build 281 (Alpha)

Post by Carl » 2008-03-22 01:55

You can (sometimes) work around the bug with restoring backup files by doing one part at a time (settings, and then domains, messages) Overwriting, deleting and restoring multiple things at once seem to be where the problem is at.
Carl

98% of computer users know just enough to be dangerous, but not enough to be useful. I'm afraid I don't fall in the top 2%.

Selecters
New user
New user
Posts: 14
Joined: 2007-07-28 00:02
Location: Rep. Argentina
Contact:

Re: hMailServer 5.0, build 281 (Alpha)

Post by Selecters » 2008-03-24 12:58

Sorry if this is not the place for my question. Admin, feel free to move if needed.
I'm a really happy user of hMailServer 4.4.1 - Build 273, in some production servers. Now downloading alpha version of Hmail 5 to test. So, my question is: any idea when HMail 5 final will be released?
TIA
___________________________
Claudio M. E. Bastos Iorio
http://www.blumer.com.ar

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: hMailServer 5.0, build 281 (Alpha)

Post by martin » 2008-03-24 13:48

When it's done and stable. :)

GlenC
Senior user
Senior user
Posts: 680
Joined: 2004-08-17 23:31
Location: Santiago, Chile

Re: hMailServer 5.0, build 281 (Alpha)

Post by GlenC » 2008-03-24 20:04

martin wrote:When it's done and stable. :)
You should put that on the Roadmap 8)

Post Reply