IMAP changes in 5.7?

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Post Reply
binarydad
New user
New user
Posts: 17
Joined: 2016-02-23 15:12

IMAP changes in 5.7?

Post by binarydad » 2021-04-07 23:16

I'm thinking of trying 5.7 (currently on build 2535) but am curious if there have been any improvements to IMAP specifically. I've previously had issues with new emails not showing up under my inbox for Thunderbird and emClient (requiring a restart of those applications for them to suddenly show up). While I'm not sure whether the issue is with the server or the clients, I'm curious if any changes or improvements have been made to the IMAP protocol in 5.7. Thanks.

palinka
Senior user
Senior user
Posts: 2558
Joined: 2017-09-12 17:57

Re: IMAP changes in 5.7?

Post by palinka » 2021-04-08 03:30

I don't think there have been any changes to IMAP at all in 5.7.

Also, I'd suggest that its your client that's misbehaving. I use emclient too and once in a blue moon get a situation where an apparently "corrupted" email causes emclient to stop downloading mail, while 9folders mail client on my phone can download all messages just fine. I think its rather something corrupted with emclient's message database than anything to do with hmailserver. Finding and deleting the message in another client allows emclient to come back to life.

binarydad
New user
New user
Posts: 17
Joined: 2016-02-23 15:12

Re: IMAP changes in 5.7?

Post by binarydad » 2021-04-08 04:03

palinka wrote:
2021-04-08 03:30
I don't think there have been any changes to IMAP at all in 5.7.

Also, I'd suggest that its your client that's misbehaving. I use emclient too and once in a blue moon get a situation where an apparently "corrupted" email causes emclient to stop downloading mail, while 9folders mail client on my phone can download all messages just fine. I think its rather something corrupted with emclient's message database than anything to do with hmailserver. Finding and deleting the message in another client allows emclient to come back to life.
Yep, this is exactly 100% my same issue. I'd have to repair the inbox (it seems to JUST be the inbox folder causing issues), restart emclient, or read/unread the missing message from my phone (Samsung mail works 100% of the time) for it to magically show up in emclient. Do you get the dreaded "..." too next to the inbox that won't download when this happens?

palinka
Senior user
Senior user
Posts: 2558
Joined: 2017-09-12 17:57

Re: IMAP changes in 5.7?

Post by palinka » 2021-04-08 04:12

binarydad wrote:
2021-04-08 04:03
palinka wrote:
2021-04-08 03:30
I don't think there have been any changes to IMAP at all in 5.7.

Also, I'd suggest that its your client that's misbehaving. I use emclient too and once in a blue moon get a situation where an apparently "corrupted" email causes emclient to stop downloading mail, while 9folders mail client on my phone can download all messages just fine. I think its rather something corrupted with emclient's message database than anything to do with hmailserver. Finding and deleting the message in another client allows emclient to come back to life.
Yep, this is exactly 100% my same issue. I'd have to repair the inbox (it seems to JUST be the inbox folder causing issues), restart emclient, or read/unread the missing message from my phone (Samsung mail works 100% of the time) for it to magically show up in emclient. Do you get the dreaded "..." too next to the inbox that won't download when this happens?
I think it was a red triangle - like can't connect icon.

The way I found the message was by enabling logging, then looking at the last message emclient attempted to fetch from hmailserver imap. There's an error in the log immediately after, so by looking at the metadata (msg time, to, from, etc) in the log for that message, I could find the message in another client and delete it. Then emclient works right away on the next fetch. This is rare, fortunately, because its a pain.

Post Reply