hMailServer 5.7

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Bodos
New user
New user
Posts: 13
Joined: 2019-01-14 16:45

Re: hMailServer 5.7

Post by Bodos » 2020-03-10 16:32

Sorry missed that out of excitement :D
Definitely give a try this weekend for our office with 5-6 users on new server that will be prepared fresh.
What is the mysql version recommended for x64 built? Stick with 5.7?

Kendo
Normal user
Normal user
Posts: 97
Joined: 2015-07-08 23:33
Location: Rural Australia

Re: hMailServer 5.7

Post by Kendo » 2020-03-10 23:16

mattg wrote:
2020-03-10 16:24
The drop down box next to the version number in the build environment shows a change log

https://build.hmailserver.com/viewType. ... eChangeLog
This link leads to a login page.

https://www.hmailserver.com/download/ shows old version links and info.

User avatar
mattg
Moderator
Moderator
Posts: 20640
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer 5.7

Post by mattg » 2020-03-10 23:29

I'm running mySQL ver5.5, but you can also use MariaDB or Microsoft's SQL Server, or PostgreSQL
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
mattg
Moderator
Moderator
Posts: 20640
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer 5.7

Post by mattg » 2020-03-26 09:47

came across an issue

Poorly configured dns I think

test@example.com

mx record for example.com = priority=10, mail.example.com

DNS lookup for mail.example.com shows a CNAME of mail.otherdomain.com
DNS lookup for mail.otherdomain.com points to an A record with an IP


hMailserver 5.7 logs

"APPLICATION" 7140 "2020-03-26 17:39:36.425" "SMTPDeliverer - Message 1511664: No mail servers could be found for the address test@example.com."
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
RvdH
Senior user
Senior user
Posts: 934
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-03-26 10:19

mattg wrote:
2020-03-26 09:47
came across an issue

Poorly configured dns I think

test@example.com

mx record for example.com = priority=10, mail.example.com

DNS lookup for mail.example.com shows a CNAME of mail.otherdomain.com
DNS lookup for mail.otherdomain.com points to an A record with an IP


hMailserver 5.7 logs

"APPLICATION" 7140 "2020-03-26 17:39:36.425" "SMTPDeliverer - Message 1511664: No mail servers could be found for the address test@example.com."
Looks similar as the DKIM CNAME records issue, but don't think this is the right place to report such bug, can't you better create a issue on github?

https://github.com/hmailserver/hmailser ... r.cpp#L159
https://github.com/hmailserver/hmailser ... r.cpp#L284
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

User avatar
RvdH
Senior user
Senior user
Posts: 934
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-03-26 11:09

I just tried a setup like you described above, don't really had a problem sending mail out (5.7), it reported 7 ip addresses where it should report only 4

Code: Select all

"TCPIP"	3392	"2020-03-26 09:33:16.919"	"DNS MX lookup: domain.nl"
"TCPIP"	3392	"2020-03-26 09:33:17.075"	"DNS - MX Result: 7 IP addresses were found."
Is mail.otherdomain.com is also a MX record on mail.otherdomain.com or only a A-record?
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

User avatar
RvdH
Senior user
Senior user
Posts: 934
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-03-26 15:53

Oops :oops:
7 mx records was right after all, 3 ip addresses (from backup mx) had a ipv6 equivalent


Weird, you didn't seem to have a issue with dkim sname's, and now I don't seem to have a issue with MX cname's....but i suspect it to be related
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

User avatar
jimimaseye
Moderator
Moderator
Posts: 8381
Joined: 2011-09-08 17:48

Re: hMailServer 5.7

Post by jimimaseye » 2020-03-26 20:15

mattg wrote:
2020-03-26 09:47
came across an issue

Poorly configured dns I think

test@example.com

mx record for example.com = priority=10, mail.example.com

DNS lookup for mail.example.com shows a CNAME of mail.otherdomain.com
DNS lookup for mail.otherdomain.com points to an A record with an IP


hMailserver 5.7 logs

"APPLICATION" 7140 "2020-03-26 17:39:36.425" "SMTPDeliverer - Message 1511664: No mail servers could be found for the address test@example.com."
According typo RFC mx's should not be cname records. Even so, I don't think it should error and I already reported this in github against 5.7.
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

User avatar
RvdH
Senior user
Senior user
Posts: 934
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-03-26 22:03

Funny thing is i recreated the MX DNS setup mattg described but had no issue sending email whatsoever...weird stuff is going on with 5.7 and DNS lookups :shock:
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

Post Reply