Search found 623 matches

by katip
2007-02-24 17:46
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 164240

They aren't error messages they are notices. Are you running PHP5? PHP 5.1.2 Yes, they are notices. I'm not a PHP expert but assume that it's reading script lines in their sequence. Those lines causing the notices are statements about not (yet) defined variables as code for the actual form - which ...
by katip
2007-02-24 17:31
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 164240

Does the script work? Are you including this script from another script or using it standalone? Have you entered anything into the boxes when you get these errors or are you just leaving them blank as there is no error checking in that script and would throw up warnings if the boxes were empty. Hi ...
by katip
2007-02-24 07:32
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 164240

It's woking, but...

Thanks for this handy script and sorry for asking same question once again: I've copied/saved above script as signup.php, made proper mods and fired it from mydomain.com/cgi-bin/signup.php Following errors are displayed on top of the page: Notice: Undefined index: name in C:\(blah...)\cgi-bin\signup...
by katip
2007-02-04 06:22
Forum: General discussions
Topic: Rules - Mail Loop
Replies: 5
Views: 1399

Hi,

...AND Recipient-List not contains alias@aliasdomain.com

should stop looping ;)
Note that "Forward" is not equal to "Move". It creates another message.
by katip
2007-01-16 22:51
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 5367

Thanks Martin. This works as it is. However if user sends mixed to local and external in To field (and even mixes something similar in CC) then you're lost in rules I think. edit// Hmm. If you omit "To Not Contains @localdomain.com", at least *any* outgoing mail > xys size should be blocked, local a...
by katip
2007-01-16 21:17
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 5367

Any clue from anybody to above question?
by katip
2007-01-13 08:09
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 5367

Ok then.
What is your suggestion for a rule(set) which deletes *outgoing* mails greater than xyz size and let the local sender notify? I'm a bit confused :) TIA
by katip
2007-01-11 06:14
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 5367

This rule: if from contains katip@katip.com and if messagesize > 100 send a reply delete email works perfect. However: if from contains @katip.com and if messagesize > 100 send a reply delete email Causes the reply to be deleted too as far as I can see in the logs, if I'm not mistaking: "SMTPD" 896 ...
by katip
2007-01-10 21:47
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 5367

Hi Martin,

exact address ok but "contains" doesn't work in any case. FYI.
by katip
2007-01-10 19:32
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 5367

Yes Martin, you're right. Now it seems to be ok. The problem was the "mail from" field defined in my mail client (Pegasus). Glad to hear that you noted this point though.

My sample filters were just do explain the problem. Of course, a "delete email" will be the last line there. Thank you.
by katip
2007-01-09 20:46
Forum: Development & alpha discussions
Topic: Signatures
Replies: 2
Views: 2132

Indeed, the problem should be mail client specific.
I've tested with TB now and sigs are ok.
But PegasusMail (with my previous tests) handles this somehow weird I think. I have to look into it's options. Thank you.
by katip
2007-01-09 20:15
Forum: Development & alpha discussions
Topic: Signatures
Replies: 2
Views: 2132

Signatures

Hi Martin,

4.4b254

1. Account and domain signatures don't seem to be appended.
2. Signatures containing special chars are deleted completely when trying to save them.

FYI. TIA
by katip
2007-01-08 20:15
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 5367

It's a global rule.
What I actually would like to do is to put a rule which deletes outgoing messages with a certain size or above and tells this to the sender.
by katip
2007-01-08 00:46
Forum: Development & alpha discussions
Topic: Send reply by rules
Replies: 13
Views: 5367

Send reply by rules

"Send a reply" in rules (both global and account) don't work for local senders here (4.4b254). i.e. message is sent from local user: if from contains katip@katip.com and if messagesize > 100 send a reply Reply never arrives (not generated) to katip@katip.com (log extract below) "SMTPD" 800 31226 "20...
by katip
2007-01-04 20:28
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 164240

Errors

I saved the script as it is as "signup.php". When I call it following errors are displayed: Notice: Undefined index: name in C:\Jana2\html\katip\cgi-bin\WebMail\src\signup.php on line 21 Notice: Undefined index: user in C:\Jana2\html\katip\cgi-bin\WebMail\src\signup.php on line 22 Notice: Undefined ...
by katip
2007-01-04 20:20
Forum: Off-topic discussions
Topic: Pegasus and Mercury dead?
Replies: 3
Views: 2762

Pegasus and Mercury dead?

David Harris will no more develop his suite.

http://www.pmail.com/
by katip
2007-01-04 20:17
Forum: General discussions
Topic: PHPWebadmin modifications in language file don't apply
Replies: 5
Views: 2401

Also, I don't see how they could possibly be kept/cached until server restart. That's a normal PHP-script.
Yes, me too. Have you checked this? Just try to change something in your language.ini and F5 your browser.
by katip
2006-12-28 20:10
Forum: General discussions
Topic: PHPWebadmin modifications in language file don't apply
Replies: 5
Views: 2401

Martin,

it seems that your globals in hmailserver_string_constants.php are kept till another restart of the server. fyi..

//edit
server-box I mean.
by katip
2006-12-28 07:22
Forum: General discussions
Topic: PHPWebadmin modifications in language file don't apply
Replies: 5
Views: 2401

Yes, I'm editing \hMailServer\Languages\turkish.ini Here config.php $hmail_config['rootpath'] = "c:/Jana2/html/katip/cgi-bin/PHPWebAdmin/"; $hmail_config['rooturl'] = "http://www.katip.com/cgi-bin/PHPWebAdmin/"; $hmail_config['includepath'] = $hmail_config['rootpath'] . "include/"; $hmail_config['te...
by katip
2006-12-27 19:42
Forum: General discussions
Topic: PHPWebadmin modifications in language file don't apply
Replies: 5
Views: 2401

PHPWebadmin modifications in language file don't apply

Hi all,

I've made some mods in language.ini (turkish.ini) but they don't apply.
Cleared cache, restart service, no avail..
What to do? TIA
by katip
2006-12-24 19:32
Forum: General discussions
Topic: PHPwebadmin language
Replies: 6
Views: 3394

PHPWebadmin Language mods don't apply

Hi all,

I've made some mods in language.ini (turkish.ini) but they don't apply.
Cleared cache, restart service, no avail :(
What to do? TIA
by katip
2006-12-23 15:38
Forum: General discussions
Topic: How to disable authentication for LAN?
Replies: 4
Views: 1965

Thx

Indeed, thanks!
Hah! My mind obviously went to DNS MX priority which is the opposit :oops:
by katip
2006-12-23 09:32
Forum: General discussions
Topic: How to disable authentication for LAN?
Replies: 4
Views: 1965

How to disable authentication for LAN?

Hi all, I have defined 3 IP ranges: 127.0.0.1 - 127.0.0.1 - MyComputer - Priority 10 Allow connections & Allow deliveries from - All is checked except External to External. Require Authentication... none is checked 192.168.1.1 - 192.168.1.255 - LAN - Priority 20 Allow connections & Allow deliveries ...