Search found 683 matches

by katip
2019-06-14 19:11
Forum: General discussions
Topic: Port 25 SMTP not work after update
Replies: 2
Views: 431

Re: Port 25 SMTP not work after update

ur welcome :)
what you update?
by katip
2019-06-14 15:38
Forum: General discussions
Topic: "Relay Access Denied" when using account Forward
Replies: 3
Views: 406

Re: "Relay Access Denied" when using account Forward

actually it's not From adress as seen on client. Envelope From was meant. in your case Gmail likely sees original sender (which is also a gmail address) as envelope from and rejects it as bogus. this seetings (RewriteEnvelopeFromWhenForwarding=1) should/may fix this. give it a try. btw, there are ma...
by katip
2019-06-14 08:56
Forum: Development & alpha discussions
Topic: Turkish Language
Replies: 8
Views: 5509

Re: Turkish Language

merhaba,

hmailserver.ini
[GUILanguages]
ValidLanguages=english,turkish
ekleyelim. sonra da restart.
by katip
2019-06-14 05:51
Forum: General discussions
Topic: "Relay Access Denied" when using account Forward
Replies: 3
Views: 406

Re: "Relay Access Denied" when using account Forward

try to put this in hmailserver.ini [Settings] and restart HMS.

Code: Select all

RewriteEnvelopeFromWhenForwarding=1
viewtopic.php?f=7&t=34026
by katip
2019-06-12 14:59
Forum: Development & alpha discussions
Topic: HMailserver HIDDEN settings
Replies: 6
Views: 3999

Re: HMailserver HIDDEN settings

I think auto forwarding and doesn't work for rule based forwarding. (Might be wrong though). this is true as i also understand. rule based forwarding writes account address where rule is fired as FROM in envelope. thread here : http://www.hmailserver.com/forum/viewtopic.php?f=7&t=34026 RvdH might h...
by katip
2019-05-30 14:45
Forum: General discussions
Topic: Problem, different from address when forwarding using account forwarding tab and account rule
Replies: 12
Views: 1106

Re: Problem, different from address when forwarding using account forwarding tab and account rule

The From header is indeed intact, however the FromAddress (envelope sender from my understanding and not From header) changes, maybe i wasn't clear in the first post. I added: [Settings] RewriteEnvelopeFromWhenForwarding=0 and restarted the service but it didn't help. hMailServer 5.6.6-B2383 learnt...
by katip
2019-05-30 08:19
Forum: General discussions
Topic: Time to say good bye ...
Replies: 24
Views: 2758

Re: Time to say good bye ...

HMS from a different point of view
:lol: :lol:
wine on HMS.png
wine on HMS.png (5.33 KiB) Viewed 2170 times
https://appdb.winehq.org/objectManager. ... n&iId=8895
by katip
2019-05-29 22:12
Forum: General discussions
Topic: Problem, different from address when forwarding using account forwarding tab and account rule
Replies: 12
Views: 1106

Re: Problem, different from address when forwarding using account forwarding tab and account rule

The emails are being forwarded using the From address of the account . However I need the forwarded emails to keep the original From address rather than changing to that of the forwarding account. interesting. i didn't know this. i use account level rules to forward tagged (by script) messages to a...
by katip
2019-05-15 02:41
Forum: Scripting
Topic: Can't delete message by calling function from ACCOUNT rule
Replies: 9
Views: 965

Re: Can't delete message by calling function from ACCOUNT rule

I've lost track of this issue, can you link to previous threads? It's something about avoiding double messaging if "Commercial vs Community Google Mail" and including "the recipient they forgot" no? Sender is _always_ external? Recipient _list_ are local users? yes, that was it. sender may be both ...
by katip
2019-05-14 20:30
Forum: Scripting
Topic: Can't delete message by calling function from ACCOUNT rule
Replies: 9
Views: 965

Re: Can't delete message by calling function from ACCOUNT rule

ID is written in table long before message hits inbox. You should be able to find oMessage.ID already in OnDeliveryStart(). .eml file is in .\hMailServer\Data at this stage. hmm, my approach was: ... strLocalSender = oMessage.Recipients(0).Address '<--- account from which the function is called by ...
by katip
2019-05-14 16:55
Forum: Scripting
Topic: Can't delete message by calling function from ACCOUNT rule
Replies: 9
Views: 965

Re: Can't delete message by calling function from ACCOUNT rule

my problem is "Subscript out of range". it seems ID isn't written in table unless file is saved on disk. and then it means message has already landed in inbox. too late for anything. am i right? if yes, no need to waste further time. i already have workarounds but it's a shame that calling a "delete...
by katip
2019-05-14 01:26
Forum: Scripting
Topic: Can't delete message by calling function from ACCOUNT rule
Replies: 9
Views: 965

Can't delete message by calling function from ACCOUNT rule

my chronic headache. i found this here : https://www.hmailserver.com/forum/viewtopic.php?t=19457#p119141 10 years ago the guy suffered from the same. didn't tell it so but very likely a "Subscript out of range" failure. once again in short: account rule message size > 0 calls a function function doe...
by katip
2019-05-12 01:54
Forum: Scripting
Topic: how to know the mail type SENT vs REPLY vs FORWARD
Replies: 2
Views: 505

Re: how to know the mail type SENT vs REPLY vs FORWARD

servers tend to add headers such as References, In-Reply-To, Thread-Index... if none of them is present, very likely it's an initially sent mail, otherwise either a forward, reply or maybe report. but as mattg suggests, for a server mail is mail, there is no 100% safe criteria for what you want to a...
by katip
2019-04-29 20:20
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

case closed :D 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r now works fine too with ODBC 5.3 . it comes out that ODBC 8.0 was the culprit. but didn't leave any trace. service just stucked. LTS-5.7.0-B2428-LibreSSL-x64 with ODBC 8.0, dying service provided the clue in Event Viewer. so, all ...
by katip
2019-04-29 18:51
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

I just went through this recently. You can't mix 32/64 bit ODBC connectors drivers with vice/verse apps. You probably didn't have an issue before because you were using the 32 bit hmailserver and 32 bit ODBC driver and your issue is coming from mixing 64 bit hmailserver with your old 32 bit ODBC dr...
by katip
2019-04-29 18:46
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

katip wrote:
2019-04-29 16:58
i think MySQL ODBC 8.0 Unicode Driver makes a problem with this build.
confirmed. MySQL ODBC 5.3 works well with LTS 5.7.0 LibreSSL build & my VBscripts. that's good news.
MySQL ODBC 8.0 causes HMS service die silently likely when script triggers commands to external table.
jfyi..
by katip
2019-04-29 16:58
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

ehm, not exactly. service stopped 2-3 times and i see this in Win Apps EventLog: Faulting application name: hMailServer.exe, version: 5.7.0.0, time stamp: 0x5cc6a2d9 Faulting module name: myodbc8w.dll_unloaded, version: 0.0.0.0, time stamp: 0x5c4e8849 Exception code: 0xc0000005 Fault offset: 0x0000...
by katip
2019-04-29 16:02
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

I have uploaded a uptodater LibreSSL 2.9.1 Release of LTS 5.7.0, maybe it works in your special Situation. https://github.com/Dravion/hMailServer/releases/download/5.7.0.0/hMailServer-LTS-5.7.0-B2428-LibreSSL-x64.exe now this works like a charm like it's predecessor. ehm, not exactly. service stopp...
by katip
2019-04-29 11:32
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

I have uploaded a uptodater LibreSSL 2.9.1 Release of LTS 5.7.0, maybe it works in your special Situation. https://github.com/Dravion/hMailServer/releases/download/5.7.0.0/hMailServer-LTS-5.7.0-B2428-LibreSSL-x64.exe thank you so much. now this works like a charm like it's predecessor. obviously th...
by katip
2019-04-28 06:39
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

The only sane Information about Error 109 (which is a Windows System Error) is this comment: // Can occurs when filled buffers are trying to flush to disk, but disk IOs are not fast enough. // This happens when the disk is slow and event traffic is heavy. // Eventually, there are no more free (empt...
by katip
2019-04-27 22:25
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

hah, das hat noch gefehlt.
service totally stucks. when i try to stop/restart it, this message comes:
Untitled 1.png
Untitled 1.png (3.5 KiB) Viewed 3922 times
then comes another dump as soon as i click Ok.
by katip
2019-04-27 21:45
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

*Do you run hMailServer in your Office LAN behind a NAT Router/DSL-Router and do you use a external Relayserver? yes, behind Untangle Firewall/Router, and yes, Smtp2Go as relayer. but as far as i see, error happens only when receiving. i stressed HMS locally between accounts, no error occured. Do y...
by katip
2019-04-27 09:29
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

AV was already off since some time. //EDIT: I mean it's on Ubuntu VM, called from within SA. i can turn off SA too if it'd help?? INI here: [Directories] ProgramFolder=C:\hMailServer DatabaseFolder= DataFolder=C:\hMailServer\Data LogFolder=C:\hMailServer\Logs TempFolder=C:\hMailServer\Temp EventFold...
by katip
2019-04-27 09:03
Forum: Development & alpha discussions
Topic: Sub OnHELO(oClient) progress?
Replies: 197
Views: 42622

Re: Sub OnHELO(oClient) progress?

As I said above, I have a lot of time invested here, and I'd like to see it work, but there comes a time where I need to protect my actual income, and move on to a product that continues to be updated. When I first started using hMailserver I wasn't keen on config file and Linux command line stuff,...
by katip
2019-04-27 05:52
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

i turned on all logs (smtp, app, tcp, debug). this came out: "DEBUG" 3004 "2019-04-27 06:26:12.850" "No messages to index." "DEBUG" 3004 "2019-04-27 06:27:12.789" "No messages to index." "DEBUG" 3004 "2019-04-27 06:28:12.789" "No messages to index." "DEBUG" 3004 "2019-04-27 06:29:12.790" "No message...
by katip
2019-04-26 21:55
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

Dravion wrote:
2019-04-26 20:12
Test again if the Error in your logs persists or something is changing.
no luck :(
by katip
2019-04-26 18:26
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

no good news. all is attached.
log entries 18:00+ are after DEP switch. fyi..
by katip
2019-04-26 16:46
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

1) Open a Windows Elevated Command prompt 2) type in bcdedit /set nx OptOut + ENTER 3) Restart 4) After Restart, goto Windows Panel, Select System and Securty and Select "System" 5) In the System Dialog clock Advanced system settings -> Tab Avanced -> Performance Button "Settings..." 6) Select Data...
by katip
2019-04-26 14:57
Forum: Development & alpha discussions
Topic: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update
Replies: 38
Views: 4055

Re: hMailServer 5.7.0 64-Bit (LTS) - April Release with OpenSSL 1.0.2r update

"ERROR" 3092 "2019-04-26 15:30:02.694" "Severity: 2 (High), Code: HM4208, Source: ExceptionHandler::Run, Description: An error occured while executing 'IOCPQueueWorkerTask'" "ERROR" 3092 "2019-04-26 15:30:02.866" "Severity: 1 (Critical), Code: HM5519, Source: StackLogger::Log, Description: An error...
by katip
2019-04-19 11:24
Forum: Development & alpha discussions
Topic: New hMailServer x 64 MSI Installer
Replies: 26
Views: 5735

Re: New hMailServer x 64 MSI Installer

here one of the dumps attached.
thks.
by katip
2019-04-19 08:29
Forum: Development & alpha discussions
Topic: New hMailServer x 64 MSI Installer
Replies: 26
Views: 5735

Re: New hMailServer x 64 MSI Installer

Hi Dravion, i replaced 5.6.8 b2431 which was running perfectly since +6 months with 5.6.7 b2427. now i get lots of "ERROR" 2520 "2019-04-19 08:14:51.015" "Severity: 2 (High), Code: HM4208, Source: ExceptionHandler::Run, Description: An error occured while executing 'IOCPQueueWorkerTask'" "ERROR" 252...
by katip
2019-04-18 09:56
Forum: General discussions
Topic: Forwarding Question
Replies: 5
Views: 602

Re: Forwarding Question

give it a try then..

here some useful info: https://www.hmailserver.com/documentati ... ails_rules
by katip
2019-04-18 09:39
Forum: General discussions
Topic: Forwarding Question
Replies: 5
Views: 602

Re: Forwarding Question

recipient list already contains all recipients to,cc,bcc. you don't need to add any cc particularly.
but you need to add the criteria AND X-hMailServer-LoopCount < 1

just curious about your setup, do you receive mails which aren't sent to your domain??
by katip
2019-04-18 09:23
Forum: General discussions
Topic: Public IMAP Folder don't show moved messages
Replies: 15
Views: 1721

Re: Public IMAP Folder don't show moved messages

Presumably you changed the PASSWORD in your script and didnt leave it as "<password>"? (Stupid question but even so....) yes sure. copy/paste, just changed the password. it works too without any error on my home setup (Dravion's x64 build + MySQL x64). but on office setup (latest HMS + 32 bit MySQL...
by katip
2019-04-18 05:27
Forum: General discussions
Topic: Public IMAP Folder don't show moved messages
Replies: 15
Views: 1721

Re: Public IMAP Folder don't show moved messages

What does hMailServer log show? Can you post your "hms_maintenance.vbs" code? turned on app log, but it shows nothing. only this: "APPLICATION" 3200 "2019-04-17 20:14:15.591" "Stopping servers..." HMS enters in Pause mode and error message pops up. code is simply copy/paste from the page (except pa...
by katip
2019-04-17 19:52
Forum: General discussions
Topic: Public IMAP Folder don't show moved messages
Replies: 15
Views: 1721

Re: Public IMAP Folder don't show moved messages

i came across to this : https://www.hmailserver.com/documentation/latest/?page=maintenance_scripts i was hoping it might help to fix this issue about messages don't showing up. according to explanation text it should be the right medicine. but it throws an error when it comes to "Call obApp.Utilitie...
by katip
2019-04-14 20:17
Forum: Development & alpha discussions
Topic: hMailServer.Message Object
Replies: 29
Views: 2979

Re: hMailServer.Message Object

jimimaseye wrote:
2019-04-14 19:50
VadaDosa wrote:
2019-04-14 19:21
Can I also see Martin's comments. I guess he is the one who would provide fix for this.
Doubt it. He hasn't been seen since 02/2018. He isn't really active any more.
so what? do we admit HMS is an open relay by design via remote scripting?
and this without leaving a trace? are you serious?
by katip
2019-04-14 19:05
Forum: Development & alpha discussions
Topic: hMailServer.Message Object
Replies: 29
Views: 2979

Re: hMailServer.Message Object

SorenR wrote:
2019-04-14 18:42
What does line 4 in your script say?
Set hm = CreateObject("hMailServer.Message")
by katip
2019-04-14 18:38
Forum: Development & alpha discussions
Topic: hMailServer.Message Object
Replies: 29
Views: 2979

Re: hMailServer.Message Object

With CreateObject("hMailServer.Application", "192.168.0.5") ... also works for me. In hMailAdmin chose Alt+F "Connect" and use what it says in the Host column. yes, sure, i know my servers IP nr. :o Error explanation is clear to me: service does not exist. so true, i have on my PC only hMailAdmin i...
by katip
2019-04-14 15:08
Forum: Development & alpha discussions
Topic: hMailServer.Message Object
Replies: 29
Views: 2979

Re: hMailServer.Message Object

It works from a client also but you need to tell it what server to use. Install hMailAdmin to install COM/DCOM on a client without hMailServer. With CreateObject("hMailServer.Application", "my_hmailserver") dim hm Set hm = CreateObject("hMailServer.Message") hm.From = "Wile E. Coyote" hm.FromAddres...
by katip
2019-04-14 13:54
Forum: Development & alpha discussions
Topic: hMailServer.Message Object
Replies: 29
Views: 2979

Re: hMailServer.Message Object

it came to my attention some time ago when i was trying jimimaseye's email clearup script (delete mails older than x days). after finishing the job it sends a report. this is not logged by SMTP. on server that's a known feature. anyone who is logged on the box can do this among countless other thing...
by katip
2019-04-14 08:06
Forum: Development & alpha discussions
Topic: hMailServer.Message Object
Replies: 29
Views: 2979

Re: hMailServer.Message Object

ok, what was your experience?
have you been able to send a message from your client without authentication?
by katip
2019-04-14 06:58
Forum: Development & alpha discussions
Topic: hMailServer.Message Object
Replies: 29
Views: 2979

Re: hMailServer.Message Object

VadaDosa wrote:
2019-04-14 06:38
All tests were done with hMailServer 5.6.8 - Build 2431 (BETA) on server and mail client on separate desktop machine.
what test have you done on mail client on separate desktop machine?
by katip
2019-04-14 05:51
Forum: General discussions
Topic: Account rule deletes message but not the reference
Replies: 9
Views: 1078

Re: Account rule deletes message but not the reference

SorenR wrote:
2019-04-14 00:08
Hmm... You remember to check for "X-hMailServer-LoopCount Less than 1" in your forwarding rule?
yes, makes no difference.
by katip
2019-04-13 23:06
Forum: General discussions
Topic: Account rule deletes message but not the reference
Replies: 9
Views: 1078

Re: Account rule deletes message but not the reference

wait 10 ninutes or so. it doesn't come right after sending.
by katip
2019-04-13 20:22
Forum: General discussions
Topic: Account rule deletes message but not the reference
Replies: 9
Views: 1078

Re: Account rule deletes message but not the reference

Untitled 1.png
Untitled 1.png (8.1 KiB) Viewed 1038 times
by katip
2019-04-13 20:05
Forum: General discussions
Topic: Account rule deletes message but not the reference
Replies: 9
Views: 1078

Re: Account rule deletes message but not the reference

i did some debug as seen below. scenario: i send one mail to one external address + CC a distribution list where i'm also in it. aim : discard the copy from distrolist to myself, forward it to trash account to be reviewed once again, account rules in my account : account rule #1: if message size > 0...
by katip
2019-04-12 16:16
Forum: General discussions
Topic: Account rule deletes message but not the reference
Replies: 9
Views: 1078

Re: Account rule deletes message but not the reference

both rules are from same account. you're right with global rules. i use also exclusively global rules to sort spam and change headers etc... till last week i was using globals also for redirectings. due to multiple receipts by splitted mails issue i told about before, i changed this policy and dropp...
by katip
2019-04-12 11:25
Forum: General discussions
Topic: Account rule deletes message but not the reference
Replies: 9
Views: 1078

Account rule deletes message but not the reference

account rule #1: if message size > 0 run a function function does some checkings, adds an header according to the result, saves the message and returns. then comes account rule #2: if x-header (which was added by above function) contains "Yes" and loopcount < 1 forward to xyz@domain.com delete messa...
by katip
2019-04-11 19:58
Forum: General discussions
Topic: Public IMAP Folder don't show moved messages
Replies: 15
Views: 1721

Re: Public IMAP Folder don't show moved messages

SorenR wrote:
2019-04-11 18:52
Brother-in-law's ex-wife is turkish. She's got a new husband in UK, but we still get together all of us every few years or so for xmas and birthdays.
that's a good thing. greetings..
by katip
2019-04-11 16:46
Forum: General discussions
Topic: Public IMAP Folder don't show moved messages
Replies: 15
Views: 1721

Re: Public IMAP Folder don't show moved messages

I have similar trouble with some text only messages - they just don't show in a mail client My text messages are all auto generated on remote servers, and I check the message content for specific text. These are logs and I look for words like 'error' in the text, I also check dates of log entries e...
by katip
2019-04-11 16:40
Forum: General discussions
Topic: Public IMAP Folder don't show moved messages
Replies: 15
Views: 1721

Re: Public IMAP Folder don't show moved messages

SorenR wrote:
2019-04-11 16:31
Dene ve başarısız ol ama asla denemede başarısız olma!
war ja am Probieren seit 2 Tagen, hab' die Schnauze voll :D
(couldn't trust Google to translate it in Danish, but your's is perfect!)
by katip
2019-04-11 16:23
Forum: General discussions
Topic: Public IMAP Folder don't show moved messages
Replies: 15
Views: 1721

Re: Public IMAP Folder don't show moved messages

my setup is slightly different. you know my concern about double, triple... receipts. after some scripting as i told before i sorted this out with 100% accuracy. now, in fact i don't need this mails which are marked such as "X-HMS-Discarded" and forward & delete them to a trash account. but just to ...
by katip
2019-04-10 23:02
Forum: General discussions
Topic: Public IMAP Folder don't show moved messages
Replies: 15
Views: 1721

Re: Public IMAP Folder don't show moved messages

disappointing.. literally i cannot get a basic feature in HMS working :o tried everything. deleted folder, recreated again. restarted service, renamed, restarted again etc.. everytime the same result. initially first 2-3 mails appear in client, then nothing more. after a restart, all meanwhile moved...
by katip
2019-04-10 11:06
Forum: General discussions
Topic: Public IMAP Folder don't show moved messages
Replies: 15
Views: 1721

Public IMAP Folder don't show moved messages

Untitled 2.png after so many happy years with HMS it may sound strange but i'm using Public IMAP folder for the first time to move there certain messages by account rules. image shows how it's setup looks like. ("Anyone" has only "Insert" permission, admin "full".) however #public.Discarded folder ...
by katip
2019-04-04 09:06
Forum: Scripting
Topic: Copy oMessage to IMAP Folder
Replies: 16
Views: 1783

Re: Copy oMessage to IMAP Folder

Well... Gave up... Started to poke around my old posts here and found this... You can call it from e.g. OnAcceptMessage but I made an Account rule to call function "CopyMail". It will clone the message, change Message-ID, add recipient and put it back in the queue. Optionally you can add a custom h...
by katip
2019-04-03 19:57
Forum: Scripting
Topic: Copy oMessage to IMAP Folder
Replies: 16
Views: 1783

Re: Copy oMessage to IMAP Folder

Thank you, have a nice evening.
we see tomorrow..
by katip
2019-04-03 18:55
Forum: Scripting
Topic: Copy oMessage to IMAP Folder
Replies: 16
Views: 1783

Re: Copy oMessage to IMAP Folder

Partial success ... It appears to work... The header "Message-ID" is changed and file is read (and removed) from Data directory and the call to oApp.Utilities.ImportMessageFromFileToIMAPFolder() returns "True" ... Only ... I'm having trouble finding the imported message :roll: yes, me too :? 1. doc...
by katip
2019-04-03 15:50
Forum: Scripting
Topic: Copy oMessage to IMAP Folder
Replies: 16
Views: 1783

Re: Copy oMessage to IMAP Folder

IIRC you need to tamper with the header "Message-ID" for hMailServer to accept and index the message... thanks for clever suggestion. yes exactly, that Message-ID thing. i adjusted your code and tried. all runs perfectly. file written to temp dir with correct full name. no any errors at all. but ac...
by katip
2019-04-03 11:45
Forum: Scripting
Topic: Copy oMessage to IMAP Folder
Replies: 16
Views: 1783

Re: Copy oMessage to IMAP Folder

or better i mark it with a header such as "X-HMS-ToBeForwarded = Yes" put a subsequent rule in account which reads this and if Yes forwards to x,y,z no, silly me, then i don't know which of x,y,z or all 3 should get a copy (function knows it!!). setting X-HMS-ToBeForwarded = x,y,z may do the job bu...