Search found 343 matches

by LesD
2012-03-01 22:33
Forum: General discussions
Topic: How to check all lines in header for a string
Replies: 12
Views: 2232

How to check all lines in header for a string

I want to check in a Rule all the header lines for a specific character string.

I can check the Body but there does not seem to be an option to check all headers, just individual types.

Can I create a custom header type for "all" records?
by LesD
2011-12-05 19:10
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

I think your argument is so strong that it begs the question whether there is any need to set up any valid names on the secondary? The 421 reply will just tell the sender to keep trying until the primary comes back on line! :) What is wrong with that logic? I can see just one advantage for accepting...
by LesD
2011-12-05 17:30
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

I accept your arguments that generally mail is sent to the backup server only for short periods of time and therefore the 'retry' route is the most appropriate and safe.

Thanks again for taking the time to explain.
by LesD
2011-12-05 17:24
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

No complaints at all from me! On the contrary, as time goes by and my knowledge of mail servers increases I become more and more impressed with what I can achieve with hMS. These postings are just for the purpose of better understanding the product and just maybe helping to improve it if the resourc...
by LesD
2011-12-05 12:45
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

LesD, Yeah I kind of figured full email address was needed. It is possible the 'default domain' could be used but not sure if that applies to list addresses or not. It is more than just a 'default domain'. In the case of a Route there can only be a single domain in the route so having to enter the ...
by LesD
2011-12-05 12:34
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

Thanks for the detailed response. You have made your case well and I agree that it is better to keep retrying and give the administrator a chance to update the address list when first setting up a system or making alterations. However, I would strongly argue for putting in an option, as you mentione...
by LesD
2011-12-05 00:29
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

I use Hmail to backup 2 primaries. Each primary has approx 50 domains and approx 400 users each. Other than spam we have no problems with it and it works very well . We do have each user name listed in each domain(a pain) but the 2 primaries are in a area that has problems with weather (mostly thun...
by LesD
2011-12-05 00:26
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

Testing Addresses: An address must have the full domain appended as otherwise it generates a 421 error "Recipient not in route list." and the sending hMS then goes into a retry loop. (I would have expected it to be treated as a rejection and not a recoverable error but I do not know what else might ...
by LesD
2011-12-04 23:06
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

OK - found it! The domain in the route was correct but it had a trailing full-stop. It got there because I was trying to make sure that it was spelled exactly right so I did a copy/paste from the actual MX DNS setup record. What forgot was that domains in DNS have a trailing full-stop. And the reaso...
by LesD
2011-12-04 22:39
Forum: General discussions
Topic: Rule: Action: Create and send copy
Replies: 6
Views: 5734

Re: Rule: Action: Create and send copy

Interesting info on it here: http://www.hmailserver.com/forum/viewtopic.php?p=128129#p128129 Funny thing is OP LesD was part of it. lol Snap! I just found that as well. Strange how I forgot all about it :( But 'ta-da!' knew if i searched long enough I'd find some 'official' history on it!: A new ru...
by LesD
2011-12-04 13:05
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

That is because you need to change route delivery retry times on the delivery tab of each Route. ;) http://www.hmailserver.com/documentation/latest/?page=reference_route But I am! I only have one Route and have set up things as follows. <mydomain.co.uk> has a single MX pointing to the backup server...
by LesD
2011-12-04 02:05
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

Problem 2: This may be due to the way I have set up my testing. I have taken a domain I do not use and set the MX record to point to the backup server instead of the primary. The backup server accepts the message. I have set the Route's Target SMTP host to my primary mail server, expecting the backu...
by LesD
2011-12-04 01:27
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

Results of first testing sessions:

Problem 1:

When the backup server cannot deliver to the primary, it reschedules the delivery for 60 minutes.

However, I have changed the retry value to 10 minutes. I have even stopped and restarted hMS but still get the same result.

Running V 5.4
by LesD
2011-12-03 22:11
Forum: General discussions
Topic: Rule: Action: Create and send copy
Replies: 6
Views: 5734

Rule: Action: Create and send copy

I see this option as an action for a rule but it seems to be undocumented.

What does it do?

Just makes a copy and sends both to the recipient?
by LesD
2011-12-02 10:43
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

Thanks for that, most reassuring.

Just on the question of entering user names - do you enter just the names or the full address including the domain?
by LesD
2011-12-01 12:01
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

Yes, I did see that and came to the same conclusion as you but it seemed rather illogical, as a route defines only a single domain so a different domain in the list of addresses would be invalid and there redundant and therefore undesirable.

I just wonder if anyone has used it either way.
by LesD
2011-12-01 11:25
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

I was concerned about spam coming in via the backup but hoped that my 'greylisting' would continue to function. My highest and lowest priority MX records both point to the primary (to stop spammers that go straight for the lowest priority record) and that should stop the spammers. [My main need for ...
by LesD
2011-12-01 01:11
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

OK - I will save the ink :) Indeed, it is a bit monotonous initially but it is really just a one-off. Once it is set up, the occasional maintenance is not an issue. You have got be a bit worried with your comment. Is it the lots of domains that is not common or is it the use of Routes as a backup se...
by LesD
2011-12-01 00:50
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Re: Setting up an MX Backup

Thanks. Is it worth putting in a request for an enhancement?

Really the need for multiple synonym domains on a Route is the same as for a regular mailserver domain.

Not that such a request will help me right now :)
by LesD
2011-12-01 00:27
Forum: General discussions
Topic: Setting up an MX Backup
Replies: 32
Views: 7038

Setting up an MX Backup

I have just got down to trying to set up a client's hMS to act as a backup to my own server. So I followed the docs and went to set up a Route only to discover that a Route has been implemented to cater for just a single domain. While a domain in the main server setup has a Names tab where other dom...
by LesD
2011-11-20 18:07
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Re: Put the Envelope-To address in the header

I think I have got to the bottom of this. You were right in the first place. The Delivered-To: header does show the SMTP recipient. What has confused me is that mail collected via POP3 shows the hMS account instead. This is understandable as the true recipient could be ambiguous. I seem to be gettin...
by LesD
2011-11-20 14:20
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Re: Put the Envelope-To address in the header

I am now rather confused. You wrote originally In the Admin GUI Settings >> Protocols >> SMTP >> Advanced There is a checkbox 'Add Delivered-to header and I replied: "I do have that ticked but it is not what I need. It writes the name of the target mailbox within hMS and not the SMTP envelope addres...
by LesD
2011-11-20 14:14
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Re: Put the Envelope-To address in the header

Thank you - that worked. However, the message ended up with only one "for" header - the last one in the loop. Moving the oMessage.save inside the loop made no difference. It seems that HeaderValue updates a matching header rather than just adding one. Using oMessage.HeaderValue("For" & i-1) = oMessa...
by LesD
2011-11-20 01:27
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Re: Put the Envelope-To address in the header

I have tested receiving a message to two recipients sent from a remote site and get the same results - a single event happens for both recipients. not a problem for me but will be a problem for some who do not want bcc recipients leaking out. From the docs, it describes the OnDeliverMessage event as...
by LesD
2011-11-18 16:32
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Re: Put the Envelope-To address in the header

Thank you - moving along with a bit more testing. What I have discovered so far: 1. The OnAcceptMessage event gets fired a. when receiving mail b. when sending mail c. only once (receiving) when sending mail to a local recipient 2. When receiving mail the Address property is the mailbox address name...
by LesD
2011-11-17 20:29
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Re: Put the Envelope-To address in the header

I have been testing this within OnAcceptMessage by sending a message with two recipients. oMessage.recipients.count then returns a value of 2 as expected. However, executing either of the following temp=oMessage.recipients.item(0) temp=oMessage.recipients.item(1) generates an error Error: 800A01B6 -...
by LesD
2011-11-17 10:57
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Re: Put the Envelope-To address in the header

oMessage.recipients.item(0) is the first recipient found in the SMTP envelope. oMessage.recipients.item(1) is the second recipient found etc... I thought that there could only ever be a single recipient in the SMTP envelope. Reading the docs I am still not clear - need to read more. I do seem to re...
by LesD
2011-11-16 19:35
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Re: Put the Envelope-To address in the header

I have been trying to write a script to create my own header containing the Envelope-To address but having problems with referencing the appropriate property. From the documentation: http://www.hmailserver.com/documentation/latest/?page=com_object_recipient - The Recipient object represents a single...
by LesD
2011-11-16 14:01
Forum: General discussions
Topic: External Accounts: Some mail not being collected.
Replies: 10
Views: 1721

Re: External Accounts: Some mail not being collected.

In 5.3 I am getting

"TCPIP" 3192 "2011-11-16 09:05:08.292" "Connecting to pop3.demon.co.uk..."
"POP3D" 840 109536 "2011-11-16 09:05:08.382" "194.217.242.253" "RECEIVED: +OK demon POP3 server ready (demon.co.uk)"

Can I safely move to 5.4?
by LesD
2011-11-16 13:50
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Re: Put the Envelope-To address in the header

In the Admin GUI Settings >> Protocols >> SMTP >> Advanced There is a checkbox 'Add Delivered-to header I do have that ticked but it is not what I need. It writes the name of the target mailbox within hMS and not the SMTP envelope address. Many mail server seem to include this information as a "for...
by LesD
2011-11-16 12:05
Forum: General discussions
Topic: External Accounts: Some mail not being collected.
Replies: 10
Views: 1721

Re: External Accounts: Some mail not being collected.

mattg wrote:External account fetching will be logged beginning with POP3C.
Actually both POP3 in and POP3 out show up as POP3D
by LesD
2011-11-16 11:35
Forum: General discussions
Topic: Put the Envelope-To address in the header
Replies: 17
Views: 3532

Put the Envelope-To address in the header

One thing that I miss enormously in hMS is not being able to see the To address as it was in the SMTP envelope. It would be great if that could be got into the headers somehow. Also, it would be useful if a date/time stamp would be added to the 'X-hMailServer-ExternalAccount' header to show when hMS...
by LesD
2011-11-16 01:11
Forum: General discussions
Topic: External Accounts: Some mail not being collected.
Replies: 10
Views: 1721

Re: External Accounts: Some mail not being collected.

I do have a catch-all. It is my main account. I have searched my emails for the "X-hMailServer-ExternalAccount" header and only found a few that were several months old. I generally delete most of my mail so it is possible that there are no recent ones but it could be an indication that something ha...
by LesD
2011-11-16 00:25
Forum: General discussions
Topic: External Accounts: Some mail not being collected.
Replies: 10
Views: 1721

Re: External Accounts: Some mail not being collected.

Good news so far. I noticed 2 emails had arrived at the backup server and neither had been received in hMS. So I deleted the External account and set it up again. Both emails then arrived via hMS. That seems to point to something being wrong with my previous setup of the external account. Unfortunat...
by LesD
2011-11-15 15:35
Forum: General discussions
Topic: External Accounts: Some mail not being collected.
Replies: 10
Views: 1721

Re: External Accounts: Some mail not being collected.

Thank you for the suggestions. There a rolling 30 days worth of emails on the backup server so I have purged them as I didn't really want those collected by hMS again. I have also started running my old program that downloads independently from the backup server so I can monitor what is going on. I ...
by LesD
2011-11-14 23:51
Forum: General discussions
Topic: External Accounts: Some mail not being collected.
Replies: 10
Views: 1721

External Accounts: Some mail not being collected.

I urgently need to get to the bottom of what looks like a serious problem for me. I use my ISP's mail service as my backup mail server - my backup MX record points to a host that forwards mail there. I have set up in hMS an External Account that collects, via POP3, all of this mail every 5 minutes. ...
by LesD
2011-11-13 19:50
Forum: Scripting
Topic: Script in a Rule to access the message properties
Replies: 5
Views: 2361

Re: Script in a Rule to access the message properties

Thank you. Is it possible to pass an additional parameter to the function called from a Rule? My function builds an email message to a specific recipient. Rather than hard-coding the address in the function I would prefer it to be in the rule. Is that possible? The docs say: "This function should ta...
by LesD
2011-11-13 15:06
Forum: Scripting
Topic: Script in a Rule to access the message properties
Replies: 5
Views: 2361

Re: Script in a Rule to access the message properties

After hunting some more, it seems that the function called by a rule has the oMessage object as a parameter so I think I can continue from there.

Correct?
by LesD
2011-11-13 01:46
Forum: Scripting
Topic: Script in a Rule to access the message properties
Replies: 5
Views: 2361

Script in a Rule to access the message properties

How do I access the various properties of the message while running a script from a Rule? I am setting up a rule to run a script for a certain type of message. I want to then write out a new email built on the Subject line and the body text. How do I access the subject and body so I can then use the...
by LesD
2011-11-08 18:00
Forum: Feature requests
Topic: Archiving and V 5.4
Replies: 8
Views: 4631

Re: Archiving and V 5.4

Both Outlook and Thunderbird (Ver 7.0 at least does) have an archiving feature that works with both IMAP and POP3, although not necessarily very good with IMAP. I use Thunderbird V7. I have read in the past about ways to Archive but it was not a simple process for a simple user. Do you have a link ...
by LesD
2011-11-06 23:01
Forum: Feature requests
Topic: Archiving and V 5.4
Replies: 8
Views: 4631

Re: Archiving and V 5.4

Thanks for the link. The Archiving described there is not really what I was thinking of. I would like to see some mechanism for archiving old emails out of the normal data folders but still have them available for subsequent access if necessary. I can see that this is not a trivial task but as time ...
by LesD
2011-11-05 22:14
Forum: Feature requests
Topic: Archiving and V 5.4
Replies: 8
Views: 4631

Archiving and V 5.4

I have just seen mention of an Archiving feature in 5.4.

I do not see any documentation as to what is new in 5.4. Where can I read about archiving?
by LesD
2011-08-15 11:02
Forum: General discussions
Topic: Greylisting
Replies: 6
Views: 1580

Re: Greylisting

Thank you for the link. The point I was trying to make is that hMS provides a greylisting feature for the receiving of mail. As such it issues a 541 busy message expecting the sending server to treat that as a polite 'please try again shortly' rather than a failure. Thus hMS subscribes to the concep...
by LesD
2011-08-14 22:28
Forum: General discussions
Topic: Greylisting
Replies: 6
Views: 1580

Re: Greylisting

I agree 100% that greylisting is good. It works for me. I have tried to turn it off and spam increased significantly. So it is here to stay. Nevertheless, I always thought that 'good' mail servers honoured the 451 and went away and came back a bit later to try again. I found with my own hMS that cer...
by LesD
2011-08-14 01:41
Forum: General discussions
Topic: Greylisting
Replies: 6
Views: 1580

Greylisting

I am just setting up a new remote hMS mail server. hMS is sitting behind ASSP which is using Greylisting and sending 451 4.7.1 Busy - Please try again later My initial test emails, sent from my own hMS server are failing to get through as it seems that my own server (hMS) is not honouring the 451 to...
by LesD
2011-08-05 12:25
Forum: General discussions
Topic: libmysql.dll 64 bit?
Replies: 3
Views: 5298

Re: libmysql.dll 64 bit?

Thank you. Working.
by LesD
2011-08-04 17:46
Forum: General discussions
Topic: libmysql.dll 64 bit?
Replies: 3
Views: 5298

libmysql.dll 64 bit?

I am using MySQL on a Windows Server 2008 64 bit and installed the 64 bit version of MySQL.

Can I use an old copy of libmysql.dll 32 bit with hMS (2009)?
by LesD
2011-07-17 14:49
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

Just tried it - before I saw your reply. As you say, it creates a loop, but from my previous tries in the areas of rules, it something I would have expected to happen. Even when you Forward a message via a Global Rule, you have to include in the rule a test to stop looping because the global rule ki...
by LesD
2011-07-17 13:10
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

The action has no parameters so all it can do is send a copy to the original recipient.

I can't see why anyone would want to do that.

I will give it a try.
by LesD
2011-07-17 12:57
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

Just a question.

I have been looking at the Action types for Rules.

There is "Create and send copy" but it is not mentioned in the documentation.

What does this do?
by LesD
2011-07-17 10:52
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

I have been doing a bit more reading in the documentation and I have seen an example giving the size > 0 way to do it so it is probably the most efficient as Martin can test for that without any actual reading of the headers. I will switch to that.

Thank again.
by LesD
2011-07-17 02:03
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

Taking a combination of suggestions I have got the following to work on my own system. 1. Created a new account XxxCC 2. Set up forwarding to the target account - do not keep original Step 2 is not enough as there is still nothing in the headers to test a rule against. 3. In the XxxCC account also s...
by LesD
2011-07-15 19:52
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

I did a quick test on my own server and it seems that Recipient-List does not include the envelope address. I will try mattg's suggestion to use a separate account. That will guarantee that the message ends up there. How do I then get the message moved from that account to an IMAP folder in the inte...
by LesD
2011-07-15 18:56
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

Sorry, I say the mention of 'Recipient List' but its meaning did not register. I see that it is a a predefined heading.

Sounds promising.

The server in question is not accessible remotely at the moment but I will check it out.

Thank you.
by LesD
2011-07-15 18:21
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

I think I am stuck. I cannot see anything in the headers that can identify emails coming from this specific BB phone other than the headers Return-Path: Delivered-To: and both of these do not respond to being tested in rules. The reason you gave seems to be the most likely cause - they do not yet ex...
by LesD
2011-07-15 10:19
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

Sounds logical - though why the 'Received' header test also fails is confusing. If you are right, I have a problem as this is a BCC address so is not mentioned anywhere other than in the Delivered-To line. I will check whether there is anything else in the header that I could use like the origin of ...
by LesD
2011-07-15 00:31
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Re: Account Rule not working

I think I have been able to prove that I cannot get a Custom Header Field to work reliably. Maybe I do not understand what a Custom Header Field actually is. In an email header I have many lines. The line: X-Assp-Delay: not delayed (whitelistdb); 14 Jul 2011 23:20:35 +0100 I can test by specifying '...
by LesD
2011-07-14 23:15
Forum: General discussions
Topic: Account Rule not working
Replies: 23
Views: 6982

Account Rule not working

I have been breaking my head on this one a long time and would appreciate some help. I have been using account rules to move messages into specific IMAP folders, and it has been working fine. But a new rule is not working. I have set up a Blackberry to automatically BCC all outgoing mail to a specif...
by LesD
2011-06-22 20:47
Forum: General discussions
Topic: Unable to access files on server from a VM
Replies: 9
Views: 1841

Re: Unable to access files on server from a VM

Got it! The ini file has the following lines at the start: (I should have posted it before) [Directories] ProgramFolder=C:\Program Files\hMailServer [Directories] ProgramFolder=C:\Program Files\hMailServer DatabaseFolder= DataFolder=\\Server\hMailServer\Data LogFolder=\\Server\hMailServer\Logs TempF...