Search found 8 matches

by bitman
2015-03-04 17:09
Forum: Development & alpha discussions
Topic: SMTP Delivery stops working; Inbound SMTP still working; Queue growing
Replies: 19
Views: 10260

Re: SMTP Delivery stops working; Inbound SMTP still working; Queue growing

Was this 'bug' specific to a particular version? (I am on 5.4.2 and dont see I have experienced this problem) My version is noted in the initial post - hMailServer 5.6.1-B2208 -- Database version 5601 Certainly a bug for me - not sure about any other builds. From the code, it seemed as though the i...
by bitman
2015-03-03 21:41
Forum: Development & alpha discussions
Topic: SMTP Delivery stops working; Inbound SMTP still working; Queue growing
Replies: 19
Views: 10260

Re: SMTP Delivery stops working; Inbound SMTP still working; Queue growing

Just an update on this issue incase anybody else runs into it. After speaking with Martin and providing the necessary information he found a bug. Apparently when the queue is cleared then delivery stops working. Issue and details added to github: https://github.com/hmailserver/hmailserver/issues/86 ...
by bitman
2015-03-03 09:22
Forum: Development & alpha discussions
Topic: SMTP Delivery stops working; Inbound SMTP still working; Queue growing
Replies: 19
Views: 10260

Re: SMTP Delivery stops working; Inbound SMTP still working; Queue growing

Why would the delivery threads just exit all of a sudden? What would trigger that? restarting the server is what I had assumed had caused that. Thats the thing - I wasn't on the server nor did I restart anything when the queue started growing. If you look at the log snipit that I posed around 18:14...
by bitman
2015-03-03 08:52
Forum: Development & alpha discussions
Topic: SMTP Delivery stops working; Inbound SMTP still working; Queue growing
Replies: 19
Views: 10260

Re: SMTP Delivery stops working; Inbound SMTP still working; Queue growing

ALSO, what is in your eventhandlers.vbs? I don't know what Eventhandlers.vbs is. Never changed it so it would be whatever is default with the install. I will get it and post it shortly if you need it. "ERROR" 7416 "2015-03-02 11:49:52.426" "Severity: 2 (High), Code: HM5017, Source: ScriptServer::Lo...
by bitman
2015-03-03 03:42
Forum: Development & alpha discussions
Topic: SMTP Delivery stops working; Inbound SMTP still working; Queue growing
Replies: 19
Views: 10260

Re: SMTP Delivery stops working; Inbound SMTP still working; Queue growing

try increasing your delivery threads... ALSO, what is in your eventhandlers.vbs? Is this mailserver used as a relay or as a spam appliance? DOes it have either of those in front of it? I don't know what Eventhandlers.vbs is. Never changed it so it would be whatever is default with the install. I wi...
by bitman
2015-03-03 03:02
Forum: Development & alpha discussions
Topic: SMTP Delivery stops working; Inbound SMTP still working; Queue growing
Replies: 19
Views: 10260

Re: SMTP Delivery stops working; Inbound SMTP still working; Queue growing

Hello, The issue just happened again and I have much more valuable data. I hope this is enough to troubleshoot. 1) The queue started growing again so I checked out the debug logs (snippit below) 2) I looked at the earliest timestamp in the queue and then scrolled to that timeframe in the log file 3)...
by bitman
2015-03-03 01:24
Forum: Development & alpha discussions
Topic: SMTP Delivery stops working; Inbound SMTP still working; Queue growing
Replies: 19
Views: 10260

Re: SMTP Delivery stops working; Inbound SMTP still working; Queue growing

Hi Matt, thanks for your response. Answers: 1.a) No error logs were created at the time of the error. There was an error log created during service restart, but I suspect thats because we probably interrupted some operation with the reset. The two lines below showed up during the service reset and a...
by bitman
2015-03-02 19:25
Forum: Development & alpha discussions
Topic: SMTP Delivery stops working; Inbound SMTP still working; Queue growing
Replies: 19
Views: 10260

SMTP Delivery stops working; Inbound SMTP still working; Queue growing

Hello We've been testing hMailServer for a few weeks and it was running great so we put it into production and started loading users onto the system last Friday night (Feb 27). Yesterday (March 1) we noticed, by chance, that the queue (Status --> Delivery Queue) was growing. After further testing we...