Search found 124 matches

by reflex84
2020-04-28 15:52
Forum: General discussions
Topic: Spambot pumping out emails blocking my server's IP
Replies: 11
Views: 2235

Re: Spambot pumping out emails blocking my server's IP

Hilton hotel - Cape Town ... Do they still have a sign saying "You are required to check in your guns at the reception desk" coming up from the parking garage ?? Last time I was there I stayed at Villa Via Hotel in a suite facing the waterfront... Fantastic food Haha - is this for real?? Wouldn't b...
by reflex84
2020-04-27 21:10
Forum: General discussions
Topic: Spambot pumping out emails blocking my server's IP
Replies: 11
Views: 2235

Re: Spambot pumping out emails blocking my server's IP

Oh right, thanks for clarifying.
Well SORBS has finally removed my IP from their blacklist and have sent them an email to this thread so they can see my legitimacy. I'm just waiting for automated TRUNCATE to remove my IP... grrrrr - I need to send off important emails FROM my actual address
by reflex84
2020-04-27 20:09
Forum: General discussions
Topic: Spambot pumping out emails blocking my server's IP
Replies: 11
Views: 2235

Re: Spambot pumping out emails blocking my server's IP

Ya, maybe I set an easy password for this particular client and it was cracked. I generally create almost impossible passwords to guess. Sender is using an IP Address belonging to: "rain-197-185-109-83.rain.network" address: Block D address: The Main Straight Office Park address: 392 Main Road addre...
by reflex84
2020-04-27 18:40
Forum: General discussions
Topic: Spambot pumping out emails blocking my server's IP
Replies: 11
Views: 2235

Re: Spambot pumping out emails blocking my server's IP

If you disable the account you won't be able to receive mail for that account too, so that's not desirable, might result in missing mails Yes this is true ... I did instead change the password on HM and on my client's PC - so that's done. Was the spammer using the authenticated accounts (From) e-ma...
by reflex84
2020-04-27 15:13
Forum: General discussions
Topic: Spambot pumping out emails blocking my server's IP
Replies: 11
Views: 2235

Re: Spambot pumping out emails blocking my server's IP

Hi, Thank you for your prompt response! I have added the IP to autoban (see image attached) - As you can see I put no email address after NAME: Auto-ban: AutoBan.JPG You should see the emailaddress of whoever is sending this.. YES!!! This worked! I can see who's account has been targeted! Should I d...
by reflex84
2020-04-27 14:24
Forum: General discussions
Topic: Spambot pumping out emails blocking my server's IP
Replies: 11
Views: 2235

Spambot pumping out emails blocking my server's IP

Hi, This started on the 23rd April, when I was informed by a client who wasn't receiving her own test emails, which prompted me to see if her emails still await in the delivery queue. Low and behold - I see hundreds of spam emails piling up in the delivery queue from "order@unileverprocurement.nl". ...
by reflex84
2017-11-19 19:02
Forum: General discussions
Topic: Receiving reported error (0x800CCC0F)
Replies: 9
Views: 3439

Re: Receiving reported error (0x800CCC0F)

So we changed MAX invalid login attempts for autoban from 2 to 8
by reflex84
2017-11-19 18:59
Forum: General discussions
Topic: Receiving reported error (0x800CCC0F)
Replies: 9
Views: 3439

Re: Receiving reported error (0x800CCC0F)

As to why my client's IP was autobanned in the first place - this kind of remains a mystery - I can only assume that HMS picked up a consecutive failed login / connectivity attempt ... and autobanned it whilst trying to connect the email account ...MEANWHILE all settings were actually correct (and i...
by reflex84
2017-11-19 18:53
Forum: General discussions
Topic: Receiving reported error (0x800CCC0F)
Replies: 9
Views: 3439

Re: Receiving reported error (0x800CCC0F)

Hi, Okay ... it just so happens that it was Autoban... Thanks to my Local IT guy who has been super helpful in the past determine this. I had actually disabled autoban today (by unchecking ENABLE) assuming that all IPs that were autobanned already were going to be unbanned but as my IT guy pointed o...
by reflex84
2017-11-19 17:32
Forum: General discussions
Topic: Receiving reported error (0x800CCC0F)
Replies: 9
Views: 3439

Re: Receiving reported error (0x800CCC0F)

Thanks for your response Jim ... I'm currently dealing with another local IT guy who knows about networking etc (this is all beyond my comprehension as you may know already from the past) ... and is trying to diagnose what could be. FYI: He did a Port Scan on my server with the following results: St...
by reflex84
2017-11-19 12:07
Forum: General discussions
Topic: Receiving reported error (0x800CCC0F)
Replies: 9
Views: 3439

Re: Receiving reported error (0x800CCC0F)

Could Autoban have a role in this by any chance?
I'm just thinking maybe this client's IP has been autobanned by HMS and is causing my client's email account to not connect ... Should I just remove all autobans and ask if my client can send / receive successfully?
by reflex84
2017-11-19 11:43
Forum: General discussions
Topic: Receiving reported error (0x800CCC0F)
Replies: 9
Views: 3439

Receiving reported error (0x800CCC0F)

Hi, Lately I've been hassling with a problem that only a handful clients have been experiencing. I am pretty much stumped as to what is causing the problem ... HMS or my client's ISP / Router / firewall etc... I'd like to eliminate HMS as the cause but I feel it's responsible. My one client cannot g...
by reflex84
2017-06-08 12:33
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

See Image attached below:
https://pasteboard.co/g200mYtsg.png

Clearly I don't have 127.0.0.1 on Port 587.

I think this all goes back to what Matt was saying I should do and change TCP ports to 0.0.0.0
by reflex84
2017-06-08 10:34
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

Why wouldn't it work?... Because you are using PHP Mail. It has a very limited ability to do anything on a good day. In saying that, it SHOULD work if you have set the port to 587 Does hMailserver logs show anything? What about PHP logs or errors? This is the log error entry when I changed SMTP por...
by reflex84
2017-06-08 10:23
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

.Run "timeout /T 5", 0, True
I did this change to 5 seconds and it's still taking 20s or more to process the form
by reflex84
2017-06-08 10:19
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

.Run "timeout /T 5", 0, True
When I look at this code

Code: Select all

"timeout /T 5"
I honestly thought it was commented out (merely notes) because it was greyed out.

Thank you though!
by reflex84
2017-06-08 10:16
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

As mentioned above - I keep seeing emails come and go within the hmailserver\data\ directory.
I took a screenshot:

https://pasteboard.co/fZFZ4Mg7c.png
by reflex84
2017-06-08 10:07
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

mattg wrote:
reflex84 wrote:by using port 587 rather than port you can put back the 20 second delay into port 25, to stop other abuse of your server
In the VBscript ... is there a way to change the 20 second delay to something less like 5 seconds?
by reflex84
2017-06-08 10:05
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

How's your VBScripting skills ?? Pathetic but thanks for the code ... what do I just copy and paste that code into VBscript? Do I need to edit the code somehow for my case? This is code I use specific to kill SnowShoe SPAM servers. After a quick Google on "Snowshoe SPAM servers" ... I don't know if...
by reflex84
2017-06-08 09:49
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

by using port 587 rather than port you can put back the 20 second delay into port 25, to stop other abuse of your server Sorry for late response. I did change Port 25 to 587 in php.ini but all online forms failed to connect via smtp (ie: form stopped working). Why wouldn't it work? Because when I s...
by reflex84
2017-06-04 05:53
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

When I go back and enable VBScript ... the form again takes long to process. Am I configuring the wrong or unused php.ini ... I think the reason goes back to my TCP/IP settings: https://pasteboard.co/el1ATnadd.png I KNOW you've told me to remove change them all to 127.0.0.1 but I'm too scared to do...
by reflex84
2017-06-04 05:44
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

Thanks again for the information! I'm slowly but surely getting to grips with all this. Something about PORTS and IPS that honestly confuse the sh*t out of me. Where can I go to help contribute to your support / organization and donate a bit of funds (it won't be a bitcoin or much because our ZAR cu...
by reflex84
2017-06-04 05:15
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

With that been said ... is it possible to assign only a couple of DNS Blacklist antispam servers to IP Range 'My Computer'?
by reflex84
2017-06-04 05:08
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

If you using IIS webserver you find SMTP in Thanks Tunis for taking the time to elaborate! Much appreciate it! However, I am actually using WAMP Developer Pro and not IIS, which I payed someone else to setup. I honestly didn't want to go down IIS route again (before when I had an old server with go...
by reflex84
2017-06-03 19:00
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

On my old server I got microsoft smtp on port 22 and relayed to hmailserver. And then setup mail in PHP to use port 22. Mail in PHP send email to microsoft smtp with no delay. Microsoft smtp then relay to hmailserver in the background. Thanks bro ... but that doesn't help me at all!! It was like tr...
by reflex84
2017-06-03 15:23
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

if you used this you could submit authenticated on another port, so that no delay + no spam checks As it looks, this would mean replacing my current PHP form ... Very probably. Create an IP RANGE for the single address of your Web form server and untick 'antispam' on it (if you think it is appropri...
by reflex84
2017-06-03 08:18
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

Didn't you introduce a script recently (as advised on this forum) that puts a delay in of 20 seconds or so (to minimise spam attempts)? Jimmy - YOU ABSOLUTE FREAKING LEGEND! This in the VBscript: Sub OnClientConnect(oClient) If (oClient.Port = 25) Then With CreateObject("WScript.Shell") .Run "timeo...
by reflex84
2017-05-31 15:23
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

Re: PHP Online Form taking long to process

This is the log report after approx 30 seconds from hitting the submit button:
https://pasteboard.co/cUDFuPaoU.png
by reflex84
2017-05-31 15:22
Forum: General discussions
Topic: PHP Online Form taking long to process
Replies: 31
Views: 7007

PHP Online Form taking long to process

Hi, First off (after some research online), I take it (presume) Hmailserver is most likely responsible for my current problem. I've got quite a lot of reliable (in terms of spam) online php forms using POST method for users to fill in on various websites of mine but about 6 months ago, I noticed my ...
by reflex84
2017-05-19 07:44
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Another thing I'd like to point out... I see that my one particular client (only this client) is getting spammed badly by the same spambot. Emails from eg: SeniorPeopleMeet@republic.duoht.us Heart-Attack.Fighter@famous.edaeh.us etc etc... and it's been going on for months! Log report example: "SMTPD...
by reflex84
2017-05-19 07:27
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Out of interest, is 197.189.238.154 a man-in-the-middle antispam system, proxy or firewall? Its strange to have these settings but if you say things work as it did then it must be something like that. Once again, I cannot give you an accurate answer to this. However I know the connection to our ser...
by reflex84
2017-05-18 09:50
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Thanks Matt for clearing that up.
I'm always nervous to do these kind of changes, so I will attempt this change during low traffic hours (very early tomorrow morning).
The fact that you have your server IP address there is the problem
Is "the problem" ... meaning?
by reflex84
2017-05-18 08:44
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

TCP IP ports FOR YOU needs to be 0.0.0.0 >> 25 0.0.0.0 >> 110 0.0.0.0 >> 143 0.0.0.0 >> 587 Just to clarify and be 100% sure: 1) I take it 0.0.0.0 must be my server's IP? 2) So in this image https://pasteboard.co/7BLWAJZiI.png ... I must remove 127.0.0.1 / 25 / SMTP ? You need to enable scripts Oka...
by reflex84
2017-05-18 05:45
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Just looking at the TCP/IP Ports:

https://pasteboard.co/7BLWAJZiI.png

Do I need this port?
Whenever I setup an email account, I always use SMTP port 587, so is having port 25 necessary and does keeping this port just give bots another "door" to attack?
by reflex84
2017-05-18 05:02
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Yes. It is EXACTLY that. Unauthorised entry attempts are common for mail servers and what you see is just normal. And it isnt a lot - the amount you have depends on who is attempting the breakin (or rather, WHAT is) and how long you are banning them for. (FYI: viewtopic.php?f=8&t=28199) Fantastic, ...
by reflex84
2017-05-17 18:28
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

As far as I can see in the autoban list, there is one email address that's legit and that is info@elsie******.co.za ( but could that still a spam attack even though it's using a legit email account )?
by reflex84
2017-05-17 18:14
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Looking at the Autobans on Hmailserver ... and after the issue has been "resolved" ... wtf is going on here?: https://pasteboard.co/7q1b2uuvZ.png ?? Not one of those email addresses are legit / real! Is this a big problem or is this Hmailserver doing a good job .. ? Seems like a lot of autobans to m...
by reflex84
2017-05-17 16:36
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Hi Guys, Ok let's hold up for a bit! Everything's working now! This is what I did: 1) As mentioned above, I did a full scan using Superantispyware which came up with these results: https://pasteboard.co/7misyaLIN.png 2) I then downloaded Malwarebytes and also did a scan which came up with 30+ threat...
by reflex84
2017-05-17 14:42
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Why are these delivering to your own server? I have no idea! There is something very wrong. I hope it isn't too serious and my server IP isn't blacklisted. I just did a malware / virus scan using superantispyware on my server and it picked up this: https://pasteboard.co/7misyaLIN.png What RELAY and...
by reflex84
2017-05-17 13:22
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Ok, here's a snippet of todays Log: EARLIER IN THE DAY: "SMTPD" 4608 586970 "2017-05-17 00:00:32.645" "127.0.0.1" "SENT: 220 srv1-jhb.host24hrs.co.za ESMTP" "SMTPC" 4328 586972 "2017-05-17 00:00:32.645" "127.0.0.1" "RECEIVED: 220 srv1-jhb.host24hrs.co.za ESMTP" "SMTPC" 4328 586972 "2017-05-17 00:00:...
by reflex84
2017-05-17 13:17
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

A quick look at your screenshots shows a LOT of attempts to connect and authenticate (with failures). It also shows autobans (from your web server?). If you have such attempts to connect and failing are these from a rogue connection/malware? And therefore is your delivery log full of spam messages ...
by reflex84
2017-05-17 13:07
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

hMailserver Admin GUI >> Utilities >> Diagnostics. Test: Collect server details hMailServer version: hMailServer 5.6-B2145 Database type: MSSQL Compact Test: Test IPv6 IPv6 support is available in operating system. Test: Test outbound port SMTP relayer not in use. Attempting mail.hmailserver.com:25...
by reflex84
2017-05-17 13:01
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Hi Matt,

I've PM'd you the message. I'm not sure if you have received it?
by reflex84
2017-05-17 12:53
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Please see this screenshot of the Log directory of today (17th): https://pasteboard.co/7kBYTB2nj.png What is this Minidump? Here is the ERROR_hmailserver_2017-05-17 records: "ERROR" 3972 "2017-05-17 08:45:51.280" "Severity: 2 (High), Code: HM4208, Source: ExceptionHandler::Run, Description: An error...
by reflex84
2017-05-17 12:29
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

[code]2017-05-17 12:29:28 PM Hmailserver: 5.6-B2145 IP: 127.0.0.1 - 127.0.0.1 Priority: 15 Name: My computer Allow connections Other SMTP: True Antispam : True POP3: True Antivirus: True IMAP: True SSL/TLS: False Allow Deliveries from Require Authentication from Local To Local - True Local To Local...
by reflex84
2017-05-17 12:28
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Todays Log file is Huge (4mb) and I feel like I'd be publishing sensitive information?
Can I just copy a portion of the log file or do need its entirety ?
Is it not best if I PM the file to you instead?
by reflex84
2017-05-17 12:04
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Another Capture of the begging of that 20 second log reports:

https://pasteboard.co/7jKQI5wgn.png
by reflex84
2017-05-17 12:01
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

Logging reports after about 20 seconds:

https://pasteboard.co/7jIE9t05E.png
by reflex84
2017-05-17 10:32
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Re: Emails aren't sending!!!

When I try SEND NOW to my test email under delivery que, it doesn't send the email off!
by reflex84
2017-05-17 10:14
Forum: General discussions
Topic: Emails aren't sending!!!
Replies: 34
Views: 8082

Emails aren't sending!!!

Hi, Hope all the local experts here are well! I had just restarted my server and have picked up and issue (1ST PRIORITY): When viewing under DELIVERY QUE ... There's an entire list of emails that aren't sending + the list is growing as I speak and I am not able to receive my tests emails either (I s...
by reflex84
2017-03-31 07:11
Forum: General discussions
Topic: Forwarding already received emails to the forwarded address
Replies: 6
Views: 1879

Re: Forwarding already received emails to the forwarded address

Then just download and install thunderbird on the server and connect via IMAP remove thunderbird when done Well I simply added my clients email account to my local Email Client (Windows Mail - yup I'm still using Vista), downloaded the emails and forwarded it to the FORWARDED account (and then dele...
by reflex84
2017-03-31 06:22
Forum: General discussions
Topic: Forwarding already received emails to the forwarded address
Replies: 6
Views: 1879

Re: Forwarding already received emails to the forwarded address

@johang Is this assuming my client has an Imap account? Or can this be done even with a POP account? @mattG Once again, you've brought some lateral thinking to the table. I will do that! (I don't have webmail setup on my server along with HMS (used to when I was Godaddy) but decided against a webmai...
by reflex84
2017-03-30 20:02
Forum: General discussions
Topic: Forwarding already received emails to the forwarded address
Replies: 6
Views: 1879

Forwarding already received emails to the forwarded address

I've create an email account on HMS (eg: name@myclient.com) and he hasn't setup his email account on his local email client (like Microsoft Outlook) Whilst he hasn't setup his email account on his local email client (like Microsoft Outlook), I can see he has already received emails (judging by the "...
by reflex84
2017-03-30 04:09
Forum: General discussions
Topic: SPAM in my inbox
Replies: 23
Views: 4853

Re: SPAM in my inbox

Then if you've got some time, go to STATUS > LOGGING and press start and just watch the activity that is reported back live. You'll see how emails are being handled (rejected / approved bla bla).
by reflex84
2017-03-30 04:00
Forum: General discussions
Topic: SPAM in my inbox
Replies: 23
Views: 4853

Re: SPAM in my inbox

I've just been liaising with these guys recently regarding the same issue and now I'm pretty much receiving a couple of spam emails a day! I suggest you read through my thread here: https://www.hmailserver.com/forum/viewtopic.php?f=7&t=31079 Maybe try restarting hMailServer for changes to take effec...
by reflex84
2017-03-29 11:46
Forum: General discussions
Topic: Tightening my Anti-spam settings
Replies: 32
Views: 10157

Re: Tightening my Anti-spam settings

This boggles my mind ... please see this image http://pasteboard.co/57s5T4FNH.png Red strike out = some persons email address (ignore) Blue strike out = this is actually a client who advertises on a website of mine HOWEVER, this client's domain name isn't even hosted on my server (nevermind my emai...
by reflex84
2017-03-29 11:32
Forum: General discussions
Topic: Tightening my Anti-spam settings
Replies: 32
Views: 10157

Re: Tightening my Anti-spam settings

Something I've just observed under LIVE logging ... please see this image: http://pasteboard.co/PciXDGfhK.png Red strike out = My Server / Host Name (ignore) Blue strike out = A personal domain name of mine ... but I have NOT created an email account elsona @mydomain.co.za Looking at that report in ...
by reflex84
2017-03-29 11:18
Forum: General discussions
Topic: Tightening my Anti-spam settings
Replies: 32
Views: 10157

Re: Tightening my Anti-spam settings

Right so Good news... I've had a massive drop in the spam receiving rate (yet to hear from my client if it's the same for her). Woke up this morning and only had 1 spam (at 6.4 score) in junkbox. Usually it's about 10 spam messages first thing in the morning. @jimimaseye Ah sorry. (I looked at my SE...
by reflex84
2017-03-28 20:21
Forum: General discussions
Topic: Tightening my Anti-spam settings
Replies: 32
Views: 10157

Re: Tightening my Anti-spam settings

One more thing thats been on my mind (and this is a deep analysis :lol: - however I might be on the right track regarding the 15mb resending log report): A part of me believes that the PC (or email server but doubt that) of [name]@heidimail.com is infected with malware or a virus ... a malware / vir...
by reflex84
2017-03-28 20:02
Forum: General discussions
Topic: Tightening my Anti-spam settings
Replies: 32
Views: 10157

Re: Tightening my Anti-spam settings

Regarding the "15mb log report" situation. No I am wrong .... my client is DEFINITELY sending to another email account. I asked her to send that person another email again so that I could quickly monitor the report to see if it keeps resending again in the delivery que. So it's myclient@myclient.com...