Search found 231 matches

by tunis
2020-01-23 11:07
Forum: General discussions
Topic: URL send to SURBL
Replies: 2
Views: 38

Re: URL send to SURBL

I checked the email and all links are like this one. href="https://dmd.idg.se/x/c/?LU.RbsMgDPyVvtCnqQ0hbMokq2q3L1gf9jgRQAldDJEDivb1DLLJtnQn_3w6DbLNCB3vmz7PILnseSbgont_EXmCKcZlfT2ft207kR3srLwZHJmTDnhJEb90WmNAJm.bwuT7v.BJtsd9qXBRbvTwaYfBqFGRV6xt7jHo7ynMWHAtVlvcH6kA.1Mv1vhgb4JdO.KBCndlFgojKUQb999rSKQtW...
by tunis
2020-01-23 09:32
Forum: General discussions
Topic: URL send to SURBL
Replies: 2
Views: 38

URL send to SURBL

Hello, I saw that the URL for SURBL lookup sometimes is faulty. Here is an example from my log. "DEBUG" 3168 "2020-01-23 08:09:03.919" "SURBL: Execute" "DEBUG" 3168 "2020-01-23 08:09:03.919" "SURBL: Found URL: webbdagarna.se" "DEBUG" 3168 "2020-01-23 08:09:03.919" "SURBL: Found URL: trippus.se" "DEB...
by tunis
2019-12-17 09:23
Forum: General discussions
Topic: False positive SURBL match
Replies: 19
Views: 806

Re: False positive SURBL match

I has also got false hits with multi.surbl.org.
But no false hit with dbl.spamhaus.org.
by tunis
2019-12-12 17:02
Forum: User contributed hMailServer 5 scripts
Topic: SpamAssassin Bootcamp (sa-learn) train BAYES
Replies: 142
Views: 47397

Re: SpamAssassin Bootcamp (sa-learn) train BAYES

Pop-up is still exist after reverting it back to 0. Are call it with cscript? If you use wscript you get popups. Unfortunately no script. I just normally called it thru windows scheduler. I have no idea how to use cscript. Can you please help me how? Thank you You call it like this in windows sched...
by tunis
2019-12-12 16:06
Forum: User contributed hMailServer 5 scripts
Topic: SpamAssassin Bootcamp (sa-learn) train BAYES
Replies: 142
Views: 47397

Re: SpamAssassin Bootcamp (sa-learn) train BAYES

ashtec014 wrote:
2019-12-12 14:43
palinka wrote:
2019-12-12 13:47
ashtec014 wrote:
2019-12-12 09:16


Hi Palinka, I changed this to

Code: Select all

Const Verbose         = 1
but still I am getting the pop after running the task scheduler.
Should be 0 for no popup.
Pop-up is still exist after reverting it back to 0.
Are call it with cscript?

If you use wscript you get popups.
by tunis
2019-12-05 09:26
Forum: General discussions
Topic: Emails are recognized as SPAM.
Replies: 4
Views: 323

Re: Emails are recognized as SPAM.

Your IP is on a blacklist.
You can check it here: https://mxtoolbox.com/blacklists.aspx
by tunis
2019-11-28 17:59
Forum: General discussions
Topic: getting blank messages without to, from subject and content
Replies: 7
Views: 401

Re: getting blank messages without to, from subject and content

Hi, telnet testsmtp.com 25 ehlo testsmtp.com mail from:shanker@test.com rcpt to:test@testsmtp.com data this test msg to test mail. . quit You are not sending to, from or subject telnet testsmtp.com 25 ehlo testsmtp.com mail from:shanker@test.com rcpt to:test@testsmtp.com data To: test@testsmtp.com ...
by tunis
2019-10-22 11:45
Forum: General discussions
Topic: LOCAL GeoIP Test
Replies: 13
Views: 1368

Re: LOCAL GeoIP Test

I use php with local geoip. https://github.com/maxmind/GeoIP2-php How is performance? Are you using a database or it reads a the flat file every time you connect? Preformence approx 10-15ms/request. (in firefox) I have a centos machine with my webmail and GeoIP installed. As you see in examples on ...
by tunis
2019-10-21 15:47
Forum: General discussions
Topic: LOCAL GeoIP Test
Replies: 13
Views: 1368

Re: LOCAL GeoIP Test

I use php with local geoip. https://github.com/maxmind/GeoIP2-php Use this vbs code ' ### ' ### hMailServer GeoAutoban Code ' ### Function GeoAutoban(oClient) Dim oGeoip Dim sPort : sPort = Trim(Mid("SMTP IMAP SMTPSSUBM IMAPS", InStr("25 143 465 587 993 ", oClient.Port), 5)) On Error Resume Next Wit...
by tunis
2019-09-24 15:46
Forum: Scripting
Topic: RCPT TO multiple commands
Replies: 4
Views: 749

Re: RCPT TO commands when not authenticated

You can disconnect client after too many invalid commands in Settings->Protocols->SMTP->RFC compliance.
Set "Maximum number of invalid commands" to 3 for example.

550 Unknown user is a invalid command and client will be disconnected after 3 tries.
by tunis
2019-09-06 14:45
Forum: General discussions
Topic: Sending mail doesn't work
Replies: 20
Views: 1260

Re: Sending mail doesn't work

qneo wrote:
2019-09-06 11:03
name: mail.almighty.se
data: "v=spf1 a:mailout.telia.com -all"

still goes to junk
spf name must be the same as after @ in email address (almighty.se) not mail.almighty.se.
by tunis
2019-09-06 10:59
Forum: General discussions
Topic: Sending mail doesn't work
Replies: 20
Views: 1260

Re: Sending mail doesn't work

qneo wrote:
2019-09-06 10:45
Like this ?

name:mail.almighty.se, type:TXT, data: "v=spf1 include:mailout.telia.com -all", prio: 0, ttl: 120
mail.telia.com has no spf, so there is nothing to include.

Use a:mailout.telia.com instead of include:mailout.telia.com.
by tunis
2019-09-05 17:03
Forum: General discussions
Topic: Sending mail doesn't work
Replies: 20
Views: 1260

Re: Sending mail doesn't work

What are your "SMTPC" says in the log?
They are your server's outgoing logs.
by tunis
2019-09-03 16:52
Forum: General discussions
Topic: SMTP connection with hubspot failed
Replies: 2
Views: 368

Re: SMTP connection with hubspot failed

I think the auth format is wrong.
You sending "login+login+password".

PS. You should change password now when it has been posted here.
by tunis
2019-08-30 13:27
Forum: General discussions
Topic: DKIM not working
Replies: 2
Views: 440

Re: DKIM not working

It look like you have 2048 dkim and that was not working for me.
I use 1024 dkim now and that works.
by tunis
2019-08-21 09:24
Forum: General discussions
Topic: customer not receive bounce email
Replies: 2
Views: 459

Re: customer not receive bounce email

Check if you allow empty senders (Settings->Protocol->SMTP->RFC compatibility).
Bounce mail often has empty sender.

You can test with bounce mail services like this.
https://www.socketlabs.com/blog/bounce- ... addresses/
by tunis
2019-06-20 14:00
Forum: General discussions
Topic: Email sent to random person as BCC when invalid TO field specified
Replies: 13
Views: 1409

Re: Email sent to random person as BCC when invalid TO field specified

I have test with this script. Set objMsg = CreateObject("CDO.Message") objMsg.Subject = "CDO TEST MESSAGE" & vbTab & Now() objMsg.Sender = "test@test.local" objMsg.To = "test1@test.local; test2@test.local: test3@test.local; test4@test.local;" objMsg.From = "admin@tech.samobler.se" objMsg.TextBody = ...
by tunis
2019-06-13 08:27
Forum: General discussions
Topic: Route for Distribution List
Replies: 6
Views: 1209

Re: Route for Distribution List

I don't use distribution list but you might use global rule.

I have setup a route based on sender.

Criteria
Use AND
From Contains test@domain.com
To Not contains @domain.com

Actions
Send using route NameOfYourRoute
by tunis
2019-06-10 09:10
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

Hmm... HM4403 is used in PersistentMessage::LoadHeader and PersistentMessage::LoadBody ... Both are called from DKIM at different times. Wonder if the error goes away if DKIM check is removed? This is tested and error goes away with wait(20) on. But I what it, so I removed wait(20) instead. So on m...
by tunis
2019-06-04 17:00
Forum: General discussions
Topic: HMAIL to Office365 without IMAP/POP
Replies: 25
Views: 2767

Re: HMAIL to Office365 without IMAP/POP

Dravion wrote:
2019-06-04 15:24
What is a "Mail Contact"?
Maybe only available on exchange.

But what I was meaning was mail users

https://docs.microsoft.com/en-us/exchan ... erver-2019
by tunis
2019-06-04 14:39
Forum: General discussions
Topic: HMAIL to Office365 without IMAP/POP
Replies: 25
Views: 2767

Re: HMAIL to Office365 without IMAP/POP

Can't you add EBSSystemMail@publicdomin.com as a mail contact and then the mail sent to EBSSystemHmail@internaldomain.com after you also setup send connector for internaldomain.com domain point to hmailserver.
by tunis
2019-06-03 15:49
Forum: General discussions
Topic: HMAIL to Office365 without IMAP/POP
Replies: 25
Views: 2767

Re: HMAIL to Office365 without IMAP/POP

mattg wrote:
2019-06-03 14:59
HTTPS is a secure web browse connection to a webmail
Exchange server use HTTPS for clients (activesync).
I manage a exchange and only port 443 and 25 open to internet.
by tunis
2019-05-27 14:24
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

@tunis What do you use to run the VMs? Is this bare metal? Which Hypervisor? This is a server with Hyper-V server 2019 That may well be your problem with taking too long HyperV doesn't pass time very well to the hosted machines. (I've had an error with some older linux drivers for my firewall, and ...
by tunis
2019-05-27 13:57
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

SorenR wrote:
2019-05-24 16:59
Hmm... HM4403 is used in PersistentMessage::LoadHeader and PersistentMessage::LoadBody ...
Both are called from DKIM at different times.

Wonder if the error goes away if DKIM check is removed?
I will test.
by tunis
2019-05-27 13:51
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

mattg wrote:
2019-05-24 16:59
@tunis What do you use to run the VMs? Is this bare metal? Which Hypervisor?
This is a server with Hyper-V server 2019
by tunis
2019-05-24 15:29
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

RvdH wrote:
2019-05-24 15:25
So we can conclude the issue you had was indeed introduced by using the Wait(20) and caused by some incompatibilities with timeout.exe on Server Core?
Time will tell.
Occurred approximately every 100-300 messages.
by tunis
2019-05-24 15:00
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

SorenR wrote:
2019-05-24 14:28
That should work fine. Sort of. My AMD Athlon(tm) II P340 Dual-Core 2.19 GHz doing absolutely Nothing else spikes to 60% CPU for the duration...
I saw that and have change to powershell. Sleep not working on Server Core 2019.

My VM got slow and CPU load at 100%.
by tunis
2019-05-24 13:34
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

I made a new function to test.

Code: Select all

Function Wait(tSec)
    Dim dtWait
    dtWait = DateAdd("s", tSec, Now())
    Do Until (Now() > dtWait)
    Loop
End Function
by tunis
2019-05-24 11:34
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

"DEBUG" 2740 "2019-04-25 14:11:20.142" "Executing event OnSMTPData" "DEBUG" 2740 "2019-04-25 14:12:00.166" "Event completed" that looks more like a 40 sec delay...something else get triggered there? Well observed, I look at this in my logs and see that when an error occur the delay are greater then...
by tunis
2019-05-24 09:00
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

Only I known is it still working with the error and the error is gone when I remove wait(20). Here is a full log off a message revived and forwarded to exchange with wait(20) and a error after SURBL. "TCPIP" 2740 "2019-04-25 14:10:19.382" "TCP - 198.2.177.17 connected to 10.120.0.30:25." "DEBUG" 274...
by tunis
2019-05-23 16:30
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

EDIT: !! Hmm... Could this be the temporary file sent to SA that is not supposed to exist yet ?? Weird, investigation needed! Ruud (RvdH) is playing with "Return-Path" before sending mail to SpamAssassin and that is at that exact place where your HM4403 error occurs. You might want to give him a pi...
by tunis
2019-05-23 13:58
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Re: Code: HM4403

I have solved it. It stops generate this error when I removed "If (oClient.Port = 25) Then Wait(20)" from OnSMTPData. I tried down to just 5 sec but still get error but less. My code I copied from SorenR. Sub OnSMTPData(oClient, oMessage) ' ' Exclude Backup-MX & local LAN from test ' If (Left(oClien...
by tunis
2019-04-26 13:56
Forum: General discussions
Topic: Code: HM4403
Replies: 31
Views: 3358

Code: HM4403

Hello, I have installed a new hMailServer 5.6.8-B2431 with RvdH's 5.6.8-B2437.17 update on new Windows server 2019 core VM. It act only as a relay server and doing it's jobb. But I get this HM4403 errors sometimes. "DEBUG" 2584 "2019-04-25 14:12:00.353" "Spam test: SpamTestSURBL, Score: 0" "ERROR" 2...
by tunis
2019-03-19 18:09
Forum: General discussions
Topic: Sending to Alias returns 550 5.1.1
Replies: 35
Views: 4193

Re: Sending to Alias returns 550 5.1.1

How do you receive mail? !! No SMTP Port 25 defined. Direct external SMTP inbound not possible !! Have you a front end server that sends the error: 550 5.1.1 <support@domain.com>: Recipient address rejected: User unknown in virtual mailbox table Then the aliases must exist on that server to or it mu...
by tunis
2018-12-21 15:18
Forum: User contributed hMailServer 5 scripts
Topic: Check incoming connections with AbuseIPDB
Replies: 44
Views: 12792

Re: Check incoming connections with AbuseIPDB

Should not the database record always be removed if it's banned or old. While Not oRecord.EOF If Not (DateDiff("n", oRecord("timestamp"), Now()) > idsMins) Then If AutoBan(oRecord("ipaddress"), "IDS", 7, "d") Then EventLog.Write( "AutoBan(" & oRecord("ipaddress") & ", IDS, 7, d)" ) End If End If oCo...
by tunis
2018-12-21 12:08
Forum: General discussions
Topic: hMailServer freezes
Replies: 6
Views: 1617

Re: hMailServer freezes

jimimaseye wrote:
2018-12-20 21:09
You sure its not related to a windows update? viewtopic.php?f=7&t=32893&p=207127#p207127 for some lessons.
I have not updated this server for months and I only install recommended updates. (no "Preview" updates)
And it started already in March.
by tunis
2018-12-20 15:26
Forum: General discussions
Topic: hMailServer freezes
Replies: 6
Views: 1617

Re: hMailServer freezes

Now it stop working again.
It seem like it only the ports that freezes (stop working). I can still login with webadmin to hMailserver!
When I try to restart the service it take a long time to stop, then after starting the service it working again.
by tunis
2018-10-30 17:03
Forum: General discussions
Topic: Installation of hmailserver in windows 2008 r2
Replies: 11
Views: 3610

Re: Installation of hmailserver in windows 2008 r2

SMTP is another mail server and both use port 25.
Uninstall SMTP or change port. ex 26 or 2525.
by tunis
2018-10-23 15:53
Forum: General discussions
Topic: Need to block Client Initiated Renegotiation
Replies: 12
Views: 4124

Re: Need to block Client Initiated Renegotiation

Look at this on github.
It seem he using vs2017 for his built.

https://github.com/mologie/hmailserver/ ... tp-xclient
by tunis
2018-10-16 16:32
Forum: Development & alpha discussions
Topic: How to get HmailServer API for C#
Replies: 4
Views: 2530

Re: How to get HmailServer API for C#

tester wrote:
2018-10-16 12:33
what is my username and Password here?
Your admin username and password you login to hMailserver with.
by tunis
2018-09-03 08:57
Forum: General discussions
Topic: Email inbox on mobile phone lost
Replies: 12
Views: 1942

Re: Email inbox on mobile phone lost

ERROR: Full paths are stored in the database.
You should fix the path to email in the database.

viewtopic.php?t=28914
by tunis
2018-08-31 14:52
Forum: General discussions
Topic: URGENT- please help, mail server sending spam
Replies: 86
Views: 9733

Re: URGENT- please help, mail server sending spam

SorenR wrote:
2018-08-31 14:07
\*\.\* ==> No idea ;-)
It was a BOT (*.*).
Maybe not relevant now.
by tunis
2018-08-31 09:17
Forum: General discussions
Topic: URGENT- please help, mail server sending spam
Replies: 86
Views: 9733

Re: URGENT- please help, mail server sending spam

I use OnHELO with one of SorenR scripts. Sub OnHELO(oClient) ' ' Exclude local LAN from test ' If (Left(oClient.IPAddress, 8) = "192.168.") Then Exit Sub If (Left(oClient.IPAddress, 9) = "127.0.0.1") Then Exit Sub strRegEx = "(127\.0\.0\.1|mail\.mydomain\.se|\*\.\*|User|xxx\.xxx\.xxx\.xxx|ylmf-pc|in...
by tunis
2018-08-14 08:35
Forum: General discussions
Topic: hMailServer Administrator COM error 80040111 starting TLS certificate dialog
Replies: 3
Views: 907

Re: hMailServer Administrator COM error 80040111 starting TLS certificate dialog

You could use the API. Add this to vbs file, edit password and cert name and paths. Const sAdminPassword = "PASSWORD" Dim oApp Set oApp = CreateObject("hMailServer.Application") ' Authenticate the client. Call oApp.Authenticate ("Administrator", sAdminPassword) Dim oSSLCertificates Set oSSLCertifica...
by tunis
2018-08-13 15:32
Forum: General discussions
Topic: Tutorials for VPS
Replies: 13
Views: 2399

Re: Tutorials for VPS

carlpicot wrote:
2018-08-13 01:32
I just get this error Matt

https://www.screencast.com/t/b8vNTdkB

Thanks Carl
What database are you using?

Build in one are not working on Windows server 2012 R2.
by tunis
2018-08-13 14:58
Forum: General discussions
Topic: Allowing hmailserver to relay emails from another domain
Replies: 10
Views: 1722

Re: Allowing hmailserver to relay emails from another domain

Don't forget that companyA and companyB most add your mail server in there SPF record if they have any.
by tunis
2018-08-09 11:38
Forum: General discussions
Topic: I can't send externals emails - Remote server closed connection.
Replies: 17
Views: 2136

Re: I can't send externals emails - Remote server closed connection.

Well running a mailserver from a dynamic IP never is a good idea...as this will always be marked as a dynamic sender address and sooner or later will be blocked, eg: spamhaus PBL , Spamrats RATS-Dyna (and RATS-NoPtr in this case) As the first post image shows SMTP relay are in use. Have you double ...
by tunis
2018-07-06 15:49
Forum: General discussions
Topic: SPFs for Multiple domains send through one server
Replies: 1
Views: 468

Re: SPFs for Multiple domains send through one server

Every domain has it's own spf record and they all has to allow mail.com to send.

Code: Select all

cutomer1.com IN TXT "v=spf1 mx -all"
cutomer2.com IN TXT "v=spf1 mx -all"
If mx is set to mail.com, else use a:mail.com or ip4:123.123.123.123
by tunis
2018-07-02 10:09
Forum: User-submitted tutorials
Topic: Windows Firewall - hMailServer Portsettings Howto
Replies: 2
Views: 4228

Re: Windows Firewall - hMailServer Portsettings Howto

I open ports by program.

netsh advfirewall firewall add rule name="hMailServer" dir=in program="c:\pathtohmailserver\bin\hmailserver.exe" action=allow
by tunis
2018-06-21 09:36
Forum: General discussions
Topic: Mails with various age deleted from inbox by accident, how to move back from trash?..
Replies: 24
Views: 3029

Re: Mails with various age deleted from inbox by accident, how to move back from trash?..

The thing to keep in mind is, this is not only related to accidental deletion. If you drag'n drop/move a bunch of mails and they end up in the wrong folder, you have the same problem. You cannot distinguish anymore between what was already in there and what went there accidentally. A failed drag'n ...
by tunis
2018-05-28 16:14
Forum: General discussions
Topic: Can Someone Tell Me More About These.
Replies: 2
Views: 688

Re: Can Someone Tell Me More About These.

I think this is php you have to config to allow lager file size.
Edit these lines in php.ini.

Code: Select all

; Maximum allowed size for uploaded files.
upload_max_filesize = 10M

; Must be greater than or equal to upload_max_filesize
post_max_size = 11M
Then restart your web server.
by tunis
2018-05-28 10:52
Forum: User-submitted tutorials
Topic: HOW TO run Clamwin and have a ClamAV system SERVICE
Replies: 186
Views: 125482

Re: HOW TO run Clamwin and have a ClamAV system SERVICE

Why not use ClamAV 0.100.0? It will work fine with ClamWin 0.99.4 . There have been some fixes with pdf parsing which IMO is pretty important for a mailserver. It not work for me. Copy only clamd.exe, error libclamav.dll is wrong version. Copy over all files clamd --install works but the service ca...
by tunis
2018-05-22 16:41
Forum: General discussions
Topic: connection to the database is not available upon startup
Replies: 7
Views: 1877

Re: connection to the database is not available upon startup

What database?
Built in one does not work on 2012r2.
by tunis
2018-05-04 13:36
Forum: General discussions
Topic: Remote server replied: 554 5.7.1 : Recipient address rejected: not allowed on postfwd configurations
Replies: 9
Views: 3649

Re: Remote server replied: 554 5.7.1 : Recipient address rejected: not allowed on postfwd configurations

Can be that your backup server not in the SPF record your client has and the receiver not see your backup server a allowed senders.
by tunis
2018-04-25 17:06
Forum: General discussions
Topic: Email not sending - unable to telnet to mail.hmailserver.com
Replies: 5
Views: 2878

Re: Email not sending - unable to telnet to mail.hmailserver.com

Probably your ISP has blocked port 25.

If so, you must configure an SMTP relay to send email. Most ISPs have relay service for their customers.
by tunis
2018-04-25 09:15
Forum: General discussions
Topic: Problema: the connection to the database is not available
Replies: 2
Views: 2702

Re: Problema: the connection to the database is not available

Problem is that hMailServer starts before MSSQL.

You have to add MSSQL service under "Dependencies" tab for hMailServer service.
by tunis
2018-04-20 08:28
Forum: Scripting
Topic: Schedule backup
Replies: 5
Views: 2205

Re: Schedule backup

If you updated hMailServer you must enter admin password in startbackup.vbs. This file overwrites on update.

I use cmd for add tasks.

Code: Select all

schtasks /create /ru "SYSTEM" /tn "hMailServer backup" /tr "C:\hMailServer\Addons\Utilities\StartBackup.vbs" /sc daily /st 01:55
by tunis
2018-04-01 16:07
Forum: Off-topic discussions
Topic: 10GB home lab project
Replies: 3
Views: 1954

Re: 10GB home lab project

mattg wrote:
2018-04-01 09:15
Do you have 10GB infrastructure in your home lab?
I have bought some dual 10GB SPF+ card from ebay.
I also have a 16 port SPF+ switch in my home lab.
by tunis
2018-03-30 14:24
Forum: Off-topic discussions
Topic: 10GB home lab project
Replies: 3
Views: 1954

10GB home lab project

Hello, I'm working on a home lab project with 10GB connections to my NAS and hyper-v servers. All servers have dual port 10GB and have think of this setup: Port 1 on all servers for VM use (file sharing on NAS). Port 2 on all servers for iSCSI. The question is which port should I have to management,...
by tunis
2018-03-23 17:55
Forum: Off-topic discussions
Topic: Letsencrypt - Now Wildcard Ready!
Replies: 4
Views: 2251

Re: Letsencrypt - Now Wildcard Ready!

You can only use DNS "TXT" record to verify.
In addition to the ACME v2 requirement, requests for wildcard certificates require the modification of a Domain Name Service "TXT" record to verify control over the domain.