Search found 49 matches

by dieseldon
2017-10-25 20:32
Forum: General discussions
Topic: Global Rule not finding custom header field
Replies: 11
Views: 4065

Re: Global Rule not finding custom header field

the problem is likely that the return-path header is not present at the time of your rule being run. (There is a known issue with this being the case with HMS when it is set to send the email to spamassassin. Ref: https://github.com/hmailserver/hmailserver/issues/116 Should I try adding this as an ...
by dieseldon
2017-10-25 20:06
Forum: General discussions
Topic: Global Rule not finding custom header field
Replies: 11
Views: 4065

Re: Global Rule not finding custom header field

Currently running hMS 5.6.3-B2249 and these messages are coming in from external delivery and the rule is a global rule. The text "QvkrNvsfix" and "tylssj" is found on every email. Before it used to be part of the body, and the url's that were embedded. It's some sort of unique super-cookie I'd gues...
by dieseldon
2017-10-25 18:52
Forum: General discussions
Topic: Global Rule not finding custom header field
Replies: 11
Views: 4065

Re: Global Rule not finding custom header field

Soooo that's what that text box was for! (j/k) Yes I am aware I need to specify the custom header radio button, and manually specify "Return-Path" as the custom header field - and have done so. I also thought the same thing where I thought hMailServer was not finding the "Return-Path" because of dup...
by dieseldon
2017-10-25 15:57
Forum: General discussions
Topic: Global Rule not finding custom header field
Replies: 11
Views: 4065

Global Rule not finding custom header field

Hi there, I have a very regular spammer that I've in the past, blocked via rules because of the way they were formatting text in the body, however, they've gotten wise after that several months, and removed that, however now I'm finding specific text in the the "Return-Path" header field that I woul...
by dieseldon
2015-07-27 19:02
Forum: General discussions
Topic: Backuo and Restore
Replies: 4
Views: 2000

Re: Backuo and Restore

A short answer, yes.
*Provided your email data folder is less than 15GB (Realistically 2GB)
by dieseldon
2014-12-09 19:56
Forum: General discussions
Topic: Sending/receiving mail from 1 hMS domain to another hMS domain
Replies: 5
Views: 2168

Re: Sending/receiving mail from 1 hMS domain to another hMS domain

Dumb question, but your information provided leaves some configuration gaps... You're using the same hMS server for all three domains? If so, do you have your DNS A and MX records configured to be the same as the working domain? Are you sure your relay is configured correctly to accept email for the...
by dieseldon
2014-11-27 02:02
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

Would it be possible to temporarily change this to let Windows manage it to see if that has any effect? I'm not sure if this requires a reboot though so I understand if its not possible. :-\ I've made the requested Virtual Memory Management tweaks to the server, (and fortunately, windows does not r...
by dieseldon
2014-11-26 21:11
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

I can do that; and I'll report back.
by dieseldon
2014-11-26 20:55
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

I know for a fact it is manually configured to have 512MB initial and 512MB max page file size (Simply because this is a VM, and if I need more RAM I can dynamically allocate it ... so I dont want Windows adding to additional disk I/O because the Host OS too has virtual memory mapped)
by dieseldon
2014-11-26 20:40
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

I certainly can do that. One word of circumstance, I did not have debug logging turned on for a part of the of the 25th. as far as memory useage is concerned, I... it varied wildly because if the many server restarts. I know i saw it acting up with around 600MB virtual memory in use; and 75 IMAP con...
by dieseldon
2014-11-26 19:42
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

LOL! No worries; habits die hard. :p
by dieseldon
2014-11-26 19:33
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

I have ;)
Using 5.6. I posted a zip of several .dmp files above
Or are you looking for the debugging log level?
by dieseldon
2014-11-26 19:07
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

No A/V software in use, now or in the past.
by dieseldon
2014-11-26 18:56
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

Tbird has no limits placed on maximum message sizes. (i double checked)

PHP has a post size limit of 512MB due to a customer requirement in accepting multimedia uploads on the web server. But in any case, this is observable when large messages are attempted to be handled by hMail.
by dieseldon
2014-11-26 16:30
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

In my case, I've only have the 40MB email size restriction at the SMTP level. Domain, and account levels are both [all] 0. I'm accessing the server using IMAP, with Tbird 17 ESR and also 29; I'm not sure about a couple clients that reported the issue initially, but I believe they're using iOS email ...
by dieseldon
2014-11-26 06:52
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

Last update:
It seems the messages do not need to be new messages. I'm seeing errors relating to a message in my sent folder from January. This particular message is 18MB.
by dieseldon
2014-11-26 06:13
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

Another update: I needed to attach more than 10MB of files to trigger this error in my scenario. A single image file of 2MB and then a single file of 8MB did not cause this. I sent two JPG's to myself from a google account, and it threw out it's limit of .dmp files; and dropped the message into prob...
by dieseldon
2014-11-26 05:29
Forum: General discussions
Topic: ERROR HM10001 - IMAP FETCH
Replies: 26
Views: 14133

Re: ERROR HM10001 - IMAP FETCH

Not trying to hijack this thread, however I found this thread in an effort to find a solution to this exact situation, where I am running the latest 5.6 production build. My message size limit are set for 40MB, and I can readily produce this error by simply emailing myself a message larger than 12MB...
by dieseldon
2014-09-05 14:17
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

I did not have to edit my my.ini to get it to work. I just had to change the type of the column. I guessing (haven't read the docs) the default-character-set settings only applies to new columns. I may and revert my settings and see what that does; I'm a defaults kind of guy after all :-p If you ch...
by dieseldon
2014-09-05 05:09
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

OK Upgraded to latest hMailserver Beta 5.5-B2074 Using MyPHPWebAdmin I :- - Changed my hMailserver database to default to utf8mb4_general_ci - Made the tables hm_Messages and hm_Message_Meteadata to be utf8mb4_general_ci I'm already on MySQL 5.5.17 Restarted MySQL (and the dependant hMailserver) se...
by dieseldon
2014-09-04 19:09
Forum: General discussions
Topic: Alot of SPAM mails in queue ?
Replies: 8
Views: 2424

Re: Alot of SPAM mails in queue ?

Edit your settings to look like this:
by dieseldon
2014-08-31 16:43
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

I can confirm this works. Having already modified the table collation, I simply compiled hmailserver and replaced the executable and ran an index. Completed with no errors. Replaced the executable with the original, cleared the index cache, and enabled indexing. About 21 minutes later, the server co...
by dieseldon
2014-08-31 05:04
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

I know your pain with upgrading MySQL. Why I haven't upgraded from 5.5.27 yet lol ... I'm waiting to do the server hardware upgrade to upgrade my software. (Also doesn't help I am switching platforms from Win32 to linux) But when I moved to 5.5.27, that's what I did, a mysqldump and import. Just sav...
by dieseldon
2014-08-30 18:33
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

I wonder if it really would be that easy of a fix... for this case scenario. I'm almost temped to fire up V Studio and try to compile the mysqlconnection and test. Now, I'm not arguing your previous statements by any means, but either my understanding is wrong, or well, something... But after lookin...
by dieseldon
2014-08-29 15:15
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

SorenR wrote:
It could be interesting to see your MySQL error log...
That can be arranged :-p ... however, since I'm not in the office all day today, I'll get that setup and done and posted later today. (I don't have mySQL error logging enabled by default)
by dieseldon
2014-08-29 01:47
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

Well reporting in, I adjusted MySQL my.ini file to adjust the collation to utf8mb4_general_ci to make it the default character set, changed the hmailserver database default collation to utf8mb4_general_ci, changed the hm_message_metadada table and the metadata_subject to utf8mb4_general_ci. Restarte...
by dieseldon
2014-08-28 16:56
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

When checking my email I saw the github notification first.. and read your comments there, but posting here for continuity and archival purposes. I am indeed running MySQL 5.5.27; and that you were correct the table collation was utf8_general_ci ... I changed the table collation to utf8mb4_general_c...
by dieseldon
2014-08-10 20:15
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

well done for tracking down the cause. I would post it as an issue at following link and provide a link back to this topic. https://github.com/hmailserver/hmailserver/issues?q=is%3Aopen ..and done. :) Also noted on the bug report page; it seems the unknown UTF-8 characters are being generated on/fr...
by dieseldon
2014-08-10 17:30
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

I see I got everyone worried about a generalized statement of 'nuking' ... what I should have stated was 'clearing with hmail admin' or using the TRUNCATE mysql statement if it came to that, however I was trying to be subtle of my work when I was out to dinner with my other boss :) I have more info,...
by dieseldon
2014-08-09 04:58
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Re: Error HM5158 While Indexing

A quick reply (as i am not at the server right now) and i only have web admin access... I tired a simple disable indexing and reenabling of it and watched the hmailserver log file and this popped up "ERROR" 1188 "2014-08-08 22:53:02.110" "Severity: 2 (High), Code: HM5032, Source: DALConnection::Exec...
by dieseldon
2014-08-08 20:38
Forum: General discussions
Topic: SENT: 502 Unimplemented command and spam issues
Replies: 2
Views: 1661

Re: SENT: 502 Unimplemented command and spam issues

My $0.02 here.. The SPAM results could be your RBL you're using, try adding additional black lists OR verify that the criteria hMail sent to the black query is actually listed.. That's issues I've had in the past is not having the sender listed on every blacklist; thus it passes through. Second, the...
by dieseldon
2014-08-08 17:14
Forum: General discussions
Topic: Error HM5158 While Indexing
Replies: 50
Views: 43928

Error HM5158 While Indexing

Hello all, A several months ago, I noticed in the performance tab not all my messages were indexed. Not thinking much of it, I disregarded this information. Recently, I've gotten several complaints of sluggish performance from the email server, and I watched system loads, etc and didn't find anythin...
by dieseldon
2014-03-31 03:16
Forum: General discussions
Topic: Built in database to MySQL
Replies: 1
Views: 1921

Re: Built in database to MySQL

Oh you just had to ask a short to answer question didn't you?!?! I went through this exact same scenario. First of all, yes you need an SQL server for roundcube.. however hmailserver does not need to be on the same SQL server as roundcube, and the internal compact MSSQL will still work fine. If you ...
by dieseldon
2013-03-28 04:35
Forum: General discussions
Topic: DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)
Replies: 10
Views: 5139

Re: DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)

*Whispers* I don't use MSSQL; and I'm still very much green on SQL in general. Honestly, I've not needed a database server until about a year ago; so I've had very little dealings with them until now.
by dieseldon
2013-03-28 04:23
Forum: General discussions
Topic: DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)
Replies: 10
Views: 5139

Re: DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)

I was also thinking a standard backup and restore (same version) may fix the file path issue, because you can do this to change the data directory, or the database type. I got yah. I tried it quickly, and it did nothing. The issue is that the file is named without the quotes; hMS sees the files and...
by dieseldon
2013-03-27 20:39
Forum: General discussions
Topic: DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)
Replies: 10
Views: 5139

Re: DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)

Howdy. No you should never backup/restore between versions!... That's what I thought; I looked at the script to move from 5320 to 5400 and it didn't look like much had changed to be detrimental; a couple manual entries and I could be set; but as you said, why take a chance. I think he's saying get ...
by dieseldon
2013-03-27 02:26
Forum: General discussions
Topic: DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)
Replies: 10
Views: 5139

Re: DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)

Builtin backup works to some degree in that I can backup, but if I do not select compress messages I run out of disk space, and I cannot save backups to a network drive; however if I choose compress messsages I cannot use the backup zip file created because it is larger than 2GB. That is on the live...
by dieseldon
2013-03-27 00:52
Forum: General discussions
Topic: DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)
Replies: 10
Views: 5139

DB Upgrade from 5.3.3 Internal to 5.4 MySQL Question(s)

Hi all, I believe I have an additional issue I bet no one else has seen... With the version of 5.4 being released, and looking at some of the improvements Bill has done with his latest experimental builds; I began venturing down the proverbial rabbit hole and upgrading my server. First I setup a vir...
by dieseldon
2012-03-20 18:20
Forum: General discussions
Topic: Anti-Spam and SURBL Question
Replies: 9
Views: 3705

Re: Anti-Spam and SURBL Question

*grabs another cup of coffee*
Just goes to show there is always another way to skin a cat. Cannot believe I didn't think of that. Good idea bill!
by dieseldon
2012-03-20 15:25
Forum: General discussions
Topic: Anti-Spam and SURBL Question
Replies: 9
Views: 3705

Re: Anti-Spam and SURBL Question

I thought about that but then I would need to change the subject modification to not append the word spam.. which is a nice fast visual.
I wasn't sure of there was a debug setting hidden away somewhere that could be enabled.
I suppose I should stop asking for my cake and eat it too.
by dieseldon
2012-03-20 14:47
Forum: General discussions
Topic: Anti-Spam and SURBL Question
Replies: 9
Views: 3705

Re: Anti-Spam and SURBL Question

http://maxxlonger.com This is the latest one I've received. I verified it is listed on the SURBL by doing a query and it found it on the "JP, and WS" lists. One behavior I've noted is hMail only puts the spam scores and the reasons only when it has reached the spam threshold. Is there a way for it ...
by dieseldon
2012-03-20 05:43
Forum: General discussions
Topic: Anti-Spam and SURBL Question
Replies: 9
Views: 3705

Re: Anti-Spam and SURBL Question

Making sure the surbl is enabled gave me a chuckle. Yes it is enabled. I triple checked and restarted hmail to ensure it was. There should be nothing whitelisted.. as I haven't added anything. I just tried enabling it last week to try an remove spam that has no subject line with a single link in the...
by dieseldon
2012-03-19 22:47
Forum: General discussions
Topic: Anti-Spam and SURBL Question
Replies: 9
Views: 3705

Anti-Spam and SURBL Question

Hi all; I have been slowly migrating to hMailServer and thus far love it. My only question at this time is it would seem hMail is not using my SURBL settings. I see email come arrive in the log entries, and it shows it was checked by zen.spamhaus.org and passes, however, I still receive messages wit...
by dieseldon
2012-02-09 01:51
Forum: General discussions
Topic: IMAP & TB 1.5.0.10 cannot delete
Replies: 11
Views: 3760

Re: IMAP & TB 1.5.0.10 cannot delete

I know it it doesn't work because it acts wonky and doesn't display correctly and eventually crashes tb 3 I wish I knew more about the underlining programming; but I am just a mere sys admin not a programmer. On a side note other than the rogue error regarding write errors with a couple clients via ...
by dieseldon
2012-02-08 19:17
Forum: General discussions
Topic: IMAP & TB 1.5.0.10 cannot delete
Replies: 11
Views: 3760

Re: IMAP & TB 1.5.0.10 cannot delete

Oh agreed I wouldn't ask for hmail to be altered to fix obsolete compatibility but I needed to be sure it wasn't an configuration issue either with Thunderbird or with hmail.
So it would appear we are going to need to find some new service ticket application. Any recommendations?
by dieseldon
2012-02-08 18:52
Forum: General discussions
Topic: IMAP & TB 1.5.0.10 cannot delete
Replies: 11
Views: 3760

Re: IMAP & TB 1.5.0.10 cannot delete

I almost agree however you cannot empty the trash folder once the messages are in there... Empty trash is greyed out as well.
I suppose a work around would be to purge the trash folder from the server admin, but I feel there should be an answer for this issue somehow.
by dieseldon
2012-02-08 18:14
Forum: General discussions
Topic: IMAP & TB 1.5.0.10 cannot delete
Replies: 11
Views: 3760

Re: IMAP & TB 1.5.0.10 cannot delete

Sorry for not using correct terms... I was simply trying to convey in lame-mans terms.. however I am aware of the IMAP basics, and 'delete' is actually the flag deleted, and expunge, etc... Also it is not a public folder. It is plain Jane email account with the four standard folders of inbox, trash,...
by dieseldon
2012-02-08 15:32
Forum: General discussions
Topic: IMAP & TB 1.5.0.10 cannot delete
Replies: 11
Views: 3760

Re: IMAP & TB 1.5.0.10 cannot delete

^DooM^ thanks for the quick reply! There are two reasons; and both reasons are for a handful of users vs. the masses of the rest of my clients: 1.) A couple of them are older, um, I mean individuals of a certain age, and the newer TB doesn't look like outlook express enough and they are stuck in the...
by dieseldon
2012-02-08 03:23
Forum: General discussions
Topic: IMAP & TB 1.5.0.10 cannot delete
Replies: 11
Views: 3760

IMAP & TB 1.5.0.10 cannot delete

Howdy everyone! Have been reading the forums for some time now; and am currently in the testing / roll-out phase of hMailserver v.5.33-B1879. So far I like it, and if I can solve this issue in one form or another I do believe I will dropping Merak Mail Server. My issue.. I have some older TB clients...