Search found 61 matches

by xydon1
2015-10-22 23:07
Forum: SpamAssassin implementation discussions
Topic: Mail Going To Junk Folder
Replies: 104
Views: 11428

Mail Going To Junk Folder

So I gave up on SpamAssassin as I felt it just wasnt doing the job. I was being bitched at by most people in my company still getting bulk emails and some spam. We are now using a company called Barracuda, they are about 98% effective. However, some email is still going to the Junk folder of some us...
by xydon1
2015-09-14 21:20
Forum: General discussions
Topic: blacklists not working
Replies: 11
Views: 1239

Re: blacklists not working

got it thnx!!!!
by xydon1
2015-09-14 21:11
Forum: General discussions
Topic: blacklists not working
Replies: 11
Views: 1239

Re: blacklists not working

so all I have to do is keep adding arrayAccounts numerically right i.e.

arrayAccounts(4,0)= "@domainname"
arrayAccounts(5,0)= "@domainname"
arrayAccounts(6,0)= "@domainname"

etc etc right?
by xydon1
2015-09-14 21:08
Forum: General discussions
Topic: blacklists not working
Replies: 11
Views: 1239

Re: blacklists not working

yup did all those things, familiar with VB so coding not an issue. I appreciate your help tremendously!!!!!!

your my best friend if this works LOL
by xydon1
2015-09-14 21:01
Forum: General discussions
Topic: blacklists not working
Replies: 11
Views: 1239

Re: blacklists not working

Thanks so much, I have been wanting to implement something like this but never knew it existed!!!! So I followed the steps on the link you gave me, I just appended to the bottom of the EventHandlers.vbs then enabled and saved. Thats all I need to do nothing more except add more to the arrayAccounts ...
by xydon1
2015-09-14 20:37
Forum: General discussions
Topic: blacklists not working
Replies: 11
Views: 1239

Re: blacklists not working

Thank you so much, I was wanting a script like this!!!!!

So can you offer one more bit of information, and that is how to implement with hmailserver please!

Thanks again!
by xydon1
2015-09-14 20:30
Forum: General discussions
Topic: blacklists not working
Replies: 11
Views: 1239

Re: blacklists not working

Apparently I dont know sorry, is there a way you could give a sample script on how to block a specific domain?
by xydon1
2015-09-14 20:22
Forum: General discussions
Topic: blacklists not working
Replies: 11
Views: 1239

blacklists not working

I have the following setup:

DNS Host: anasatsiadate.com
Expected result: 127.0.0.*
Rejection Message: Rejected by [mydomain name]
Score: 5

However, I am still getting emails from the DNS Host. I have SPAM Assassin enabled and still getting tons of SPAM Can anyone explain why?
by xydon1
2015-09-09 17:44
Forum: General discussions
Topic: 2 week old email just received
Replies: 1
Views: 529

2 week old email just received

As the title suggests, a person in my company just received an email that was 2 weeks old. She states that she just cleaned out her inbox and the email appeared.

Anyone have this issue before? She is using IMAP
by xydon1
2015-08-14 18:18
Forum: SpamAssassin implementation discussions
Topic: Plz help SpamAssassin installed, but not filtering SPAM
Replies: 3
Views: 1937

Plz help SpamAssassin installed, but not filtering SPAM

Hi All, I have searched through the forums and found little help regarding my issue, so sorry if this is discussed again. I installed SpamAssassin a while back, have had it working and limited results. We have had an increase in SPAM lately and I have been getting my butt chewed by everyone crying a...
by xydon1
2015-06-22 21:48
Forum: General discussions
Topic: Useradmin and Password Changes not working
Replies: 3
Views: 951

Re: Useradmin and Password Changes not working

Anyways... Next time tell them that you have emailed them their new password... They WILL call you back, guaranteed

That is not the issue!!!!

The issue is, using the builtin user admin does not allow user to use new password. Changing password back to an old pwd does allow login to useradmin.
by xydon1
2015-06-22 19:02
Forum: General discussions
Topic: Help: Server is being abused
Replies: 3
Views: 764

Re: Help: Server is being abused

Just wanted to chime in here on this one. I suspect you arent using SSL with your hmailserver. I had the exact same issue and changing passwords worked. But first verify that your Advanced->IP Ranges->Internet settings are correct. Verify the following: Allow Deliveries from: All checked Require SMT...
by xydon1
2015-06-22 18:54
Forum: General discussions
Topic: Useradmin and Password Changes not working
Replies: 3
Views: 951

Useradmin and Password Changes not working

Hi I searched for anything regarding this but found none. As per the request of one of the senior users on the forum. If I wanted a web based way for users to set Out Of Office, I should use the useradmin web pages and DCOM. I have this working and for the most part it works just fine. I had a coupl...
by xydon1
2015-05-22 22:31
Forum: User-submitted tutorials
Topic: Installing GoDaddy SSL Certificate and Hmailserver
Replies: 4
Views: 4575

Installing GoDaddy SSL Certificate and Hmailserver

yes on Godaddy, but more companies are issuing intermediate certificates as well so I think this is applies to others as well, but this is precise for using GoDaddy
by xydon1
2015-05-22 21:46
Forum: User-submitted tutorials
Topic: Installing GoDaddy SSL Certificate and Hmailserver
Replies: 4
Views: 4575

Re: Pulling My Hair Out Here!!! SSL and Hmailserver

I have resolved this myself, It is way simplier than what you read online! If you have received a regular cert and an intermediate cert all you have to do is open the intermediate cert in notepad and open the root cert in notepad and copy the intermediate cert under the root certs -----END CERTIFICA...
by xydon1
2015-05-22 20:23
Forum: User-submitted tutorials
Topic: Installing GoDaddy SSL Certificate and Hmailserver
Replies: 4
Views: 4575

Installing GoDaddy SSL Certificate and Hmailserver

Hi All, So I have been reading everything under the sun regarding SSL. I have followed so many of the online suggestions but still have issues. I have generated an SSL from GoDaddy. GoDaddy gives the .crt and a gd_bundle which is the intermediate certificate. I have followed the instructions here un...
by xydon1
2015-05-21 23:46
Forum: General discussions
Topic: SSL Installation Issues
Replies: 3
Views: 782

Re: SSL Installation Issues

I tried all files. I obtained the certs from GoDaddy they gave me the following: ad71f048d214dab5.crt gd_bundle-g2-g1.crt I tried both as the Certificate file and the .key as the private key, then verified ports were open for the port I enabled SSL on in Hmailserver Administrator. I then went back t...
by xydon1
2015-05-21 21:37
Forum: General discussions
Topic: SSL Installation Issues
Replies: 3
Views: 782

SSL Installation Issues

So I searched the boards but no luck. So I installed openssl on my win 7 box where I am running hmailserver. I generated the csr just fine. Howerver, GoDaddy gives me a .crt file and a .p7b file extension. Can I use the .p7b file as my key? Or am I supposed to use the .key file I generated when runn...
by xydon1
2015-04-23 22:07
Forum: General discussions
Topic: Email Disappearing
Replies: 7
Views: 1193

Re: Email Disappearing

Well the users are on Mac's which dont run an antivirus software. I do run AVG antivirus software on the mailserver. Think I should temporarily disable to see?

I have set AVG to not scan the hmailserver mail directory however just an FYI
by xydon1
2015-04-23 18:53
Forum: General discussions
Topic: Email Disappearing
Replies: 7
Views: 1193

Email Disappearing

Hi All, Please forgive if this is a post that has already been answered. I have searched the forums and extensively on Google and with no luck. I have a couple users running Outlook 2011 for Mac. They claim every now and then mail will just disappear from a folder. They state they actually watched i...
by xydon1
2015-03-27 21:00
Forum: General discussions
Topic: Simple Question please answer
Replies: 2
Views: 579

Simple Question please answer

I was having issues with SMTP authentication from external applications. I resolved by turning off on my external IP Range I removed "Require SMTP authentication for Local to local e-mail addresses" However, doesnt this allow a malicious individual to use my mail server to send SPAM to people in my ...
by xydon1
2015-03-27 19:51
Forum: General discussions
Topic: 530 Authentication error when Return-Path and To are same.
Replies: 8
Views: 1465

Re: 530 Authentication error when Return-Path and To are same.

Actually, I think I fixed my issue. On the internet IP range I removed "Require SMTP authentication for Local to local e-mail addresses" However, doesnt this allow a malicious individual to use my mail server to send SPAM to people in my domain by setting the from address to an email address on my s...
by xydon1
2015-03-27 19:41
Forum: General discussions
Topic: 530 Authentication error when Return-Path and To are same.
Replies: 8
Views: 1465

Re: 530 Authentication error when Return-Path and To are same.

Here is a screenshot of my Internet IP Range

Did it come through?
by xydon1
2015-03-27 19:26
Forum: General discussions
Topic: 530 Authentication error when Return-Path and To are same.
Replies: 8
Views: 1465

Re: 530 Authentication error when Return-Path and To are same.

Is this third party app on your hmailserver machine? Elsewhere? - 3rd party app is another company and on another server. Is the FROM domain (not return path NOR Reply to, but FROM) hosted on your hmailserver? - they use my email address as the from Is the recipient hosted on your hMailserver? - yes...
by xydon1
2015-03-27 18:15
Forum: General discussions
Topic: 530 Authentication error when Return-Path and To are same.
Replies: 8
Views: 1465

530 Authentication error when Return-Path and To are same.

So I have had hmailserver up and running for quite some time. However we have a 3rd party application using Ruby on Rails that sends email notifications to us and are getting rejected. I am running SPAM Assassin and I have obscurred my email address in red. They state they think my issue is that the...
by xydon1
2015-02-02 21:37
Forum: General discussions
Topic: Any Help Appreciated
Replies: 5
Views: 887

Re: Any Help Appreciated

The only thing repeatedly in the event log is the Bonjour Service erroring. I am not sure why an apple service wants to run. There is no itunes, or anything installed unless hmailserver uses it.
by xydon1
2015-02-02 20:50
Forum: General discussions
Topic: Any Help Appreciated
Replies: 5
Views: 887

Re: Any Help Appreciated

So here is what my log says. Can you shed some light on what this means? "IMAPD" 1476 6237 "2015-01-29 13:24:44.868" "71.15.58.10" "SENT: * 3 EXISTS[nl]* 0 RECENT[nl]* FLAGS (\Deleted \Seen \Draft \Answered \Flagged)[nl]* OK [UIDVALIDITY 1420475800] current uidvalidity[nl]* OK [UIDNEXT 4] next uid[n...
by xydon1
2015-02-02 19:55
Forum: General discussions
Topic: Any Help Appreciated
Replies: 5
Views: 887

Any Help Appreciated

So I had a user tell me that an email disappeared. They new the date, time, and who it was from. I do backups every 30 minutes and found the exact message in the hm_messages table. However, upon scanning the users directory (we use IMAP) I cannot find the .eml file listed in the db. The user swears ...
by xydon1
2015-01-20 20:57
Forum: General discussions
Topic: User Error of attachment size but no message in outbox
Replies: 10
Views: 1117

Re: User Error of attachment size but no message in outbox

Thnx again, much appreciate the clarity.
by xydon1
2015-01-20 20:48
Forum: General discussions
Topic: User Error of attachment size but no message in outbox
Replies: 10
Views: 1117

Re: User Error of attachment size but no message in outbox

Thanks I will try your settings, much appreciated
by xydon1
2015-01-20 20:39
Forum: General discussions
Topic: User Error of attachment size but no message in outbox
Replies: 10
Views: 1117

Re: User Error of attachment size but no message in outbox

under Settings->Protocols->SMTP->Max Message size is 30000

Under domain it is set to 0 (zero)

Max account size is 0 all settings under domain are 0 (zero)
by xydon1
2015-01-20 20:34
Forum: General discussions
Topic: User Error of attachment size but no message in outbox
Replies: 10
Views: 1117

Re: User Error of attachment size but no message in outbox

it was set to 0.

So if I have max message size set to 30 Meg on outbound will that interfere? Should I set both to 30 Meg?

Just to be clear, under Settings->Protocols->SMTP->Max Message size is 30Meg. Under Domain->Limits tab->Max Message size it was 0

Thnx for your assistance.
by xydon1
2015-01-20 20:03
Forum: General discussions
Topic: User Error of attachment size but no message in outbox
Replies: 10
Views: 1117

Re: User Error of attachment size but no message in outbox

Are you saying that there is a setting for inbound SMTP? I have looked at the admin quite extensively but do not see where I set that.

FYI I have max message size set to 30Meg

Also my Domain limits are all 0 so that means there is no limit.
by xydon1
2015-01-20 19:15
Forum: General discussions
Topic: User Error of attachment size but no message in outbox
Replies: 10
Views: 1117

User Error of attachment size but no message in outbox

Hi I tried searching for this with little to no results.

I have a user getting "Message size exceeds fixed maximum message size" but they do not have a message in their outbox. I tried looking in the log files but couldnt find anyhting. How can I help her resolve this?

Thnx!
by xydon1
2015-01-09 21:37
Forum: User contributed hMailServer 5 scripts
Topic: Add Blacklist, server restart?
Replies: 1
Views: 1738

Add Blacklist, server restart?

I am going to write a script for people to add things into the blacklist table of the MySql DB Hmailserver uses.

If I add this in with a PHP script, do I need to restart the server before it goes into affect?
by xydon1
2015-01-08 20:09
Forum: General discussions
Topic: Hmailserver and SpamAssassin
Replies: 4
Views: 1128

Re: Hmailserver and SpamAssassin

For those of you who need help with this. I found this on the web and it worked like a charm: http://life.innove.it/index.php/2010/11 ... a-service/ This is a quick easy way to install spamassassin and get it setup as a service. I also partly used this procedure. http://www.alterprocedure.net/articl...
by xydon1
2015-01-08 19:28
Forum: General discussions
Topic: Hmailserver and SpamAssassin
Replies: 4
Views: 1128

Hmailserver and SpamAssassin

So I have hmailserver installled an configured, as well as spamassassin. However, when I try to test port 783 it says "Unable to connect to the specified SpamAssassin server" I even opened up port 783 to be sure. I have read that SpamAssassin is a service and not really anything you can run. But sur...
by xydon1
2014-09-29 17:47
Forum: General discussions
Topic: IP Ranges and Sendmail
Replies: 5
Views: 1176

Re: IP Ranges and Sendmail

So probably the best thing to do is add another IP Range and set it to the 192.168.1.4 which is my webserver and only allow that IP to send local to local.

Is that a safe guess?
by xydon1
2014-09-29 17:39
Forum: General discussions
Topic: IP Ranges and Sendmail
Replies: 5
Views: 1176

IP Ranges and Sendmail

Hi All, Not sure if this is the best place for this or not but will post any way. I use sendmail on my linux server to send email from my website only. I use hmail server for my email using Outlook and other programs. I have a masquerade setup for sendmail with an account that exists in hmail server...
by xydon1
2014-08-04 19:01
Forum: Scripting
Topic: MySQL hm_accounts accountvacationmessageon
Replies: 12
Views: 5335

Re: MySQL hm_accounts accountvacationmessageon

Thank you for your time sir! your a scollar and a gentleman! :0)
by xydon1
2014-08-04 18:50
Forum: Scripting
Topic: MySQL hm_accounts accountvacationmessageon
Replies: 12
Views: 5335

Re: MySQL hm_accounts accountvacationmessageon

What I wanted was to use roundcube for the gui version of their email. I got the PHPWebMail to work with the COM but it requires a seperate login, make sense? I am working on with JQuery to login both directory login forms but if there is a way to do it with PHPWebMail I would prefer it. and I fully...
by xydon1
2014-08-04 18:36
Forum: Scripting
Topic: MySQL hm_accounts accountvacationmessageon
Replies: 12
Views: 5335

Re: MySQL hm_accounts accountvacationmessageon

Is it possible to do an automatic login with PHPWebAdmin? it would be frustrating to have my users login twice.
by xydon1
2014-08-02 00:30
Forum: Scripting
Topic: MySQL hm_accounts accountvacationmessageon
Replies: 12
Views: 5335

Re: MySQL hm_accounts accountvacationmessageon

So how does a end user update their out of office auto reply?
by xydon1
2014-08-02 00:06
Forum: Scripting
Topic: MySQL hm_accounts accountvacationmessageon
Replies: 12
Views: 5335

Re: MySQL hm_accounts accountvacationmessageon

how do you call refresh cache with php and the COM?

By the way, I used my script, restarted the server and no joy!
by xydon1
2014-08-01 23:42
Forum: Scripting
Topic: MySQL hm_accounts accountvacationmessageon
Replies: 12
Views: 5335

MySQL hm_accounts accountvacationmessageon

So I wrote a small script to enable and update the mysql table using PHP. However, when I enable it, my auto reply does not work. Only from the hmailserver interface will it work. My past experience is it must have something to do with a COM call. Is this right? Can I not simply update the hm_accoun...
by xydon1
2011-07-27 21:56
Forum: Scripting
Topic: COM API Create New Folder
Replies: 5
Views: 2871

Re: COM API Create New Folder

Ok i think i understand, so all i need to create a folder is the .add("folderName") at the end to create a folder for the specified account. However is there an attribute for subscribed? I will take a crack at this and post my code if i have problems. Also how come just adding a record in the table ...
by xydon1
2011-07-27 05:22
Forum: Scripting
Topic: COM API Create New Folder
Replies: 5
Views: 2871

Re: COM API Create New Folder

I appreciate the reply however the documentation link u sent me doesnt give any examples regarding the COM API You mentioned domain.account.imapfolders.add() can u give an example as to how to create the folder "Trash" and how to create it under the correct user. Any assistance or sample script woul...
by xydon1
2011-07-26 20:44
Forum: Scripting
Topic: COM API Create New Folder
Replies: 5
Views: 2871

COM API Create New Folder

Does anyone know how to create new folders via the COM API? Here is what i have got going on. I have scripted out the automatic creation of a new account via a .vbs script. Seems to work fine however when I create the account it only creates the "INBOX" record in the hm_imapfolders table. I have man...
by xydon1
2011-07-25 22:31
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

Actually in Outlook the new password I believe is cached until you restart Outlook. What I did is copied the new password to the hm_accounts Then did send and receive the password prompt did not come up. I then closed outlook and then re-opened and then I was prompted for new password I just updated...
by xydon1
2011-07-25 22:03
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

I notice that the password does not take affect unless I restart the server from the Status section of hmailserver. Is there a way to refresh the server to make the password affective immediatly? It does work with the php script generator but not on my client till I restart the server.
by xydon1
2011-07-25 21:52
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

Oh My God!!!!!! You rock!!! your definitly on my Christmas list!!!!!!!
by xydon1
2011-07-25 17:08
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

I would be willing to work with you on your price. Please this is essential for my company I am starting.

Can we talk on the phone to negotiate?

720.524.4487
by xydon1
2011-07-25 16:50
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

Thanks Bill,

However I feel this is over my head :( would you be interested in a small side project that may take you an hour or so? I would be willing to pay you for your troubles.
by xydon1
2011-07-23 02:26
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

I understand you are calling an object with the code right?, I just dont know how you are instantiating any of the objects? I installed phpWebAdmin on my site, so is there a way I can call the set $obAccount->Password = "$accountpassword"; via /var/www/html/phpWebAdmin/the file or include this in my...
by xydon1
2011-07-23 01:52
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

Great how do call the com api to change a users password for hmailserver

This should soooooo not be this hard!!!
by xydon1
2011-07-23 00:46
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

This is just rediculous :( I did exactly what you stated, and the encryption is still being forced to use the salt method. I just do not know what to do. If I could get php to use the salt method I would simply update the db with it. Let me explain what I am trying to do: I have a user creation form...
by xydon1
2011-07-22 23:41
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

Ok, I must be missing something! You are telling me that if my settings are the following: PreferredHashAlgorithm=2 and the accountpwencryption is set to 2 That I will be using the md5 encryption method? This cant be true because the encryption string still looks like the salt method and when I chan...
by xydon1
2011-07-22 22:45
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

Re: hMailServer.INI and MD5 Encryption Please Help 911

yes I went into the services and stopped and restarted the server. The thing which puzzles me is take password of 123456789 the following is the two encryptions 4123ec930f96f8f535fd4f254600893d403fdae199b2632ac2e2d8b8511afc27c8785f //from the admin panel of hmail server 25f9e794323b453885f5181f1b624...
by xydon1
2011-07-22 20:32
Forum: General discussions
Topic: hMailServer.INI and MD5 Encryption Please Help 911
Replies: 24
Views: 9470

hMailServer.INI and MD5 Encryption Please Help 911

First if I have repeated a post my apologies, so be gentle :) I am running a PHP website and have my own login encryption to my site. I have read numerous threads regarding the hMailServer.INI configuration in the documentation and cannot seem to get this to work. According to the documentation I se...