Search found 18 matches

by rickyrick
2014-10-08 09:38
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

when you have it installed in mysql could you try running above script in mode 0. It would be useful to know how much faster it runs on a real database. Only need to let it run for a couple a couple of thousand rows to get a rough idea. I suspect it will be a lot faster. Hi, migration to mysql went...
by rickyrick
2014-10-07 15:58
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

percepts wrote:when you have it installed in mysql could you try running above script in mode 0. It would be useful to know how much faster it runs on a real database. Only need to let it run for a couple a couple of thousand rows to get a rough idea.
I suspect it will be a lot faster.
Will do.
by rickyrick
2014-10-07 09:56
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

Good thinking. Its much slower than I expected but I thought it wouldn't be quick. Where's it upto now ? If it does find only a handful of missing files (if any), then it will be a lot quicker to remove them manually rather than running in mode 1. Its upto 15000, overnight it found a batch of entri...
by rickyrick
2014-10-07 08:22
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

Good thinking. Its much slower than I expected but I thought it wouldn't be quick. Where's it upto now ? If it does find only a handful of missing files (if any), then it will be a lot quicker to remove them manually rather than running in mode 1. Its upto 15000, overnight it found a batch of entri...
by rickyrick
2014-10-07 08:12
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

percepts wrote:how many users do you have on your setup for all domains ?

Just two users and one domain.
by rickyrick
2014-10-06 23:23
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

I thought about putting a count out for every 1000 mails processed but didn't think it would take so long that it needed one. So I'm curious to know how you know how many rows have been processed so far ? It only outputs missing file paths when they are not found in data folder. It seemed to be tak...
by rickyrick
2014-10-06 21:44
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

Note: following lines in above script are redundant and you can safely remove them (I didn't need them and forgot to take them out). Dim User User = split(oApp.Domains.item(oDomain).Accounts.item(oAccount).address, "@") Thanks so much for this, I'll run it as soon as I get back home and let you kno...
by rickyrick
2014-10-06 10:17
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

Note: following lines in above script are redundant and you can safely remove them (I didn't need them and forgot to take them out). Dim User User = split(oApp.Domains.item(oDomain).Accounts.item(oAccount).address, "@") Thanks so much for this, I'll run it as soon as I get back home and let you kno...
by rickyrick
2014-10-05 22:06
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

percepts wrote:I wouldn't know how to modify for MS SQL CE since I never used it.

do you have PHP on your system ?

and how many rows do you have in hm_messages ?
Yes I have PHP on my server. I have just under 22000 rows in the hm_messages table.
by rickyrick
2014-10-05 21:04
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

percepts wrote:can you post a link to the forum post of the script you found
Here you go : viewtopic.php?f=14&t=19341

It looks to be written for MySQL and wold need converting to MS SQL CE, also might need tweaking as the paths arent in the db anymore.

Thanks

Richard
by rickyrick
2014-10-05 20:33
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

I don't understand why DDS has not fixed the problem, that is what its designed to do. can you run it again making sure you select option to remove records in DB which aren't in data folder (no eml file). select all domains. edit: Just looking at DDS it doesn't seem to have an option for what I sug...
by rickyrick
2014-10-05 17:00
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

check where your hmailserver.ini is saying that your data folder is. If you were storing your data folder somewhere other than hmailserver/data and somehow your ini file has changed back to using hmailserver/data this could happen. I checked and it's pointing to the correct place. I looked at the. ...
by rickyrick
2014-10-05 16:35
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

AND you should not be deleting anything directly from DB. use the Data Directory Synchroniser ( DDS) tool in your addons folder for this purpose. Thanks, cleared and refreshed the message index. Restarted the service too, still same error. I ran the DDS tool but it didn't seem to remove db entries ...
by rickyrick
2014-10-05 13:45
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Re: Backup failing with msg : All messages not in data folde

mattg wrote:Check the message paths in that table
Sort them alphabetically, and reverse alphabetically and look for a path that is different
Thanks, I've checked every entry and none have paths, just filenames stating with a { and all of the files seem to be in the data folder.
by rickyrick
2014-10-05 11:42
Forum: Development & alpha discussions
Topic: Backup failing with msg : All messages not in data folder
Replies: 30
Views: 7620

Backup failing with msg : All messages not in data folder

Somehow my data folder/ms sql ce database got slightly out of sync and I had a few entries in the hmailserver db (hm_messages) that didnt exist in the data folder. I've removed these from the database and now all entries have a corresponding .eml file however when I try a backup I still get the mess...
by rickyrick
2014-10-05 11:34
Forum: Development & alpha discussions
Topic: Certificate issue when sending and receiving email on 5.5
Replies: 29
Views: 13206

Re: Certificate issue when sending and receiving email on 5.

Hi

I've installed the latest build 2103, and the btinernet.com cert is now working. Thanks :-)

"Certificate verification succeeded for session 8."

Richard
by rickyrick
2014-09-28 00:40
Forum: Development & alpha discussions
Topic: Certificate issue when sending and receiving email on 5.5
Replies: 29
Views: 13206

Re: Certificate issue when sending and receiving email on 5.

The certificate validation is new to 5.5 This should only be an issue because the certificate used by your ISP isn't setup correctly. Contact your ISP. Thanks for the quick reply. Is there anyway to have an option in the ini file to disable this verification? I only ask as one of my email address h...
by rickyrick
2014-09-27 23:06
Forum: Development & alpha discussions
Topic: Certificate issue when sending and receiving email on 5.5
Replies: 29
Views: 13206

Certificate issue when sending and receiving email on 5.5

I have just moved from 5.4 to 5.5 (before the 5.5 went back to beta), and when I am trying to send emails (via encrypted SMTP) and receive emails from external accounts (via encrypted POP) I am getting the following error : Verify certificate: True, Expected remote host name: mail.btinternet.com Cer...