Search found 71 matches

by rattenfanger
2006-08-22 19:29
Forum: Development & alpha discussions
Topic: plus addressing
Replies: 9
Views: 7466

Another question about plus adressing, why can't I specify my own character? Is it because many people for example use the _ character in their mail adresses? I want to use the _ ;) lol it wouldn't be called plus addressing then :P Underscore addressing doesn't have the same ring to it :D Haha that...
by rattenfanger
2006-08-18 02:06
Forum: Development & alpha discussions
Topic: plus addressing
Replies: 9
Views: 7466

Another question about plus adressing, why can't I specify my own character? Is it because many people for example use the _ character in their mail adresses? I want to use the _ ;)
by rattenfanger
2006-04-11 08:50
Forum: General discussions
Topic: question: Mailing With PHP Does Not Send
Replies: 10
Views: 5364

actually on the sendmail_from you can use any string that complies with RFC 2822. Also.. if I do remove the name, some services will not accept the emails from my server. Yes Admin@aljo.afraid.org is a local account. Aljo.afraid.org is my server. If I'm right the sendmail_from setting will only be ...
by rattenfanger
2006-04-10 19:35
Forum: General discussions
Topic: question: Mailing With PHP Does Not Send
Replies: 10
Views: 5364

Is admin@aljo.afraid.org a local account? So if I send mail to admin@aljo.afraid.org will it be handeled by your hMailServer?
by rattenfanger
2006-04-10 14:41
Forum: General discussions
Topic: question: Mailing With PHP Does Not Send
Replies: 10
Views: 5364

Turning on "External accounts to External accounts" for the entire server is a serious security risk. Your server can be used as relayer bij spammers. If you only enabled it for local connections its safe. You can let the setting disabled and change the "sendmail_from" setting in the php.ini to a lo...
by rattenfanger
2006-03-28 20:36
Forum: Development & alpha discussions
Topic: 4.2.1 b197 - IMAP stopped working
Replies: 4
Views: 3316

Then its very strange... I'm sure I didn't open the hMailServer admin interface...

Fuck it, it works now ;) I'm sure its not reproducable...

Thanks for your time ;)
by rattenfanger
2006-03-28 17:19
Forum: Archived feature requests
Topic: Alias field in user account settings
Replies: 5
Views: 4387

The way you describe it it would be very confusing I think..
by rattenfanger
2006-03-28 17:15
Forum: Development & alpha discussions
Topic: 4.2.1 b197 - IMAP stopped working
Replies: 4
Views: 3316

Oooh stupid me! I totally overlooked that setting! Thats very embarrassing :P

I checked all settings... Except at protocols..
Now it works fine again!

The point is now that I'm sure I didn't change it with the upgrade. Is it possible it corrupted it in some way?
by rattenfanger
2006-03-28 14:51
Forum: Archived feature requests
Topic: Alias field in user account settings
Replies: 5
Views: 4387

Why do you need this? You can add aliasses at domain level. Do you just want to have a shortcut for this?
by rattenfanger
2006-03-28 11:45
Forum: Archived feature requests
Topic: Feature Request: Only allow SMTP authentication from...
Replies: 8
Views: 6083

It would still use authentication. The whole idea is to add another layer of security against people handing out their username and password. So along with authentication, the senders address must also be on a trusted list. I do realize people could change their email (in say Outlook or something),...
by rattenfanger
2006-03-28 11:26
Forum: Development & alpha discussions
Topic: 4.2.1 b197 - IMAP stopped working
Replies: 4
Views: 3316

4.2.1 b197 - IMAP stopped working

I just upgraded from build 179 to build 197. Before the upgrade everything was fine. Everything worked including IMAP on port 143. After the upgrade SMTP and POP3 worked fine, but IMAP didn't! I restarted the server machine and looked again. Nothing. Telnetting to port 143 on the server didn't work....
by rattenfanger
2006-03-06 11:07
Forum: Off-topic discussions
Topic: Access home computer from school?
Replies: 17
Views: 17168

I cannot use SSH because, as far as I know, I can only use the HTTP protocol. I'm guessing this because I can connect to HTTP on any port. But, for thngs like FTP, the connection is opened and then closed. If the connection is opened port 21 is allowed. If it was blocked it can't connect in the fir...
by rattenfanger
2006-01-31 15:37
Forum: Development & alpha discussions
Topic: hMailServer 4.3...
Replies: 30
Views: 22537

Sounds very good!
I'm looking forward to it!
by rattenfanger
2006-01-29 14:58
Forum: Off-topic discussions
Topic: Build in the IssueTracker
Replies: 3
Views: 3452

Wow! Yeah! You made that incredible fast! Nice work :)
by rattenfanger
2006-01-29 14:23
Forum: Off-topic discussions
Topic: Build in the IssueTracker
Replies: 3
Views: 3452

Build in the IssueTracker

I think it would be usefull if you can specific a build in which a bug was found. I think just the version is not enought.

Also a thing when its fixed would be nice.. And not just as comments as u did last time..
by rattenfanger
2006-01-29 14:21
Forum: Off-topic discussions
Topic: Mirror
Replies: 6
Views: 6019

I think only stable releases have to be mirrored.. You can send every mirror a mail with the question to update their mirror. Not much work I think :)

If you want I can mirror you..
by rattenfanger
2006-01-24 18:04
Forum: General discussions
Topic: HOWTO: Use ASSP with hMailServer
Replies: 204
Views: 301799

I had ASSP for one day running with Activestate Perl 5.8.7.815 without crashing. RBL was not enabled at that time. After enabling it it kept on crashing! For using RBL with ASSP I had to install Net::DNS with the package manager (install Net::DNS). So I used an official package... It look likes the ...
by rattenfanger
2006-01-24 14:30
Forum: General discussions
Topic: HOWTO: Use ASSP with hMailServer
Replies: 204
Views: 301799

In test mode (and in non test mode): Spam mails are placed under ASSP>SPAM NonSpam mails are placed under ASSP>NOSPAM The only diference is that in non test mode spam is blocked reducing CPU processing time and internet bandwith (as it is able to quit an SMTP conversation in some cases). I thought ...
by rattenfanger
2006-01-24 11:50
Forum: General discussions
Topic: HOWTO: Use ASSP with hMailServer
Replies: 204
Views: 301799

Yeah I think it will work very nice soon ;) Training is a fucked up work!! But you have testmode on all the time? If you do that all the mail is always put in ASSP's spam folder. So if you want to rebuild the spamdatabase (because users gave feedback which is placed in the ASSP errors folders) you a...
by rattenfanger
2006-01-24 02:06
Forum: General discussions
Topic: HOWTO: Use ASSP with hMailServer
Replies: 204
Views: 301799

I think I just succesfully set up ASSP with hMailServer! Thanks!!! Just one question.. I'm I right that if I let testmode enabled ALL mail get send to hMailServer and hMailServer can look at the header if it is spam or not and move it to the Spam folder? I think that that is the case.. Just a questi...
by rattenfanger
2006-01-21 21:40
Forum: Archived feature requests
Topic: Modify headers option for built-in Anti-Spam features
Replies: 7
Views: 7516

Yeah this would be a really nice feature!!!!
I also want to move my spam rather dan reject it :)

I don't think its much work; do you Martin?
by rattenfanger
2006-01-20 17:48
Forum: Development & alpha discussions
Topic: Awstats Logfile
Replies: 14
Views: 12777

Do you have the tab (\t) as log seperator? That changed some versions ago..
by rattenfanger
2005-12-28 21:46
Forum: Development & alpha discussions
Topic: MySQL server has gone away
Replies: 4
Views: 3507

I saw you put up a new build (184) with a fix which can be related to my problem. Do you think this will help? Or haven't you looked at the logs at this time? (It doensn't matter if you have not, just a question:)) The point is that my server was gone for some time. Not exact at the time the message...
by rattenfanger
2005-12-28 15:19
Forum: Development & alpha discussions
Topic: MySQL server has gone away
Replies: 4
Views: 3507

Log send :) I didn't saw any 550 error at the time the MySQL server was down..
by rattenfanger
2005-12-23 13:19
Forum: Development & alpha discussions
Topic: MySQL server has gone away
Replies: 4
Views: 3507

MySQL server has gone away

For about a week my MySQL server has problems. Sometimes it crashes and I don't no why. Can't find errors in the log and nothing strange happend.. Nothing to do with hMailServer I think. But when the MySQL server is crashed, hMailServer tries to reconnect but is accepting messages! The messages can'...
by rattenfanger
2005-12-06 19:10
Forum: Archived feature requests
Topic: "On the fly" email alias creation
Replies: 27
Views: 24571

I think people have to create an alias himself and then use wildcards. Then all messages matching the wildcard have to be send to the corresponding adress. Example: I create an alias rene*@alias.nl wich is an alias for rene@test.nl. So messages sent to rene@alias.nl will me sent to rene@test.nl. But...
by rattenfanger
2005-12-06 18:54
Forum: Archived feature requests
Topic: Global catch-all address
Replies: 5
Views: 5092

I think it would be a obscure feature... And too much features is not good! You cant see the the wood though the trees ;)

A possible solution is to write a database query or a script doing the job
by rattenfanger
2005-12-06 18:51
Forum: Development & alpha discussions
Topic: Creating a PHP Webmail Client designed for hMailserver
Replies: 9
Views: 7196

The building will be a night job, so if anyone could participate with knowledge about php/mysql and or php/msaccess. that would be great. I suggest you to use AdoDB to do the database access so it can run on all databases! Futher smarty is a good way to make it good skinnable and to keep the code a...
by rattenfanger
2005-11-09 23:58
Forum: Development & alpha discussions
Topic: hMailServer 4.2 - Build 170 (Alpha)
Replies: 3
Views: 3317

Just wondering why you are bundling MySQL 4.0 instead of 4.1. That version has been stable for a long time now..
by rattenfanger
2005-11-01 11:13
Forum: Development & alpha discussions
Topic: Beta?
Replies: 7
Views: 6357

Same here. I think it can be marked as a beta! :)
by rattenfanger
2005-10-28 13:28
Forum: Development & alpha discussions
Topic: SQL Optimalization
Replies: 4
Views: 4780

Yeah I thought the same Bingo! But all my queries (from other sites) in the slow log have Query_time: 0 so I think it is something different.. Now I searched the mysql site for it and found this: http://dev.mysql.com/doc/refman/4.1/en/slow-query-log.html. There's a option to enable logging for queri...
by rattenfanger
2005-10-21 11:03
Forum: Scripting
Topic: Alternate SM Mod
Replies: 148
Views: 170615

I love this mod! It looks very nice :) One thing: hMailServer now supports the SORT extension for new versions (I think for the 4.2 alpha branche??) Maybe its nice to notice in the opening post the ability to set the server side sort to true. It makes SM muchhh faster! Depening this variable on the ...
by rattenfanger
2005-10-20 14:45
Forum: Development & alpha discussions
Topic: SQL Optimalization
Replies: 4
Views: 4780

hm_fetchaccounts only has 3 rows! Very strange that it is a slow query...
I have it on for a long time and it comes back every time. So now and then also other queries from hmailserver, but not notable.

Maybe its due to my slow (not fast :P) computer? Or someone else has to test it :)
by rattenfanger
2005-10-20 11:04
Forum: Development & alpha discussions
Topic: SQL Optimalization
Replies: 4
Views: 4780

SQL Optimalization

Hi! I'm running 7 account at 4 domains with hMailSever so performance is not a big issue. But I saw something interesting with the database. I use MySQL 4.1 and I have Slow Query Log enabled. Every query that takes longer than 2 secondes to execute is logged in slow_query.log. In that file I saw the...
by rattenfanger
2005-10-19 14:43
Forum: Development & alpha discussions
Topic: hMailServer 4.2 - Build 162 (Alpha)
Replies: 4
Views: 3817

I thought I was watching this topic, not! I didn't receive a mail for it.. Better late then never? ;) The error I get when i open the webadmin (before i log in): Notice: Undefined index: loggedin in F:\Web_root\bosweb.demon.nl\admin\hMailserverWebAdmin\index.php on line 61 Thanks for the fix! :D Wil...
by rattenfanger
2005-10-16 23:44
Forum: Development & alpha discussions
Topic: hMailServer 4.2 - Build 162 (Alpha)
Replies: 4
Views: 3817

As i said before: it looks very good, the new webadmin! Maybe renaming it to hMailServerWebAdmin is better? Not everybody has to rename it when copying to the webroot ;) I recommend you to set error_reporting(E_ALL ^ E_NOTICE) because you used it with programming it, and I have it at E_ALL myself so...
by rattenfanger
2005-10-11 22:41
Forum: Development & alpha discussions
Topic: PHPWebAdmin error in Build 159
Replies: 7
Views: 4399

Oh then I'm very silly! :$ I think i was confused because you removed the edit button. Woeepsss! Sorry! Its down at the moment, but I believe if you say it works ;) And btw, if you made de webadmin using AJAX it would be very smoother and faster. But if you don't know how to use it its a lot work im...
by rattenfanger
2005-10-11 22:16
Forum: Development & alpha discussions
Topic: PHPWebAdmin error in Build 159
Replies: 7
Views: 4399

Yes al that things is about that version ;)
But with editing the distribution list recipients I mean clicking a recipient from a list and then edit the mail adres. For example when you made a typing mistake.. Or when you want to replace one person in a organisation with a new one.
by rattenfanger
2005-10-11 22:06
Forum: Development & alpha discussions
Topic: PHPWebAdmin error in Build 159
Replies: 7
Views: 4399

When I loggin it points me to http://localhost/ When I then come back I'm logged in and it works fine. The new admin looks good to me! The icons are a lot nicer, similar to the normal very admin is good! And I love the added status screen! Yesterday I was looking for it but couldnt find it ;) I can'...
by rattenfanger
2005-10-11 21:43
Forum: Development & alpha discussions
Topic: PHPWebAdmin error in Build 159
Replies: 7
Views: 4399

PHPWebAdmin error in Build 159

When I edit the recipients of a distribution list i get the following error: Notice: Undefined variable: DomainID in F:\Web_root\bosweb.demon.nl\admin\hMailserverWebAdmin\distributionlists_recipients_edit.php on line 45 Fatal error: Uncaught exception 'com_exception' with message 'Parameter 0: Type ...
by rattenfanger
2005-10-08 01:35
Forum: Development & alpha discussions
Topic: hMailServer 4.2 - Build 157 (Alpha)
Replies: 8
Views: 6846

martin wrote:....Sorry for taking so long..

Hehehe you 're funny ;) It is a milion times faster than Microsoft fixes bugs ;) You 're good! (Y)
by rattenfanger
2005-09-30 19:58
Forum: Development & alpha discussions
Topic: 2d's webmail
Replies: 11
Views: 7305

Yeah you said that but I said that maybe COM is a better solution with the same performance ;)
by rattenfanger
2005-09-29 08:19
Forum: Development & alpha discussions
Topic: 2d's webmail
Replies: 11
Views: 7305

i make a webmail that work with the database and mails directly and integrate to save and send messages , worsk very well, fast and do not need conexions imap or pop Maybe you can use COM objects for it. It don't nog how much is possible with them but I think they put a layer between the databas an...
by rattenfanger
2005-09-27 16:33
Forum: Development & alpha discussions
Topic: 2d's webmail
Replies: 11
Views: 7305

I'm looking forward to it!!

Does it have multi language support? I can't read Hungarian (Or something ;))
by rattenfanger
2005-09-08 07:53
Forum: Development & alpha discussions
Topic: hMailServer 4.2 - Build 142 (Alpha)
Replies: 36
Views: 23214

So every build you make is stable when you put it online? ;);)

Nice job! :)
by rattenfanger
2005-08-29 12:04
Forum: Development & alpha discussions
Topic: PHP Exception in WebAdmin (PHP 5.0.3)
Replies: 1
Views: 3243

Same problem here.

Also at some other points problems with uncaught exceptions.

Sorry but I have no time to look futher in to it at the moment..
by rattenfanger
2005-07-18 16:40
Forum: Archived feature requests
Topic: Not resetting the stats at the Live section
Replies: 0
Views: 3382

Not resetting the stats at the Live section

It would be nice if the shown stats in the Live section are not resetted when the server is restarted. My server is restarted very often (once a week) and i want the stats from a longer period... Maybe display the totalcounts and the counts since the uptime? Not much work I think.. (Maybe another su...
by rattenfanger
2005-07-18 16:33
Forum: Development & alpha discussions
Topic: hMailServer 4.1 - Build 127 (Alpha)
Replies: 11
Views: 11416

I LOVE the cache!!! Good work!
by rattenfanger
2005-06-17 20:10
Forum: Development & alpha discussions
Topic: Mail going in circles, pegging CPU at 100%
Replies: 16
Views: 9874

[quote="martin"]Thanks. Feels a bit stupid that I as an developer of an email server didn't know that. :-P
quote]

learning is a good thing martin ;)
by rattenfanger
2005-06-08 22:11
Forum: Development & alpha discussions
Topic: Finally..
Replies: 7
Views: 6805

That's great! :D
Will the features mentoied http://www.hmailserver.com/forum/viewtopic.php?t=1786 here be included? The things you said there not the stuff we as users said ;)
by rattenfanger
2005-06-01 14:50
Forum: Development & alpha discussions
Topic: Install problems on WinXP with build 109
Replies: 14
Views: 11666

rattenfanger wrote:Oh yeah, I thought of better error handling.. But that's much work to implement isn't it? Depends on how you program but usually its much work.. :(
That's done in the new build :D Great work :)
by rattenfanger
2005-05-26 11:50
Forum: Development & alpha discussions
Topic: dbase troubles
Replies: 3
Views: 4091

Did you choose to create a database or to select a database?
When selecting it is oke you don't see stuff in the white box..
by rattenfanger
2005-05-26 00:54
Forum: Development & alpha discussions
Topic: Install problems on WinXP with build 109
Replies: 14
Views: 11666

Over 200 peoples downloaded it, so the installation should be tested by much people. But they only upgrade. New users first try the stable...
by rattenfanger
2005-05-25 22:01
Forum: Development & alpha discussions
Topic: Martin for knighthood
Replies: 2
Views: 3539

I agree I agree!!!!!!!
I wanted to donate about euro 25 last year when I installed for 2 months and saw it was sooo great but I don't have a credit card :(
by rattenfanger
2005-05-25 21:58
Forum: Development & alpha discussions
Topic: Install problems on WinXP with build 109
Replies: 14
Views: 11666

@martin: The problem is fixed now! Great work, so fast :D I first thought it was strange if it was a bug since so many people installed it.. But many people are upgrading I think :)

Thnx!
by rattenfanger
2005-05-24 23:08
Forum: Development & alpha discussions
Topic: Install problems on WinXP with build 109
Replies: 14
Views: 11666

Oh yeah, I thought of better error handling.. But that's much work to implement isn't it? Depends on how you program but usually its much work.. :(
by rattenfanger
2005-05-24 23:04
Forum: Development & alpha discussions
Topic: Install problems on WinXP with build 109
Replies: 14
Views: 11666

I selected "Select a new hMailserver default database" at the DBSetup, so it don't have to create the database or tables. (I forgot to say that, sorry). The database hmailsever is an existing one with the tables from an old hMailserver install (the 106 build on the other server). My internet connect...
by rattenfanger
2005-05-24 20:42
Forum: Development & alpha discussions
Topic: Internal counter instead of DB auto_increment
Replies: 24
Views: 17528

The mixed solution sounds great Anlan!
by rattenfanger
2005-05-24 20:30
Forum: Development & alpha discussions
Topic: Install problems on WinXP with build 109
Replies: 14
Views: 11666

Install problems on WinXP with build 109

First of all i'm running hMailserver now for a year or something. I upgraded to build 106 some days ago and everything went fine. Now I'm trying to install on a second machine. I try build 109 but it gives some errors during install! (I also tried 106 but it gives the same error) -hMailserver wasn't...
by rattenfanger
2005-03-01 23:37
Forum: General discussions
Topic: 550 Sender verify failed.
Replies: 12
Views: 9400

Sorry!
I readed the logs and thought it was the other mailserver complaining, not mine! :$

And i really searched for the error but i found nothing usefull.. Strange i missed that post!