Search found 111 matches

by black zero
2015-03-13 04:33
Forum: Scripting
Topic: Cannot automate script, always stuck in running mode.
Replies: 12
Views: 76138

Re: Cannot automate script, always stuck in running mode.

I wa able to reproduce the OP's error exactly as he described. I fixed the problem by doing what I said. Yes, your solution fixed mine as well. Thank you very much, really appreciate it. But still, it doesn't explain why my other script works (simply by pointing out the .vbs file from Task Schedule...
by black zero
2015-03-12 08:53
Forum: Scripting
Topic: Cannot automate script, always stuck in running mode.
Replies: 12
Views: 76138

Re: Cannot automate script, always stuck in running mode.

Yes, single line

Code: Select all

WScript.Echo "Removed a total of " & GrandTotal & " message(s)."
At the very bottom.

I'm going to remove it.
by black zero
2015-03-12 04:11
Forum: Scripting
Topic: Cannot automate script, always stuck in running mode.
Replies: 12
Views: 76138

Re: Cannot automate script, always stuck in running mode.

Here's a bit more data to depict my situations. I'm running everything on Administrator account. The said script is located on: C:\Program Files (x86)\hMailServer\Addons\Utilities Funny thing is, when I setup to Scheduler other script named "StartBackup.vbs", it runs just fine. I compared StartBacku...
by black zero
2015-03-10 04:32
Forum: Scripting
Topic: Cannot automate script, always stuck in running mode.
Replies: 12
Views: 76138

Cannot automate script, always stuck in running mode.

The said script is here: https://www.hmailserver.com/forum/viewtopic.php?f=20&t=15363&p=173161#p158795 Having been using this script for many days, I am certain it's good for me. Now the question is, I can't seem to automate it every night with Windows' Task Scheduler. The script runs, but always st...
by black zero
2015-01-15 10:11
Forum: User contributed hMailServer 5 scripts
Topic: Script to delete messages older than X days
Replies: 75
Views: 84382

Re: Script to delete messages older than X days

Thanks for posting the script. I made a few changes to make the script a bit faster, but also fixed a pretty major flaw. - Flaw: When message is deleted, the oMessages collection changes. The Count goes down and not all messages are iterated anymore, resulting in not all mails being deleted that sh...
by black zero
2013-01-23 09:07
Forum: General discussions
Topic: How to periodically delete all mails saved on all mailbox?
Replies: 3
Views: 1150

Re: How to periodically delete all mails saved on all mailbo

The script works. The problem is (I'm using script for one account only for test), in a very large mailbox, it doesn't wipe everything within range (e.g older than one day mail).

Example, 10.000 mails older than one day. Script runs. It wipes out only 10%. Sometimes 30% of 10.000 mails.

Help?
by black zero
2012-11-30 09:30
Forum: General discussions
Topic: How to periodically delete all mails saved on all mailbox?
Replies: 3
Views: 1150

How to periodically delete all mails saved on all mailbox?

I don't want to go through all accounts one by one and click 'empty account' on each and every account. >.>
by black zero
2012-06-18 07:34
Forum: General discussions
Topic: Cannot backup to network share
Replies: 10
Views: 4044

Re: Cannot backup to network share

Yo, it works.

When I used UNC path it worked. Certainly ain't credential issue then?

Thanks doom.
by black zero
2012-06-18 03:02
Forum: General discussions
Topic: Cannot backup to network share
Replies: 10
Views: 4044

Re: Cannot backup to network share

^DooM^ wrote:Try using the UNC path instead of a mapped drive. I always had issues with mapped drives once i was no longer logged in.

\\192.168.1.20\path\to\file\store
Trying now. Will report back later.
by black zero
2012-06-15 08:15
Forum: General discussions
Topic: Cannot backup to network share
Replies: 10
Views: 4044

Re: Cannot backup to network share

You are running an internet facing application under the administrator account? That's just asking for trouble. Create a new dedicated hMail user and set the correct permissions. Don't worry I blocked all incoming connection to that machine. I'll do it after I figure out what's wrong with this back...
by black zero
2012-06-14 10:37
Forum: General discussions
Topic: Cannot backup to network share
Replies: 10
Views: 4044

Re: Cannot backup to network share

Okay so I added a new user named administrator (same as credential of which hmail is using on the server, previously there wasn't administrator), on the network attached storage so that it matches with each others. hmail has administrator credential on the server network attached storage has adminis...
by black zero
2012-06-14 08:40
Forum: Off-topic discussions
Topic: suggestions for firewall please
Replies: 10
Views: 6506

Re: suggestions for firewall please

Not sure why Windows 7's regarded as complicated. I've been using it and no issues.

If you want to block IP, it would be better to do pessimistic approach - Block All Allow Some (whitelisting). That way you don't need to block multiple IPs since it means more work for you.
by black zero
2012-06-14 04:34
Forum: General discussions
Topic: Cannot backup to network share
Replies: 10
Views: 4044

Cannot backup to network share

According to manual: Backup to network drives For a backup to be successful, the hMailServer service must have permission to write to the path you have specified as backup destination. If the backup destination is a network drive, you must ensure that the hMailServer service has permissions to write...
by black zero
2010-06-08 11:29
Forum: General discussions
Topic: How do I keep a copy of all emails...
Replies: 2
Views: 774

How do I keep a copy of all emails...

...to one specified address? I used to be able to, but forgot how. -.-
by black zero
2009-08-31 03:42
Forum: Development & alpha discussions
Topic: My backup script stopped working after upgrading...
Replies: 8
Views: 4227

Re: My backup script stopped working after upgrading...

Ok, I just restarted my Windows, reinstall hmail and it works. Weird...

Do we need to restart windows after upgrading HMail?

EDIT: reinstalled it and then restarted windows. My English is bad. >_>

Anyway, problem solved... Thanks everyone.
by black zero
2009-08-31 03:35
Forum: Development & alpha discussions
Topic: My backup script stopped working after upgrading...
Replies: 8
Views: 4227

Re: My backup script stopped working after upgrading...

So does the backup still work? Just not the notification script, is that correct? The backup works if it's done manually via hmail GUI The script fails at line 20 Call oApp.Authenticate("Administrator", g_sAdminPassword) I checked the admin password variable and it's correct, and so is the Administ...
by black zero
2009-08-31 03:19
Forum: Development & alpha discussions
Topic: My backup script stopped working after upgrading...
Replies: 8
Views: 4227

Re: My backup script stopped working after upgrading...

- I didn't change any password
- I didn't change any username
- I only upgraded hmail from 5.1.1 to latest beta
by black zero
2009-08-31 03:17
Forum: Development & alpha discussions
Topic: My backup script stopped working after upgrading...
Replies: 8
Views: 4227

Re: My backup script stopped working after upgrading...

5.1.1 to latest beta. The script looks as follows Option Explicit const g_sBNFrom = "zero" 'CHANGE ME const g_sBNFromAddress = "postmasterzero@pt-yyy.co.id" 'CHANGE ME const g_sAdminPassword = "itsmeadmin" 'CHANGE ME dim MessageRecipientName, MessageRecipientAddress,MessageRecipientName2, MessageRec...
by black zero
2009-08-30 06:59
Forum: Development & alpha discussions
Topic: My backup script stopped working after upgrading...
Replies: 8
Views: 4227

Re: My backup script stopped working after upgrading...

It's wrong to assume that a script which works with one version of hMailServer always will work with all future versions. hMailServer evolves and so must scripts sometimes. So have you done what the error message suggested that you must do? Martin, I have no idea what to do. Everything seems ok. My...
by black zero
2009-08-29 09:08
Forum: Development & alpha discussions
Topic: My backup script stopped working after upgrading...
Replies: 8
Views: 4227

My backup script stopped working after upgrading...

to the latest version. It worked on the older version just fine. 'You do not have access to this property/method. Ensure that hmailserver.application.authenticate() is called with proper login credentials.' That's the error message. HOWEVER, I didn't change ANYTHING in my script - it's because of th...
by black zero
2009-08-27 08:58
Forum: Off-topic discussions
Topic: Donate button is back
Replies: 26
Views: 7183

Re: Donate button is back

Ok I'm being slow here, but what's this donate button you people are talking about?
by black zero
2009-08-21 04:41
Forum: Off-topic discussions
Topic: Beer ...
Replies: 5
Views: 1969

Re: Beer ...

Hmmm.. I guess drinking is pretty popular there in Europe? It's not here though in Indonesia, maybe because it's warm already -- and would be hot if drink alcohol lol.

And it's expensive D:
by black zero
2009-08-21 02:31
Forum: Off-topic discussions
Topic: Torrent question
Replies: 6
Views: 2368

Re: Torrent question

Yep. I've forwarded the required port for uTorrent already.

And I used to think port - forwarding is only needed if you want to do a better upload not download?
by black zero
2009-08-20 10:56
Forum: Off-topic discussions
Topic: Torrent question
Replies: 6
Views: 2368

Torrent question

Does anyone know why my upload speed is always higher than my download speed on the torrent status?

Not that I grudge that, just curious. :lol:
by black zero
2009-08-03 04:36
Forum: Off-topic discussions
Topic: Webmail Clients
Replies: 8
Views: 4587

Re: Webmail Clients

Squirrel, since it's the very first webmail I've ever successfully installed on my Hmail. kthxbai.
by black zero
2009-08-03 04:33
Forum: Off-topic discussions
Topic: The mother of cool tools.
Replies: 8
Views: 3583

Re: The mother of cool tools.

Defence in depth is always fun - Adblockplus + NoScript + Flashblock = very few ads or annoyances. It can be slightly annoying when going to a new site, but I hardly ever do these days (at least I hardly ever stay on a site for very long or come back again unless it is actually useful!). lol *high ...
by black zero
2009-07-03 05:37
Forum: Off-topic discussions
Topic: Documentation
Replies: 15
Views: 5408

Re: Documentation

*follows merge train*
by black zero
2009-05-25 05:20
Forum: Off-topic discussions
Topic: Help me, please find the e-mail client that supports databas
Replies: 7
Views: 2828

Re: Help me, please find the e-mail client that supports databas

Possibly unrelated but.. From my experience, Outlook 6 storage capabilities is really terrible. It can not store and maintain properly an inbox sized more than 2-3 GB. It gets corrupted every time and then... I had encountered this many times on my clients pc. It's because they don't delete their ol...
by black zero
2009-05-25 05:00
Forum: Off-topic discussions
Topic: Is there any FREE Antivirus for Windows Server 2003?
Replies: 21
Views: 15761

Re: Is there any FREE Antivirus for Windows Server 2003?

Maybe I'm too cheap to buy one, but this time I am really out of budget hence I've been searching for a free Server AV. I'd reconsider the budget for AVG, though.
by black zero
2009-04-29 04:21
Forum: Off-topic discussions
Topic: Is English your first language?
Replies: 28
Views: 9812

Is English your first language?

Just want to know.. I'm asking this since apparently, there are many people that post in their language, or in a... (sorry) terrible English. Not in this forum, but on the other forum I frequent in. Mine isn't. It's Indonesian. I know my English isn't that good, but at least... it's enough to delive...
by black zero
2009-04-29 04:17
Forum: Off-topic discussions
Topic: "old" Servers to be put in production again
Replies: 10
Views: 4569

Re: "old" Servers to be put in production again

4 GB RAM????

:roll: That's insane lol...

I don't think the specs are going to slow hmail down, I think.
by black zero
2009-04-29 03:49
Forum: Development & alpha discussions
Topic: Translation editor available again!
Replies: 18
Views: 10634

Re: Translation editor available again!

Indonesian translation has been completed.
by black zero
2009-04-28 11:42
Forum: Development & alpha discussions
Topic: Translation editor available again!
Replies: 18
Views: 10634

Re: Translation editor available again!

I just sent out my application form for Indonesian Translation. :D I'd be happy to give my small help to improve this software.
by black zero
2009-04-28 08:23
Forum: General discussions
Topic: How do I lift a ban for a specific ip (auto ban feature)
Replies: 10
Views: 2081

Re: How do I lift a ban for a specific ip (auto ban feature)

Yeah. I run a DHCP Wireless Linksys.

It's encrypted, though. With... WEP IIRC :lol:

I deleted my computer, and as you said, no impact.

Overall, thanks for all your help, really appreciate it.
by black zero
2009-04-28 04:22
Forum: General discussions
Topic: How do I lift a ban for a specific ip (auto ban feature)
Replies: 10
Views: 2081

Re: How do I lift a ban for a specific ip (auto ban feature)

Whoa, a reply at the speed of the light >_> You're really something, matt.

Internet is 9

My Computer is 1



For LAN, isn't it safe enough so that there's no need for me to activate smtp authentication?
by black zero
2009-04-28 04:18
Forum: Off-topic discussions
Topic: Whoa...
Replies: 9
Views: 2787

Re: Whoa...

IIRC, you (martin) decided to make this HMS as a closed source because some thieves grabbed yours and claimed it as theirs?

And no, don't change your mind please. D:
So is mine. So you'll buy?
Huh? Yours isn't US Dollar?
by black zero
2009-04-28 03:50
Forum: General discussions
Topic: How do I lift a ban for a specific ip (auto ban feature)
Replies: 10
Views: 2081

Re: How do I lift a ban for a specific ip (auto ban feature)

at the risk of being called as a noob...

(see attached file)

Is it the correct config for that higher priority you mentioned? My IP range (LAN) 192.168.2.0/24
by black zero
2009-04-27 18:02
Forum: Off-topic discussions
Topic: Whoa...
Replies: 9
Views: 2787

Re: Whoa...

It's not like I don't want to pay anything for the creator of this great software... However, since the exchange rate for dollar against my currency is too high, I can't give donation / pay for the license fee (if it was a shareware) at the significant rate. D:
by black zero
2009-04-27 12:08
Forum: Off-topic discussions
Topic: Whoa...
Replies: 9
Views: 2787

Re: Whoa...

No no. What I meant is... Will hmail ever be a shareware? :?
by black zero
2009-04-27 11:45
Forum: General discussions
Topic: How do I lift a ban for a specific ip (auto ban feature)
Replies: 10
Views: 2081

Re: How do I lift a ban for a specific ip (auto ban feature)

Whoa it's there. There should've been a special tree list for that part (lifting an ip ban).
by black zero
2009-04-27 11:33
Forum: Off-topic discussions
Topic: Whoa...
Replies: 9
Views: 2787

Whoa...

http://fileforum.betanews.com/detail/hM ... 95667052/1

Read the comments posted there carefully.... especially from Aegis69.

Who can give me the answer then? :|
by black zero
2009-04-27 11:29
Forum: Off-topic discussions
Topic: Can hmailserver + RoundCube + IIS5 + WindowsXP work??
Replies: 8
Views: 6161

Re: Can hmailserver + RoundCube + IIS5 + WindowsXP work??

I prefer SM over RC. >_>

However... someone please help me over the vacation script please. T.T
by black zero
2009-04-27 11:20
Forum: General discussions
Topic: How do I lift a ban for a specific ip (auto ban feature)
Replies: 10
Views: 2081

How do I lift a ban for a specific ip (auto ban feature)

topic..

It's just silly... I got blocked out from my OWN server because I wrongly typed my password three times lol.

Searched the docs, to no avail. -_-
by black zero
2009-04-27 03:49
Forum: Off-topic discussions
Topic: It must be a bug
Replies: 21
Views: 8413

Re: It must be a bug

martin wrote:That's a heart. As in heartbeat. As in some kind of diagnostics. ;)
Has it been put inside the last posted beta version?
by black zero
2009-04-26 13:22
Forum: Off-topic discussions
Topic: It must be a bug
Replies: 21
Views: 8413

Re: It must be a bug

Wait...

What does that love icon for lol?
by black zero
2009-04-26 12:58
Forum: Off-topic discussions
Topic: Is there any FREE Antivirus for Windows Server 2003?
Replies: 21
Views: 15761

Is there any FREE Antivirus for Windows Server 2003?

That supports resident shield.

And I hope it's completely free... -.-
by black zero
2009-04-26 12:51
Forum: Off-topic discussions
Topic: It must be a bug
Replies: 21
Views: 8413

Re: It must be a bug

Aw that's so sweet.

I can't wait for that version to come.
by black zero
2009-04-26 12:41
Forum: Feature requests
Topic: Bandwidth Logging
Replies: 17
Views: 11598

Re: Bandwidth Logging

Voted yes.

I am more than happy to do that. :D
by black zero
2009-04-26 06:27
Forum: Scripting
Topic: hmailserver vacation responder plugin does not work
Replies: 2
Views: 1314

hmailserver vacation responder plugin does not work

Here's the script, I only changed the hmail password as asked. <?php // If you have some problems with a plank page or something like that, // pleasy temporary uncamment the following line: //ini_set('error_reporting', E_ALL); /** * This configuration variable is used in hMailServer 4.3 authenticati...
by black zero
2009-03-19 10:00
Forum: Off-topic discussions
Topic: <Doom> 's new signature
Replies: 20
Views: 9738

Re: <Doom> 's new signature

I can't read the sig.... It's jumbled. Does the fault lie on my side?
by black zero
2009-03-19 05:38
Forum: Scripting
Topic: Backup log is messed up after upgrading to v5 from v4.
Replies: 27
Views: 5040

Re: Backup log is messed up after upgrading to v5 from v4.

lol that's brilliant. You should've told me that trick earlier...
by black zero
2009-03-19 02:52
Forum: Scripting
Topic: Backup log is messed up after upgrading to v5 from v4.
Replies: 27
Views: 5040

Re: Backup log is messed up after upgrading to v5 from v4.

After several tests,

It's able to send a notification to one email address only. ~_~
by black zero
2009-03-18 09:07
Forum: Scripting
Topic: Backup log is messed up after upgrading to v5 from v4.
Replies: 27
Views: 5040

Re: Backup log is messed up after upgrading to v5 from v4.

"ERROR" 4808 "2009-03-18 14:03:34.398" "Script Error: Source: Microsoft VBScript runtime error - Error: 800A01C2 - Description: Wrong number of arguments or invalid property assignment: 'oMessage.AddRecipient' - Line: 53 Column: 3 - Code: (null)" It is the error log. I reloaded the script and rechec...
by black zero
2009-03-18 06:53
Forum: Scripting
Topic: Backup log is messed up after upgrading to v5 from v4.
Replies: 27
Views: 5040

Re: Backup log is messed up after upgrading to v5 from v4.

"ERROR" 2196 "2009-03-18 11:45:24.882" "Script Error: Source: Microsoft VBScript runtime error - Error: 800A01C2 - Description: Wrong number of arguments or invalid property assignment: 'oMessage.AddRecipient' - Line: 53 Column: 3 - Code: (null)" Option Explicit const g_sBNFrom = "zero" 'CHANGE ME ...
by black zero
2009-03-18 06:03
Forum: General discussions
Topic: Is there any automatic backup in hmail?
Replies: 3
Views: 1238

Re: Is there any automatic backup in hmail?

Done all you listed above.

Let's see for the result then. Thank you very much.
by black zero
2009-03-18 03:54
Forum: General discussions
Topic: Is there any automatic backup in hmail?
Replies: 3
Views: 1238

Is there any automatic backup in hmail?

Well.. I am surprised my previous thread was moved to this subforum, o.O so I posted this thread here instead on general discussion. As the topic title says, I want an automatic backup function either built in or script. The script matt provided to me is working wonderfully, and I am very satisfied ...
by black zero
2009-03-17 08:17
Forum: Scripting
Topic: Backup log is messed up after upgrading to v5 from v4.
Replies: 27
Views: 5040

Re: Backup log is messed up after upgrading to v5 from v4.

Thank you!

I'll PM you if I encounter any problem with the edited script (with more than 1 recipient).

:D Finally I can sleep peacefully.
by black zero
2009-03-17 04:46
Forum: Scripting
Topic: Backup log is messed up after upgrading to v5 from v4.
Replies: 27
Views: 5040

Re: Backup log is messed up after upgrading to v5 from v4.

EDIT:

My bad, I forgot to include DeleteFile from the original script.

It's working properly now.


Next question: How do I make the script to send the notification to MORE than one recipient?
by black zero
2009-03-17 04:25
Forum: Scripting
Topic: Backup log is messed up after upgrading to v5 from v4.
Replies: 27
Views: 5040

Re: Backup log is messed up after upgrading to v5 from v4.

Here you go. Apparently DeleteFile sub is missing lol.

Code: Select all

"ERROR"	1384	"2009-03-17 09:23:19.851"	"Script Error: Source: Microsoft VBScript runtime error - Error: 800A01F4 - Description: Variable is undefined: 'DeleteFile' - Line: 43 Column: 3 - Code: (null)"