Search found 41 matches

by BrandonH75
2010-05-12 17:41
Forum: User contributed hMailServer 5 scripts
Topic: Bounce Processing / Undeliverable Notification
Replies: 14
Views: 20034

Re: Bounce Processing / Undeliverable Notification

Well it turns out they wanted to know about the body for something else other than the bounce processing. The oMessage.Body was working, just not on the emails they were sending. So I just added the original email as an attachment and it works great. I will definitely take a closer look at your post...
by BrandonH75
2010-05-11 21:00
Forum: User contributed hMailServer 5 scripts
Topic: Bounce Processing / Undeliverable Notification
Replies: 14
Views: 20034

Re: Bounce Processing / Undeliverable Notification

I just wanted to say thanks for the script. We too are using Interspire and hMS together and this will help a lot with those bounces. I do have one question on a small change that someone here wants. Let's say we wanted to tack on the body of the message as well as all of the headers. How would we d...
by BrandonH75
2010-04-28 22:44
Forum: General discussions
Topic: Easy \ latest install instructions for ClamWin?
Replies: 28
Views: 7653

Re: Easy \ latest install instructions for ClamWin?

I see this is kind of an old thread, but I've been fighting with this as well. I don't have a good solution, but it seems that clamd is taking too long to load all of the stuff in the data folder. I removed all of the sig files that ClamSup had in there, and then the service fired right up. Clamd wo...
by BrandonH75
2010-03-26 16:47
Forum: General discussions
Topic: "forwarded" indicator doesn't stick
Replies: 7
Views: 5131

Re: "forwarded" indicator doesn't stick

Now I know I'm not imagining things. :lol:

I had put a couple posts on the Mozilla forums about this but I haven't heard anything.
by BrandonH75
2010-03-03 22:05
Forum: General discussions
Topic: "forwarded" indicator doesn't stick
Replies: 7
Views: 5131

Re: "forwarded" indicator doesn't stick

OK I don't feel quite so confused anymore. Yes, Thunderbird uses the msf files for local info. I've read that deleting those and having TBird recreate them can fix some of TBird's strange habits. So it would appear that TBird is at fault for our forward indicators disappearing. What still confuses m...
by BrandonH75
2010-03-01 19:02
Forum: General discussions
Topic: "forwarded" indicator doesn't stick
Replies: 7
Views: 5131

Re: "forwarded" indicator doesn't stick

That's what I thought at first. But I was confused by a couple things. I have one TBird that accesses both an hmail account and a gmail account. The forwarded indicators stick on the gmail account, but not on the hmail account. Then, I set up a new workstation for a user. When I connected to her hma...
by BrandonH75
2010-02-26 22:39
Forum: General discussions
Topic: "forwarded" indicator doesn't stick
Replies: 7
Views: 5131

"forwarded" indicator doesn't stick

Hey guys. I have a strange issue that just started happening recently. If I assume correctly, HMS keeps track of whether a particular message has been either forwarded or replied to. Lately it is no longer keeping track of what has been forwarded. A user first noticed this after getting set up with ...
by BrandonH75
2010-02-26 22:08
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

I thought I would put some closure on this thread. :) This "pause" thing seems to have slowly straightened itself out. I can still make it happen if I really try, but it is not bad at all so I haven't messed with anything. I still have to move everything back to the original server. :| There are ver...
by BrandonH75
2010-01-07 21:24
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

That is correct. 3310 is the clamd service.

We are going to try moving the hms db from mysql to sql server in the near future and see if that makes any difference. But so far today, aside from that one error, everything has been running OK.
by BrandonH75
2010-01-07 20:27
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

The MySQL db is running on port 3307 on a separate machine. We do have an old Pervasive engine sitting on this machine (as a backup), but it is disabled.
by BrandonH75
2010-01-07 20:18
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

I have been watching the network tab and it is always low. In fact, for some reason the file backup on that server was still running this morning, copying files to another server, and hms was running normal. For a long time HMS was on the same box and mysql. I just recently split them up to try to s...
by BrandonH75
2010-01-07 17:28
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

Here are the results from netstat on our new email server as it was acting up. There is no web server running with hms, and we aren't running any virtual machines on servers, but we do have a few on developer workstations that aren't used very often. So far this morning hms is acting fine. (Except f...
by BrandonH75
2010-01-06 23:10
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

Thanks I will have to check that out :D This all started after upgrading both hms and mysql, but the way my luck is, we would start getting attacked at the same time. The Chinese have been constantly trying to hack into our FTP server for years. Anyways....On the new box the cpu doesn't hit 100 afte...
by BrandonH75
2010-01-06 21:07
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

I'm sorry if I'm not being clear. It seems like it's doing something different every time I look. We moved our hms to a new server last night on a fresh install of Windows Server 2003 R2 Standard. The MySQL database is still on a separate machine (which we did a couple days ago). It was running grea...
by BrandonH75
2010-01-05 01:02
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

The hangs got very bad again this morning, so I let MySQL run for a while with the slow query logging on. I witnessed several "hangs" while the logging was on. There was nothing in the slow query log. I just moved the db to another box (running Win7 Pro), hooked hMS up to that one (hMS on the same s...
by BrandonH75
2009-12-30 22:06
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

hMailServer is the only software using this MySQL.
by BrandonH75
2009-12-30 21:50
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

Sorry...indexing has never been enabled.
by BrandonH75
2009-12-30 21:30
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

Indexing has been disabled. I was able to get the hang using localhost, and it did the same with IMAP Sort disabled. When I got it to hang when updating a large number (a couple thousand) headers on localhost, I went to my workstation and hit Send/Receive. My POP account checked successfully right a...
by BrandonH75
2009-12-29 22:52
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

It looks like both hms and mysqld-nt jump way up for a second or two after each hang. The last couple times I got the server to pause like that, I got mysqld-nt to hit 85ish%, with hms taking up the last 15%. So far today there have been no errors in the error log. I have yet to create any errors on...
by BrandonH75
2009-12-29 17:52
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

Most of our users are using Thunderbird, and they all use IMAP. A few users have various versions of Outlook and see the same things happen. To clarify for Martin...when I say that the server "hangs"...for clients, they just do nothing until the server starts responding again. When I am on the serve...
by BrandonH75
2009-12-29 00:07
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

Log is sent. Last week users were getting timeout errors. Today so far it occasionally takes 30 seconds or so to start downloading headers for a folder or to send an email. I haven't heard of any more timeouts. I had the cache disabled all last week. I just turned it back on a little while ago but e...
by BrandonH75
2009-12-28 21:11
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

We have it set at 100 command threads now. MySQL Admin shows hmailserver using 5 connections. From what I've seen, and the few reports from users that I've gotten today, it is when deleting emails or refreshing a folder's headers that seems to cause the most trouble. Some users have thousands and th...
by BrandonH75
2009-12-28 20:24
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

I'm not sure if it got hung up or was taking its time. There were thousands of emails being deleted, and the server pretty much just stops when that happens. I was hoping the update would help with that, but it still happens. Is that normal? We sent out a mass email recently telling our users to NOT...
by BrandonH75
2009-12-28 19:56
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

No SpamAssassin. We have ClamAV 0.95.2 from http://oss.netfarm.it/clamav/ to scan emails. The latest ClamWin is installed on that server, but is not used anymore. I have removed our Viper antivirus just in case that was causing issues, but it should not have been because the active and email scannin...
by BrandonH75
2009-12-28 19:01
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

I did get the OK for you to get access Martin, but now there is something wrong with our firewall and I can't get in to set it up. But since it works other than that no one wants to mess with it. :roll: So...other than occasional error messages and occasional slowness that clients experience when co...
by BrandonH75
2009-12-23 18:02
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

Viper Enterprise runs a client on each computer. It communicates with and can be controlled by a main program on one of the servers. I imagine others are similar, but this is the only one I have used. After Googling, I tried a few techniques that I found to transfer/upgrade the built-in database to ...
by BrandonH75
2009-12-22 23:59
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

Re: HMS/MySQL upgrade, errors, hangs

For antivirus on the server we have Vipre Enterprise. The hMS data directory is excluded from scans. For email scanning in hMS we currently use ClamAV 95.2. The hMS data directory did not move during the upgrade. The MySQL installation is in a different location. This is a 32-bit system. The only ot...
by BrandonH75
2009-12-22 21:53
Forum: General discussions
Topic: HMS/MySQL upgrade, errors, hangs
Replies: 38
Views: 10899

HMS/MySQL upgrade, errors, hangs

Hello! I'm not exactly sure where this problem is, but hMailServer left me two 4 GB log files yesterday... Over the weekend we upgraded hMS from 4.4.1-B273 to 5.3-B1617, then MySQL from the one included in the hMS 4.4.1 setup to 5.0.85. Everything seemed to work fine until everyone got back in the o...
by BrandonH75
2009-08-27 21:50
Forum: General discussions
Topic: "Delivery is not allowed to this address"
Replies: 1
Views: 1154

"Delivery is not allowed to this address"

Hello! We are having a problem with two of our servers trying to send email to external addresses through our hMailServer, but hMailServer is blocking them and we can't figure out why. These two servers are on the same network as everyone else, who are able to send emails to external addresses with ...
by BrandonH75
2009-01-27 00:29
Forum: Off-topic discussions
Topic: ClamAV with the new Sanesecurity
Replies: 1
Views: 1954

Re: ClamAV with the new Sanesecurity

Some more weirdness... When I send the three new Sanesecurity tests to myself through hmailserver, clamd logs them, but they are not marked VIRUS DETECTED. I can send the old scam and phish test files the same way, and they are marked like they should be. However, I can send those same three tests t...
by BrandonH75
2009-01-21 18:52
Forum: Off-topic discussions
Topic: ClamAV with the new Sanesecurity
Replies: 1
Views: 1954

ClamAV with the new Sanesecurity

I'm not sure where to start with this. The sanesecurity email list is busy with some other discussions and I can't get an answer. Maybe someone around here has either noticed this or can point me in the right direction. I've been using a Windows version of ClamAV (from http://oss.netfarm.it/clamav/)...
by BrandonH75
2008-09-09 16:54
Forum: General discussions
Topic: Signatures are not added when replying mails
Replies: 24
Views: 5696

Re: Signatures are not added when replying mails

I received a report yesterday of a user not receiving a couple internal emails that were BCCed to him. I haven't had a chance to look into it further yet.
by BrandonH75
2008-08-14 20:29
Forum: General discussions
Topic: what anti SPAM system do u use?
Replies: 14
Views: 4531

Re: what anti SPAM system do u use?

I also have similar setup to Rainer, but I don't do the HELO check. I also use ClamAV [tbb] with the SaneSecurity and ClamSup ( http://www.sanesecurity.co.uk/clamav/ ) signatures. Very few SPAM emails get past hMail before getting tagged by Clam. I've had very few false-positives...approximately 60 ...
by BrandonH75
2008-07-29 18:52
Forum: User contributed hMailServer 4 scripts
Topic: Automatic whitelisting
Replies: 41
Views: 35401

Re: Automatic whitelisting

I'm trying this out with about 150 users on one domain.

I don't know anything about vbs, but I finally got up enough courage to try using someone's script. So far so good! :D
by BrandonH75
2007-12-28 00:56
Forum: User contributed hMailServer 4 scripts
Topic: hMailCleaner (Compare hMaildatabase with files on disk)
Replies: 18
Views: 32159

I've been thinking I needed something like this for a while. I'm glad I finally found it. :) I'm having an issue with it though. First, I don't know anything about VB. When I run the script it gets up to "Please wait while the files are compared...", then I get the error... "C:\hMailServer\Addons\Ut...
by BrandonH75
2007-11-15 18:11
Forum: General discussions
Topic: bulk-send performance?
Replies: 6
Views: 2316

Yes they did go much faster, averaged over 200/minute with 500 threads.

And CPU utilization was up. It wasn't steady at all, just kept bouncing around. Memory usage didn't increase much at all, maybe 50 MB.

The emails we were sending out weren't very large.
by BrandonH75
2007-11-15 01:06
Forum: General discussions
Topic: bulk-send performance?
Replies: 6
Views: 2316

No, kidding - that's like asking how long a rope is. I prefer "How far can you throw a rock?" :D Have you restarted the hMailServer service after chnaging the number of delivery threads? I had them do this and it righted itself. :P I bumped up the threads to 500 and it was running fine. I tried 100...
by BrandonH75
2007-11-14 23:19
Forum: General discussions
Topic: bulk-send performance?
Replies: 6
Views: 2316

bulk-send performance?

What kind of performance should I be expecting when I'm trying to send 23k emails with hMailServer? I have a box with P4 3.2 GHz, WinXP Pro, 1 GB RAM that is only used for our bulk emailing. We have a major website change happening soon, and we want to send off about 100k emails as quickly as possib...
by BrandonH75
2007-06-22 17:20
Forum: General discussions
Topic: No such folder here...
Replies: 1
Views: 1154

No such folder here...

I've been seeing some strange issues with folders on a couple IMAP accounts lately. One person was moving some folders around when they "suddenly disappeared". I blamed this one on Netscape since it has done that to me before, and I gave her Thunderbird. Now she has a few folders that show up in her...
by BrandonH75
2007-06-19 22:41
Forum: General discussions
Topic: help getting ClamAV to work
Replies: 5
Views: 2531

I did manage to get it hMS working with ClamAV. I'm not sure what I did differently from the last 3 tries though. Windows installed it into the "Program Files (x86)" folder no matter what I entered during the installation, so I just dragged everything to the regular "Program Files" folder, changed t...
by BrandonH75
2007-06-19 19:42
Forum: General discussions
Topic: help getting ClamAV to work
Replies: 5
Views: 2531

help getting ClamAV to work

Hello! I'm new to this whole hMailServer thing as I've been thrown into fixing this problem. I've looked through this forum and haven't been able to find anything that works for me. I hope someone can help me out. Over the weekend our mail server developed the ClamWin clamscan peaking the processor ...