Search found 27 matches

by ssevennm
2012-12-13 09:27
Forum: Development & alpha discussions
Topic: Another small issue with IMAP fetch response 5.4 B1944
Replies: 5
Views: 5700

Re: Another small issue with IMAP fetch response 5.4 B1944

Sweet. The only issue I see is that Jeff Lee's MimeField class doesn't seem to have a method to return all of the Parameters of a MimeField instance only GetParameter to return the value given a known attribute name. This is why I suggested perhaps writing MimeField::GetParameterList() to return the...
by ssevennm
2012-12-13 08:21
Forum: Development & alpha discussions
Topic: Another small issue with IMAP fetch response 5.4 B1944
Replies: 5
Views: 5700

Re: Another small issue with IMAP fetch response 5.4 B1944

http://tools.ietf.org/html/rfc3501#section-4.4 4.4. Parenthesized List Data structures are represented as a "parenthesized list"; a sequence of data items, delimited by space, and bounded at each end by parentheses. A parenthesized list can contain other parenthesized lists, using multiple levels o...
by ssevennm
2012-12-12 22:58
Forum: Development & alpha discussions
Topic: Another small issue with IMAP fetch response 5.4 B1944
Replies: 5
Views: 5700

Re: Another small issue with IMAP fetch response 5.4 B1944

It would appear that in the IMAPFetch::_IteratePartRecursive() in IMAPFetch.cpp (version 4.4.4 source) that just the boundary is set directly as the only attribute: // Add multipart stamp. String sTemp; String sBoundary = oPart->GetBoundary(); sTemp.Format(" \"%s\" (\"BOUNDARY\" \"%s\") NIL NIL", sT...
by ssevennm
2012-12-11 20:57
Forum: Development & alpha discussions
Topic: Another small issue with IMAP fetch response 5.4 B1944
Replies: 5
Views: 5700

Another small issue with IMAP fetch response 5.4 B1944

IMAP fetching in hMS that doesn't return all the attributes of the Content-Type in the response? Take the following: 08 fetch 1 (uid body.peek[header.fields (Content-Type)] bodystructure) * 1 FETCH (UID 1 BODYSTRUCTURE (("TEXT" "PLAIN" ("CHARSET" "US-ASCII") NIL NIL "7bit" 317 7)("MESSAGE" "DELIVERY...
by ssevennm
2012-12-11 20:20
Forum: Development & alpha discussions
Topic: Small issue with IMAP fetch response 5.4 B1942
Replies: 12
Views: 10355

Re: Small issue with IMAP fetch response 5.4 B1942

The c-client libs were also failing on functions that fetch bodystructure because of this error in 5.4 B1944 which is now working correctly in 5.4-B2012093001.

Moving the remaining portion of this post to a new thread... my bad.
by ssevennm
2005-08-05 02:18
Forum: General discussions
Topic: Forwarding rule with Auto-Reply
Replies: 8
Views: 3943

Well, I'll take your word on that. ;-)

As long as auto-reply doesn't loop, I'll be happy. Thanks martin.
by ssevennm
2005-08-05 02:02
Forum: General discussions
Topic: Forwarding rule with Auto-Reply
Replies: 8
Views: 3943

If the From-address in the message envelope is changed, would that change the FROM and TO headers n the message as it is displayed in a mail client? The way it works today is more like a bounce and is appropriate if user2 wants and needs to be able to respond to the original sender. Like you said, i...
by ssevennm
2005-08-05 00:55
Forum: General discussions
Topic: Forwarding rule with Auto-Reply
Replies: 8
Views: 3943

Thanks. Good thinking. So baz sends a message to foo which gets forwarded to bar which auto-replies to baz from bar. If the message is "Hi, bar will be out of the office, so e-mail foo instead" wouldn't that look funny to baz who originally e-mailed foo? Is there a way to make the auto-reply only au...
by ssevennm
2005-08-05 00:38
Forum: General discussions
Topic: Forwarding rule with Auto-Reply
Replies: 8
Views: 3943

Forwarding rule with Auto-Reply

I was wondering if this would be a Bad Thing: foo@domain has a rule to forward all messages with size > 0 to bar@domain.com. bar@domain.com has an auto-reply message set. Message comes in from baz@otherdomain.com to foo which gets forwarded to bar which which sends an auto-reply to whom? If gets the...
by ssevennm
2005-06-28 22:56
Forum: Development & alpha discussions
Topic: BODYSTRUCTURE not returning Content-ID
Replies: 12
Views: 9323

You may, I'll PM you details.
by ssevennm
2005-06-28 22:18
Forum: Development & alpha discussions
Topic: BODYSTRUCTURE not returning Content-ID
Replies: 12
Views: 9323

I like (and appreciate) the timeliness of your fixes, that's all.
by ssevennm
2005-06-28 16:18
Forum: Scripting
Topic: Image in mail does not appear with SM
Replies: 11
Views: 7318

If what you're seeing is an image that says "Unsafe Image Removed" (or something similar), then that is because SquirrelMail will only show images in HTML Mail if the image is included in the message. That is, the image has to be like this: <IMG src="cid:foo"> This was one of the reasons I was repor...
by ssevennm
2005-06-28 01:27
Forum: Scripting
Topic: Image in mail does not appear with SM
Replies: 11
Views: 7318

There is a plug-in that supposedly lets you write HTML mail with IE.

http://www.squirrelmail.org/plugin_view.php?id=209

But I wouldn't know since I don't use IE. :roll:
by ssevennm
2005-06-28 00:01
Forum: Development & alpha discussions
Topic: BODYSTRUCTURE not returning Content-ID
Replies: 12
Views: 9323

I have also confirmed that the BODYSTRUCTURE is including the Content-ID and that images in HTML mail images referenced by cid are showing.

Good job, Martin.

I think I might have to make a donation now. :!:
by ssevennm
2005-06-27 20:49
Forum: Development & alpha discussions
Topic: BODYSTRUCTURE not returning Content-ID
Replies: 12
Views: 9323

You're absolutely correct. I did mean <logo_cid> and not <logo.jpg>. That would have been horrible if I had you fix the bug incorrectly. :wink: I try to make it as painless as possible to fix the bugs, so you might be tempted to just go and fix them right away. And so far, you haven't let us down. T...
by ssevennm
2005-06-27 03:33
Forum: Development & alpha discussions
Topic: BODYSTRUCTURE not returning Content-ID
Replies: 12
Views: 9323

I read it too. It is pretty ugly.

I'll send you the file right away.

Thanks.
by ssevennm
2005-06-27 03:32
Forum: Scripting
Topic: Image in mail does not appear with SM
Replies: 11
Views: 7318

Just to be clear, the two lines I added address the following issue: SquirrelMail not showing images when the preference setting to do so is turned on and the message is viewed in plain text. If a message comes in as HTML mail and/or the option of view HTML mail by default is enabled, that is a diff...
by ssevennm
2005-06-25 16:46
Forum: Scripting
Topic: Image in mail does not appear with SM
Replies: 11
Views: 7318

In addition to the fact that that you have to have image/jpeg and image/gif in the HTTP_ACCEPT request header there is also a problem with <IMG src='cid:'> tags in SquirrelMail do to the Content-ID tags not getting sent from hMailServer. I've reported this here: http://www.hmailserver.com/forum/view...
by ssevennm
2005-06-24 23:11
Forum: Development & alpha discussions
Topic: BODYSTRUCTURE not returning Content-ID
Replies: 12
Views: 9323

Well, as you probably already know, the code that's doing this is in IMAPFetch::_GetPartStructure(). Not having a windows development enviornment at my disposal, I hesitate to suggest a fix, though it looks like a NIL is hardcoded and a Content-ID isn't being written. Any change you could look at th...
by ssevennm
2005-06-24 22:00
Forum: Development & alpha discussions
Topic: BODYSTRUCTURE not returning Content-ID
Replies: 12
Views: 9323

RFC822 Message body Received: FROM [192.168.0.2] BY foo.bar.com with hMailServer ; Fri, 24 Jun 2005 12:23:24 -0600 Received: from localhost ([192.168.0.245]) by foo.bar.com with Microsoft SMTPSVC(6.0.3790.211); Fri, 24 Jun 2005 12:23:22 -0600 Date: Fri, 24 Jun 2005 12:23:21 -0600 Return-Path: maile...
by ssevennm
2005-06-24 21:53
Forum: Development & alpha discussions
Topic: BODYSTRUCTURE not returning Content-ID
Replies: 12
Views: 9323

BODYSTRUCTURE not returning Content-ID

Martin, Doing a FETCH of the BODYSTRUCTURE is NOT returning the Content-ID. It's also not returning the correct Content-Disposition. An example of an alternative text/plain, text/html message with one inline image that is used as an <img src="cid:my_image"> follows: BODYSTRUCTURE ( ( ( "TEXT" "PLAIN...
by ssevennm
2005-06-22 18:21
Forum: Scripting
Topic: Admin through MySQL...
Replies: 2
Views: 2335

After reading the thread before this, it would seem it is possible if the item ins't cached. http://www.hmailserver.com/forum/viewtopic.php?t=2011 I would also be interested in a feature to force the server to clear its cache without restarting (and without going through COM). :wink: Any other comme...
by ssevennm
2005-06-22 18:18
Forum: Scripting
Topic: Admin through MySQL...
Replies: 2
Views: 2335

Admin through MySQL...

Is it possible to do administration by accessing the MySQL database directly? For example, is it possible to change the password of a user (encrypt the new password and update the row) without going through the COM object. I ask because I'd like to be able to change the password, add domains and use...
by ssevennm
2005-06-21 17:26
Forum: Scripting
Topic: PERMANENTFLAGS always an empty set?
Replies: 5
Views: 3292

It happens. We all frequently work late at night with little sleep. No, I'm not a SquirrelMail developer, but I do like to checkout the CVS versions and see what's going on so I can make useful bug reports. *grin* Just trying to get it all to work together. I unfortunately am running on OS X Server ...
by ssevennm
2005-06-21 16:46
Forum: Scripting
Topic: PERMANENTFLAGS always an empty set?
Replies: 5
Views: 3292

Problem fixed with hMS 4.0 build 117.
by ssevennm
2005-06-21 16:37
Forum: Scripting
Topic: PERMANENTFLAGS always an empty set?
Replies: 5
Views: 3292

Thanks for getting a new build out so fast. The problem only appears in the 1.5.1 CVS build of SquirrelMail. It integrates the msg_flags plugin into the core. In prior versions, the buttons were shown even if the server would only be changing the flags session-only: echo getButton('SUBMIT', 'markRea...
by ssevennm
2005-06-21 02:22
Forum: Scripting
Topic: PERMANENTFLAGS always an empty set?
Replies: 5
Views: 3292

PERMANENTFLAGS always an empty set?

This can't possibly be what is intended. (?) xxx SELECT INBOX * 17 EXISTS * 0 RECENT * FLAGS (\Deleted \Seen \Draft \Answered \Flagged) * OK [UIDVALIDITY 27] * OK [UNSEEN 58] * OK [PERMANENTFLAGS ()] xxx OK [READ-WRITE] SELECT completed With the 1.5.x builds of SquirrelMail, features like Mark Read,...