Search found 148 matches

by mcampbell
2006-03-29 23:40
Forum: General discussions
Topic: Messages in hm_Messages
Replies: 0
Views: 1862

Messages in hm_Messages

I did a quick search for this and didn't really find anything though I may have overlooked something, sorry if I did. I noticed in my hm_Messages table there are 900+ rows of messages that haven't been picked up yet by the users. maybe out of all of them 5 ot 6 are users who are still active, the re...
by mcampbell
2005-12-28 23:30
Forum: General discussions
Topic: "550 The address is not valid..."
Replies: 16
Views: 14631

You would think so. The problem in the first place is getting them to respond to any english messages. I have been told they respond to korean mail quickly but I dont know korean so I cant verify that myself. Why not try using bablefish http://babelfish.altavista.com/translate.dyn and send them a s...
by mcampbell
2005-11-30 04:02
Forum: Off-topic discussions
Topic: Zimbra integration
Replies: 3
Views: 5426

I'm testing Zimbra on my linux box now. I like what I see and I'm sorry to say that this may mean a move away from HMailserver. Zimbra is a mailserver as well as other things so integrating it with HMail is somewhat redundent not to mention a pain because of the two different platforms. Maybe my com...
by mcampbell
2005-11-17 23:40
Forum: General discussions
Topic: Spam recommendations?
Replies: 13
Views: 7013

I think I'm using Pre ver 1 because of a bug that was giving me issues in 1.0 I shall have to upgrade this weekend and test it out. I should also point out that I was wrong is saying the email is deleted instead of rejected, thank you for clarifying that. I rebuild my DB once a day and I alslo must ...
by mcampbell
2005-11-17 20:43
Forum: General discussions
Topic: Spam recommendations?
Replies: 13
Views: 7013

I use ASSP with HMail and it does mark a lot the spam as spam. My problem is that because my users don't update the enigne but sending non-spam that was flagged as spam and visa-versa back to the server so it can learn from mistakes. This has made it so I can't turn it off test mode (where it just f...
by mcampbell
2005-11-16 23:35
Forum: General discussions
Topic: Empty Sender Address
Replies: 12
Views: 5817

no only SMTP Auth is required for outside IPs trying to send mail, IE when someone is going through the webmail client.
by mcampbell
2005-11-16 22:24
Forum: General discussions
Topic: Empty Sender Address
Replies: 12
Views: 5817

I have empty sender addresses allowed but I can't send a "read recepit" message to anyone that requests one that isn't a local domain user. Is there some setting I should look at for that as well? I'm sorry I don't have the error message in front of me to tell you what is displays.
by mcampbell
2005-11-11 21:31
Forum: General discussions
Topic: sender mx-record
Replies: 2
Views: 2310

Oh okay I see. Well in that case then it's probably due to the fact that we use a server here for DNS and forward anything that isn't found to our ISPs DNS. I have MX records for the mailserver in the local DNS but they point to the private IP address instead of our public IP address.
by mcampbell
2005-11-11 20:31
Forum: General discussions
Topic: sender mx-record
Replies: 2
Views: 2310

sender mx-record

I noticed that if I check off under SMTP "check if sender has DNS MX-Record" that local users can't send email, they get an error saying that there is no MX-Record. I thought this option was to check the incoming mails sender address for a valid MX record. Am I missing something? BTW sorry if this w...
by mcampbell
2005-11-09 20:39
Forum: General discussions
Topic: SMTP Problems
Replies: 23
Views: 12163

I have to give you credit Martin. I probably would have pulled my network connection out of the wall long ago if I was doing this project. I haven enough grief with my own users, nevermind the public.
by mcampbell
2005-11-09 20:27
Forum: General discussions
Topic: No Port 25 access after Windows update? (Kind of Urgent)
Replies: 8
Views: 3955

gettings things wrong is how one learns but a word of advice. DON'T have any server set to auto-install windows patches. You should always review each patch before installing it. Plus if the server crashes from the patch being installed you'll know (more easily then not) which one of the patch or pa...
by mcampbell
2005-11-07 23:28
Forum: Archived feature requests
Topic: Email archiving
Replies: 34
Views: 35347

The message must be stored including headers. Any incoming or outgoing email is subject to archiving and the messages should (must) be stored using encryption so that the orignal contents can not be altered. There should also be an audit trail showing who has done what with the archive and when. Thi...
by mcampbell
2005-11-07 17:25
Forum: Archived feature requests
Topic: Email archiving
Replies: 34
Views: 35347

Email archiving

With all the talk of government coming down on companies who don't archive and retain emails (sent and received) I was wondering if there were any plans to include a way to archive emails with retention rules for deleteing, etc? I've looked at 3rd party solutions but before I commit to something lik...
by mcampbell
2005-08-25 18:52
Forum: Archived feature requests
Topic: Shared Address Book
Replies: 16
Views: 12331

I've tried the LDAP approach, either I'm doing something wrong or it's not really that great of a solution. Using that method you can search for a person but they're not really listed in a address book for you to see like when you click on the "To" button to add people. An LDAP search is fine for me...
by mcampbell
2005-08-25 15:45
Forum: Archived feature requests
Topic: Shared Address Book
Replies: 16
Views: 12331

Shared Address Book

I searched the form and found some older posts that deal with this but I wanted to bring it up again. A lot of people want shared folders, I just want a public or shared address book. Our company seems to always be changing employees, by the time I've set them up with an email address and everything...
by mcampbell
2005-07-12 20:54
Forum: Scripting
Topic: #services# missing / Actual Mailbox size PHPWebAdmin 4.0
Replies: 2
Views: 2734

yep that took care of it.
by mcampbell
2005-07-12 20:53
Forum: Scripting
Topic: PHPWebAdmin 4.0B125
Replies: 20
Views: 14198

Yep that was it.
I know there was a problem with the Max Size for mailboxes being different then what HMail admin showed and HMailAdmin was correct over PHPWebAdmin. Is that all fixed in this verison too?

Thanks as always Martin!
by mcampbell
2005-07-12 16:56
Forum: Scripting
Topic: PHPWebAdmin 4.0B125
Replies: 20
Views: 14198

PHPWebAdmin 4.0B125

Is anyone else having a lot of issues with WebAdmin in the new 4.0 125 build? When I edit a user (like max mailbox size) and click save it just goes to a blank page and doesn't save the changes. Clicking on the "edit" link from the Account listing screen just goes to a blank page (same if you click ...
by mcampbell
2005-07-12 16:47
Forum: Scripting
Topic: #services# missing / Actual Mailbox size PHPWebAdmin 4.0
Replies: 2
Views: 2734

#services# missing / Actual Mailbox size PHPWebAdmin 4.0

When I'm on the Server page in PHPWebAdmin (HM 4.0B125) It says in a couple of places: #services# Missing - english.lang Also the "Actual Size" for the account list under the domains area seems to be rounding to the 16th place? Now that's what I call detailed system information! I already did a full...
by mcampbell
2005-06-01 18:30
Forum: General discussions
Topic: dnsbl problems
Replies: 12
Views: 4813

Are you sure that one of your users isn't spamming or maybe one of those machines inside the network is infected as a spam-bot?
by mcampbell
2005-06-01 14:55
Forum: General discussions
Topic: Best Practice: Large Email Attachements - How?
Replies: 2
Views: 2039

Martin would know best but I think you may be able to do something like this with ver 4.0 and a VB script.
by mcampbell
2005-05-31 16:03
Forum: General discussions
Topic: oh that darn blank page in PHPwebAdmin!
Replies: 3
Views: 2234

Sounds like your using the cgi mod instead of ISPA. I would suggest an upgrade and using ISPA (if you can) as there is less overhead and I believe it is more secure. Then comment out your "doc_root" line in php.ini
by mcampbell
2005-05-24 18:30
Forum: General discussions
Topic: install/configure PHPWebAdmin
Replies: 11
Views: 7740

Try commeting out the "doc_root" line in your php.ini file I had the same problem but commeting that line makes it all work. (though I have IIS)
by mcampbell
2005-05-23 21:45
Forum: Development & alpha discussions
Topic: When stable?
Replies: 11
Views: 8600

1000 eh? Seems like a good number but how long do you think it would take to get to that point? Usually I'll download the "unstable" version if it's over 300 downloads and the forums have been pretty quite with bug reports.
by mcampbell
2005-05-23 21:39
Forum: General discussions
Topic: mail passing for unknown users
Replies: 23
Views: 13511

if you received the mail for an unknown user, are you setup as the catch-all address (postmaster) for that domain? All thet mail will go to that account. I also noticed it looks like you have ASSP, what do you have your "Accept All Mail" setting under Relaying? These should only be set to your local...
by mcampbell
2005-05-20 21:25
Forum: Development & alpha discussions
Topic: 550 error
Replies: 3
Views: 4503

That means you DNS doesn't have an mx record:
DNS for eample.com

Host www [ip of server]
host mail [ip of mail server]

mx mail.example.com

you could also type nslookup -type=ANY yahoo.com
from a windows prompt to check out a real DNS record
by mcampbell
2005-05-20 18:40
Forum: Development & alpha discussions
Topic: Internal counter instead of DB auto_increment
Replies: 24
Views: 17083

Well Martin I think you've defended your choice quite well. Like I said in my prev. post, whatever works, works for me and it can only help HMail in the long run when improving things.
by mcampbell
2005-05-20 16:40
Forum: Development & alpha discussions
Topic: Internal counter instead of DB auto_increment
Replies: 24
Views: 17083

I think the max() function would work too in this case because you don't have to worry about multiple "writers" to the DB in Hmail right? If I'm correct in my thinking HMail controls all the writing access and only has one write going at one time.
by mcampbell
2005-05-20 16:26
Forum: Development & alpha discussions
Topic: Internal counter instead of DB auto_increment
Replies: 24
Views: 17083

So if you store the counter in memory and have to reboot, when HMail restarts it will poll the DB for all needed counter information to set it back up in memory? Works for me and would probably speed things up in large installations like some people have been asking about lately without much of an i...
by mcampbell
2005-05-18 20:35
Forum: Development & alpha discussions
Topic: Testing in the real world...
Replies: 10
Views: 7928

If his current Mail Server Prog has a mirror address then couldn't he set that for an email address on the HMail server. Yes it would only send the emails to a single address on HMail but if that's not an incoming stress then I'll be damned. It's taking everything you get and forcing it to a single ...
by mcampbell
2005-05-17 15:03
Forum: Off-topic discussions
Topic: German SPAM
Replies: 9
Views: 6427

I've been lucky not to see this yet. My ASSP stats show a normal load of blocked SPAM (around 40%) but once again my blocked relay attempts are up to almost 100% again, though that's still small compared to the 3000% and 4000% that I was getting earlier this year. I have noticed a lot of probing on ...
by mcampbell
2005-05-16 17:15
Forum: Archived feature requests
Topic: Reconnect if database is down
Replies: 5
Views: 4953

It's just a good idea to have this feature even if you don't need it. There should be a limit, like 5 tries before it considers the error fatal or something.
by mcampbell
2005-05-12 19:54
Forum: General discussions
Topic: SMTP & POP parameters
Replies: 10
Views: 4488

That's one way but the easiest would to just set the servers based on IP. IE: SMTP Server is 192.168.0.5 POP3 Server is 192.168.0.4 You would use those settings in Outlook Otherwise as long as you have a W2k or W2k3 Server with DNS installed you can setup those domains as you want (smtp.demolad.fr a...
by mcampbell
2005-05-11 18:42
Forum: General discussions
Topic: SMTP & POP parameters
Replies: 10
Views: 4488

Okay...I think I get you now. I tried demolad.fr but get a "Can not find server" error so I'm guessing you haven't registered that domain name yet or aren't point it to anything. In order to use demolad.fr you need to have it registered and pointing to your servers public IP Address. There's tutoria...
by mcampbell
2005-05-11 16:54
Forum: General discussions
Topic: SMTP & POP parameters
Replies: 10
Views: 4488

They would be as you have set them up in your DNS settings. A lot of (smaller) places use just mail.domainname.com. That points to your mail servers public IP address. If you are just using HMail as a in between server and sending the mail via a realy, checking via the external POP3 option then you ...
by mcampbell
2005-05-11 14:43
Forum: Scripting
Topic: Webmail with hMailServer
Replies: 11
Views: 7745

I answered these question in the reply to the PM you sent.
by mcampbell
2005-05-11 14:40
Forum: General discussions
Topic: problem with outlook express
Replies: 4
Views: 2935

I don't think that's going to help if his router is the issue. I don't understand how people post a question and then never bother to come back and check if they got an answer or need to reply again in regular intervals. I'm here like every hour.
by mcampbell
2005-05-10 20:24
Forum: Scripting
Topic: PHPWebAdmin
Replies: 3
Views: 3053

after all that I finally get in there and I'm like...Wow, fancy interface. Well that was nice...
I guess it will come in handy though for those days when I don't want to get up and go to the server to add/change users.
by mcampbell
2005-05-10 20:08
Forum: Scripting
Topic: PHPWebAdmin
Replies: 3
Views: 3053

Well slap me silly that did the trick. Thanks Martin! Don't know how I overlooked that one in all my searches of the forum.
by mcampbell
2005-05-10 19:16
Forum: Scripting
Topic: PHPWebAdmin
Replies: 3
Views: 3053

PHPWebAdmin

Alright...one more time. I got PHPWebmail "working" except for after I enter my login info and click Logon I get an "HTTP 405 - Resource not allowed" error page. I have the template_c and temp folders and gave IUSR Write permission to them. Files are appering in the temp folder too but this is a far...
by mcampbell
2005-05-10 19:10
Forum: Scripting
Topic: Webmail with hMailServer
Replies: 11
Views: 7745

humm, that's a good question. I run multiple domains but onle have 1 setup of SQMail. Since all my domains are on a single machine, you should just be able to enter a single domain/mail server for one instance of SQMail in the config and it will work. I would get one all setup and test it out. If yo...
by mcampbell
2005-05-10 17:55
Forum: Scripting
Topic: Webmail with hMailServer
Replies: 11
Views: 7745

Just unzip to your webroot or even the C drive and point either a virtual site or new site in IIS to that directory. You'll want to have Perl installed too just to make thing easier, and every webserver should have it anyway. Then just go into the sqmail/config directory and run config.pl (from a co...
by mcampbell
2005-05-10 14:52
Forum: Scripting
Topic: Webmail with hMailServer
Replies: 11
Views: 7745

have you tried squirrelmail?
People here have made mods for it just for HMail and it's very easy to implement. I'm tried Horde/IMP and wasn't happy with it's speed and there are def. problems with its setup including crappy documentation.
by mcampbell
2005-05-09 16:53
Forum: General discussions
Topic: problem with outlook express
Replies: 4
Views: 2935

just a hunch here, because as Martin said that whole thing is VERY confusing, but did you have any static routing on your router? Also when you say you can log into webmail, is this from an outside your network...IE does your DNS send you outside your network on a public IP to your own server, just ...
by mcampbell
2005-05-05 14:25
Forum: Archived feature requests
Topic: queue management
Replies: 4
Views: 5157

unless you are sending massive amount of outgoing email at once it can be very hard to stop the mail even with a que. Some sort of send delay option would also have to be added.
by mcampbell
2005-05-05 03:56
Forum: Off-topic discussions
Topic: Web site problems
Replies: 4
Views: 4343

that gives new meaning to "computer closet"
by mcampbell
2005-05-05 03:49
Forum: Scripting
Topic: PHPWebAdmin
Replies: 15
Views: 8783

I finally figured this out, in case it's still an issue for anyone now or later. If you're running IIS it seems better to just comment out the doc_root path in php.ini. My next problem is after I log in I get a 405 error "resouces denied" I have the temp and template_c and both have modify/write per...
by mcampbell
2005-04-29 19:24
Forum: Development & alpha discussions
Topic: New build...
Replies: 8
Views: 6507

No way man, the first time one of your alpha or beta releases crashes my servers I'm coming after you! LOL :wink:
by mcampbell
2005-04-29 17:48
Forum: Off-topic discussions
Topic: Where did the screenshots go?
Replies: 11
Views: 8427

No No, firefox is def slower on my personal machine too. I still use IE at work though. I still like IE over firefox (except for the tabbed browsing, love that!) but on my home machine there is some adware somewhere that nothing has been able to remove including my own manual serach and destroy miss...
by mcampbell
2005-04-25 20:33
Forum: Archived feature requests
Topic: "On the fly" email alias creation
Replies: 27
Views: 24018

This would be great. Being the Admin I can add my own aliases at anytime via my desktop/server connections but having this feature for everyone and not having to worry about having 100 alaises is perfect.
by mcampbell
2005-04-22 01:39
Forum: Archived feature requests
Topic: AWStats support
Replies: 25
Views: 33233

I Don't really need the feature but I voted yes anyway because it would be something nice to have. With ASSP I get an overall idea of my traffic and can see the logs there but it would be nice to see in a grid like that senders/receivers and errors. Would also be helpful when answer other users ques...
by mcampbell
2005-04-21 22:38
Forum: Scripting
Topic: PHPWebAdmin
Replies: 15
Views: 8783

Do we maybe need to use PHP 5.0.3, I'm using 4.3.11 and jbardi is using 5.0.2 and we both have the same problem.
Is anyone NOT getting a blank page when going to the main PHPWebAdmin url that isn't using PHP 5.0.3?
by mcampbell
2005-04-21 22:26
Forum: Development & alpha discussions
Topic: For the new version
Replies: 9
Views: 7871

No offence to those who use it but Sharpmail looks like crap compared to SquirrelMail, at least as far as I can tell from the screenshots. To each his own though.

Martin: Maybe it's time to start another new side project, hWebMail. :D
by mcampbell
2005-04-21 22:21
Forum: General discussions
Topic: Production environment with Hmailserver
Replies: 4
Views: 3107

We have Win2K with about the same amount of users as you. Our mail traffic is on the medium-light side but I've never had a problem with HMail. I do suggest setting it so that SQL is a dependency of HMail in services that way if the server has to be restarted you don't have to worry about HMail fail...
by mcampbell
2005-04-20 17:17
Forum: Scripting
Topic: PHPWebAdmin
Replies: 15
Views: 8783

I created both those directories and revisted each step. I too get a blank page when I go to my url.
index.php is set as an allowed default document in IIS as well as PHP extenstions added to the home directory configuration and all that. I know my PHP is working fine because SQMail works fine.
by mcampbell
2005-02-07 17:06
Forum: General discussions
Topic: Newbie Basic Questions
Replies: 21
Views: 8273

Glad to see it's working but jsut to conform with 99% of the internet you may want to think about adding another host record called 'mail' on your public DNS. The mail host should point to the same IP as mydaomin.com does. This will give you that mail.mydomain.com working address. You may have to th...
by mcampbell
2005-02-07 16:10
Forum: General discussions
Topic: keep getting this bad password error
Replies: 18
Views: 8804

It's doable if you have a public IP Address assigned to that box and (if you have a firewall/router) open and map port 80 from that public IP to that boxes private IP Address. There may be some permission issues to deal with after that but it all depends on how everything was setup.
by mcampbell
2005-02-04 19:29
Forum: General discussions
Topic: PHP
Replies: 2
Views: 1943

Could that be the reason why I'm able to login to Squirrelmail but then after the login screen comes up and it opens to what should be the mailbox list it says "Bad Password?" I know I'm getting into squirrlemail okay because I see my custom colors show up instead of the usually white screen with "B...
by mcampbell
2005-02-04 19:27
Forum: General discussions
Topic: keep getting this bad password error
Replies: 18
Views: 8804

Do you have "My Server Requires Authentication" check off in you account setup in outlook? If so is SMTP Authenticaiton required checked off in HMailAdmin? And finally if both are true did you enter your information into outlook for the outgoing server (username/password)?
by mcampbell
2005-02-02 19:04
Forum: Scripting
Topic: New squirrelmail package fixes several vulnerabilities
Replies: 8
Views: 7893

Thanks for the info.