Messages allways pendings and a extra "<" in sender address

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
kemistry
New user
New user
Posts: 2
Joined: 2009-01-24 14:54

Messages allways pendings and a extra "<" in sender address

Post by kemistry » 2009-01-24 15:19

Hi,
i've installed hMailServer and RoundCube on a Windows Web Server 2008,
it was a total mess up , with all php/pear installation etc etc
but i managed to have it work.
So the problem is that mail are not going to the outside !
i managed to recieve mail from either google or hotmail, but when i send an email ,
nothing happens.
I've looked to the hmailserver admin and it says that my message were treated but they are pending...
so i look in the logs, and sometimes i have "Syntax error" response from the recipient server (google or hotmail), it seems that every sender address has an extra "<" in front of it !!
so sometimes it give something like this : FROM : <<jeremy@kemistrylabs.com>
:lol:
and in the admin , of course, in the "sender" column all senders have also the extra "<" :S
I don't know what to do, i am lost , do you have an idea where it may come from ?

Thanks, and hmailserver is great :) love it

User avatar
mattg
Moderator
Moderator
Posts: 20272
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Messages allways pendings and a extra "<" in sender address

Post by mattg » 2009-01-24 15:57

What happens when you use another mail client, like say thunderbird or outlook express or windows mail?

Do you have any logs that you can show? really we are just guessing without logs?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

kemistry
New user
New user
Posts: 2
Joined: 2009-01-24 14:54

Re: Messages allways pendings and a extra "<" in sender address

Post by kemistry » 2009-01-25 03:36

Hi,
Thank you for your answer.
i cannot use it with other mail client , i only have a mac right now and i don't know how to configure the mail app lol..
Here is some log :
"DEBUG" 3944 "2009-01-24 23:46:26.186" "SD::_InitiateExternalConnection"
"DEBUG" 3944 "2009-01-24 23:46:26.186" "Socket::Socket(ID:1297, Addr=34449832)"
"DEBUG" 2244 "2009-01-24 23:46:26.228" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 2244 1297 "2009-01-24 23:46:26.228" "209.85.219.187" "RECEIVED: 220 mx.google.com ESMTP 12si21021394ewy.78"
"SMTPC" 2244 1297 "2009-01-24 23:46:26.228" "209.85.219.187" "SENT: HELO kemistrylabs.com"
"DEBUG" 2244 "2009-01-24 23:46:26.229" "SMTPClientConnection::~_ParseASCII() - 2"
"DEBUG" 2244 "2009-01-24 23:46:26.253" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 2244 1297 "2009-01-24 23:46:26.253" "209.85.219.187" "RECEIVED: 250 mx.google.com at your service"
"SMTPC" 2244 1297 "2009-01-24 23:46:26.253" "209.85.219.187" "SENT: MAIL FROM:<<jeremy@kemistrylabs.com>"
"DEBUG" 2244 "2009-01-24 23:46:26.253" "SMTPClientConnection::~_ParseASCII() - 4"
"DEBUG" 2244 "2009-01-24 23:46:26.274" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 2244 1297 "2009-01-24 23:46:26.274" "209.85.219.187" "RECEIVED: 555 5.5.2 Syntax error. 12si21021394ewy.78"
"DEBUG" 2244 "2009-01-24 23:46:26.275" "SMTPClientConnection::~_ParseASCII() - 5"
"DEBUG" 2976 "2009-01-24 23:48:26.171" "PersistentMessage::ReadObject()"
"DEBUG" 2976 "2009-01-24 23:48:26.172" "PersistentMessage::~ReadObject()"
"DEBUG" 2900 "2009-01-24 23:48:26.195" "SD::DeliverMessage"

can you see the extra "<" ?? just in front of "jeremy@kem..."

Seeya

User avatar
mattg
Moderator
Moderator
Posts: 20272
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Messages allways pendings and a extra "<" in sender address

Post by mattg » 2009-01-25 14:45

I'd guess that it is a configuration error in your roundcube setup.

What do the people at the roundcube forum say?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Thomas Parvais
Normal user
Normal user
Posts: 111
Joined: 2004-12-17 12:21
Contact:

Re: Messages allways pendings and a extra "<" in sender address

Post by Thomas Parvais » 2009-11-12 00:30

Hello
I have exactly the same trouble with roundmail.... there is a extra "<" in the command FROM:<<thomas@parvais.com>"

Some SMTP server over pass this error but gmail refuses and stop the SMTP connection.

very strange

Have you succeed to find the solution ? I'll also check on roundcube

Thomas
Interrested by Law & new technologies ?
Intéressé par le droit de l'internet et des nouvelles technologies ?
Visit/Visitez http://www.droit-technologie.org

Thomas Parvais
Normal user
Normal user
Posts: 111
Joined: 2004-12-17 12:21
Contact:

Re: Messages allways pendings and a extra "<" in sender address

Post by Thomas Parvais » 2009-11-12 00:57

Thomas Parvais wrote:Hello
I have exactly the same trouble with roundmail.... there is a extra "<" in the command FROM:<<thomas@parvais.com>"

Some SMTP server over pass this error but gmail refuses and stop the SMTP connection.

very strange

Have you succeed to find the solution ? I'll also check on roundcube

Thomas
I thing I found it.... missing SMTP config in roudcube.... strange that a lot of emails were ok but some not

Thomas
Interrested by Law & new technologies ?
Intéressé par le droit de l'internet et des nouvelles technologies ?
Visit/Visitez http://www.droit-technologie.org

Post Reply