Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Greylisting bug or feature?
PostPosted: 2009-02-10 07:37 
Normal user
User avatar

Joined: 2005-07-20 17:08
Posts: 125
Location: Catawissa, PA
i have been receiving a significant amount of spam that is address to me@mydomain.com and it also has a sender address of me@mydomain.com. Normally SA and/or hMail's spam protection catches it and it is dumped into my spam folder. But i got curious as to why so much was getting past the gray list. I picked a few messages and went to look up their IP in the gray list table and to my surprise there wasn't an entry for them. Upon further inspection I discover that there was no entries where glsenderaddress was set to mydomain.com.

So is this behaivor expected or is it a bug? It seems like a bug to me...at least i can't think of a reason that it should do this.

Thanks
Peter


Top
 Profile  
 
 Post subject: Re: Greylisting bug or feature?
PostPosted: 2009-02-10 07:57 
Moderator
User avatar

Joined: 2007-06-14 05:12
Posts: 11350
Location: 'The Outback' Australia
Peter,

Have you upgraded to Ver 5 yet?

I think that this was related to the way that mail with a local from address bypassed the ANTI-SPAM tests. I believe that this is amended in the way that Ver 5 handles these connections.

You could also look at the first script here, to force those with a local from address authenticate - http://www.hmailserver.com/documentatio ... eptmessage

Matt

_________________
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
Documentation


Top
 Profile  
 
 Post subject: Re: Greylisting bug or feature?
PostPosted: 2009-02-10 08:04 
Normal user
User avatar

Joined: 2005-07-20 17:08
Posts: 125
Location: Catawissa, PA
mattg wrote:

Have you upgraded to Ver 5 yet?

I think that this was related to the way that mail with a local from address bypassed the ANTI-SPAM tests. I believe that this is amended in the way that Ver 5 handles these connections.

Yes i am on the latest 5.0 build

mattg wrote:
You could also look at the first script here, to force those with a local from address authenticate - http://www.hmailserver.com/documentatio ... eptmessage



Although this would probably fix the issue it doesn't explain the gray list behavior.


Top
 Profile  
 
 Post subject: Re: Greylisting bug or feature?
PostPosted: 2009-02-10 08:05 
Moderator
User avatar

Joined: 2007-06-14 05:12
Posts: 11350
Location: 'The Outback' Australia
What do you have set in your IP ranges?

_________________
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
Documentation


Top
 Profile  
 
 Post subject: Re: Greylisting bug or feature?
PostPosted: 2009-02-10 08:11 
Normal user
User avatar

Joined: 2005-07-20 17:08
Posts: 125
Location: Catawissa, PA
i have one range for the internet and one for my lan--this is not the issue--all the mail in question would get included in the internet category which i know is gray listing other mail correctly.


Top
 Profile  
 
 Post subject: Re: Greylisting bug or feature?
PostPosted: 2009-02-10 08:23 
Moderator
User avatar

Joined: 2007-06-14 05:12
Posts: 11350
Location: 'The Outback' Australia
So is your domain in the whitelist or even the greylist...whitelist

_________________
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
Documentation


Top
 Profile  
 
 Post subject: Re: Greylisting bug or feature?
PostPosted: 2009-02-10 15:31 
Normal user
User avatar

Joined: 2005-07-20 17:08
Posts: 125
Location: Catawissa, PA
neither


Top
 Profile  
 
 Post subject: Re: Greylisting bug or feature?
PostPosted: 2009-02-10 16:10 
Developer

Joined: 2003-11-21 01:09
Posts: 6403
Location: Sweden
In hMailServer 5.0 grey listing isn't applied on local senders. Not sure why it was implemented this way (it was deliberate but ..) so it has been changed in v5.1 to always be done unless the sender is authenticated. (It's changed in the 5.1 alphas already available)


Top
 Profile  
 
 Post subject: Re: Greylisting bug or feature?
PostPosted: 2009-02-10 16:47 
Normal user
User avatar

Joined: 2005-07-20 17:08
Posts: 125
Location: Catawissa, PA
k thanks

i don't really want to run an alpha release maybe when it goes to beta


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 


Who is online

Users browsing this forum: No registered users and 2 guests



Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group