Post new topic Reply to topic  [ 92 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-12 19:01 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Bill48105 wrote:
FiShBuRn wrote:
The version of my file is 5.0.2195.7280

Hmm so yours is likely newer. Either microsoft broke something in newer version or that is not it. :D

Btw my rough method of rebuilding file paths was:
Need to grab messageacccountid from hm_messages & lookup their account & domain from hm_accounts using that then update messagefilename in hm_messages to prepend DatafolderPath\theirdomain\theiraccount\originalfilename.eml & repeat for every message in hm_messages likely only doing ones that have messagetype = 2 which means delivered

In either case I'd have backups of your database & realize it is very risky.. I'd certainly test on a test server 1st. :D once paths are fixed (view some ot make sure they look right) then the other changes between 5.3.x & 5.4 shouldn't matter or are less critical. I thought I posted them up but you can view the upgrade SQL file in the DBScripts folder inside the hmail folder. You definitely need to manually change the db version value though. Then you should be able to install 5.3.4 over 5.4, select your existing database & cross your fingers. (Again I'd do trial runs on test server, even if using backups from your real server..)


Once im able to finish him i will post here...indeed, i will stop hmail and make a full backup including sql dump then i will rollback and if anything goes wrong at least im able to get 5.4 ready to rock again...

When u say "manually change db version" is to 5320 value right?


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-12 21:06 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
FiShBuRn wrote:
Once im able to finish him i will post here...indeed, i will stop hmail and make a full backup including sql dump then i will rollback and if anything goes wrong at least im able to get 5.4 ready to rock again...

When u say "manually change db version" is to 5320 value right?


You'd match whatever version you were planning to install.

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-13 10:37 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Thanks Bill, the script is almost done i only have one problem that is creating the "\\" in file path, when i run the script they are not created :s any idea?


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-13 12:15 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Well i had to make this in other way:

Code:
UPDATE
   hm_messages    
SET
   messagefilename = (SELECT CONCAT('C:\\Programas\\hMailServer\\Data\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', -1),'\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', 1),'\\', SUBSTR(hm_messages.messagefilename,2,2),'\\', hm_messages.messagefilename) caminho
               FROM hm_accounts
               WHERE hm_messages.messageaccountid = hm_accounts.accountid and hm_messages.messagetype = 2
              )
WHERE EXISTS
  (
     SELECT CONCAT('C:\\Programas\\hMailServer\\Data\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', -1),'\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', 1),'\\', SUBSTR(hm_messages.messagefilename,2,2),'\\', hm_messages.messagefilename) caminho
               FROM hm_accounts
               WHERE hm_messages.messageaccountid = hm_accounts.accountid and hm_messages.messagetype = 2
  );

It looks OK from the test ive made and compare, what do you think Bill?


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-13 14:24 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
Cool. Did you test it on a test server? :D

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-13 14:48 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Ive tested only in DB not with hmail running...ive compared with a DB after the upgrade and seems to match.

I cant do this at business hours so ive to wait until night...


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-13 15:46 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
OK cool just checking cuz obviously could get VERY ugly if you muck up your database. :D Btw you test on a copy/dump of your actual database just to be sure? In case there is something odd about your database..

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-13 16:09 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Bill48105 wrote:
OK cool just checking cuz obviously could get VERY ugly if you muck up your database. :D Btw you test on a copy/dump of your actual database just to be sure? In case there is something odd about your database..


yeap, my tests were made on an actual database. Before do anything later i will backup every thing so if got any error for sure i can return to 5.4.


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-13 17:10 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
FiShBuRn wrote:

yeap, my tests were made on an actual database. Before do anything later i will backup every thing so if got any error for sure i can return to 5.4.

ok cool so if you did tests on copy of actual database did you also try changing db version value & installing 5.3.4 to see if it actually works? :D

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-13 18:48 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Bill48105 wrote:
FiShBuRn wrote:

yeap, my tests were made on an actual database. Before do anything later i will backup every thing so if got any error for sure i can return to 5.4.

ok cool so if you did tests on copy of actual database did you also try changing db version value & installing 5.3.4 to see if it actually works? :D


I loved to test that sitation but i cant :/ lets hope that will be not a problem...


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-13 19:27 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
FiShBuRn wrote:
I loved to test that sitation but i cant :/ lets hope that will be not a problem...

Why not? Copy (dump) database over & test as if that was your live server. :)

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-14 12:57 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Bill48105 wrote:
FiShBuRn wrote:
I loved to test that sitation but i cant :/ lets hope that will be not a problem...

Why not? Copy (dump) database over & test as if that was your live server. :)


Ok Bill, full test made, all went OK, installed hmailserver, copy Data folder, db dump, just fine and then checked some email and OK :D

Lets hope it run just fine in the main server.


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-14 13:15 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
FiShBuRn wrote:
Ok Bill, full test made, all went OK, installed hmailserver, copy Data folder, db dump, just fine and then checked some email and OK :D

Lets hope it run just fine in the main server.

Ok cool. You missed the change db versions, run your path update and install 5.3.4 but assuming you did those things great news! Not only for you but for anyone else scared to upgrade due to no (easy/trusted) downgrade path. :)

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-14 13:27 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Bill48105 wrote:
FiShBuRn wrote:
Ok Bill, full test made, all went OK, installed hmailserver, copy Data folder, db dump, just fine and then checked some email and OK :D

Lets hope it run just fine in the main server.

Ok cool. You missed the change db versions, run your path update and install 5.3.4 but assuming you did those things great news! Not only for you but for anyone else scared to upgrade due to no (easy/trusted) downgrade path. :)


Nah, i had to change db version ;) if i didnt change hmail cant inicialize DB and path update to ofcourse.

thansk for your help Bill.

To undo the changes made on 5.4 on settings:

Code:
update hm_greylisting_whiteaddresses set whiteipaddress = replace(whiteipaddress, '%', '*');

update hm_whitelist set whiteemailaddress = replace(whiteemailaddress, '%', '*');

update hm_dbversion set value = 5320;

INSERT into hm_settings(settingid,settingname,settingstring,settinginteger) values (9,'tarpitdelay','',0),(10,'tarpitcount','',0);

delete from hm_settings where settingname = 'EnableWhitelisting';

delete from hm_settings where settingname = 'MaxNumberOfMXHosts';

delete from hm_settings where settingname = 'ClamAVEnabled';

delete from hm_settings where settingname = 'ClamAVHost';

delete from hm_settings where settingname = 'ClamAVPort';


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-14 15:21 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
Way cool, thanks for the info! So that means you downgraded your actual server or just test server so far?
Bill

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-14 15:23 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Just test server so far...later tonight i will downgrade main server...and post back the results.


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-14 18:16 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
FiShBuRn wrote:
Just test server so far...later tonight i will downgrade main server...and post back the results.

Ahh ok cool.
Btw, was thinking. Should a test be put in to to NOT update paths that have \ in the name or perhaps don't start with { just to be safe? :D (Would be REAL ugly to run that update on full paths!!)

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-14 18:33 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Something like this Bill:

Code:
UPDATE
   hm_messages    
SET
   messagefilename = (SELECT CONCAT('C:\\Programas\\hMailServer\\Data\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', -1),'\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', 1),'\\', SUBSTR(hm_messages.messagefilename,2,2),'\\', hm_messages.messagefilename) caminho
               FROM hm_accounts
               WHERE hm_messages.messageaccountid = hm_accounts.accountid and hm_messages.messagetype = 2 and SUBSTR(hm_messages.messagefilename,1,1) = '{'
              )
WHERE EXISTS
  (
     SELECT CONCAT('C:\\Programas\\hMailServer\\Data\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', -1),'\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', 1),'\\', SUBSTR(hm_messages.messagefilename,2,2),'\\', hm_messages.messagefilename) caminho
               FROM hm_accounts
               WHERE hm_messages.messageaccountid = hm_accounts.accountid and hm_messages.messagetype = 2 and SUBSTR(hm_messages.messagefilename,1,1) = '{'
  );


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-14 19:13 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
If that works then suppose yeah! :D Obviously someone else looking to use that would need to change the Data dir path but hopefully that'd be obvious. lol

Btw what is "caminho" in there?
Thx
Bill

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-15 10:17 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Bill48105 wrote:
If that works then suppose yeah! :D Obviously someone else looking to use that would need to change the Data dir path but hopefully that'd be obvious. lol

Btw what is "caminho" in there?
Thx
Bill

Hey,

It works fine, indeed, main server is downgraded OK :D now lets pray that it doesnt crash!

"caminho" could have whatever name you want, its a name for a column in case you need to call that select...in this case its no needed but...


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-15 16:44 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
FiShBuRn wrote:
Hey,

It works fine, indeed, main server is downgraded OK :D now lets pray that it doesnt crash!

"caminho" could have whatever name you want, its a name for a column in case you need to call that select...in this case its no needed but...

OK cool! Yeah let's see if it works ok then we might know if it is 5.4/2k issue or such.

So caminho is a temp table name you made up? I'm asking in case someone else needs to downgrade we know the steps to provide.
Thx
Bill

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-15 17:55 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Bill48105 wrote:
FiShBuRn wrote:
Hey,

It works fine, indeed, main server is downgraded OK :D now lets pray that it doesnt crash!

"caminho" could have whatever name you want, its a name for a column in case you need to call that select...in this case its no needed but...

OK cool! Yeah let's see if it works ok then we might know if it is 5.4/2k issue or such.

So caminho is a temp table name you made up? I'm asking in case someone else needs to downgrade we know the steps to provide.
Thx
Bill


Its not need to create, its like a temp collumn for that query...but like i said its not needed for this job but it doesnt hurt either :)

Sure, the only thing that need to be changed is the path to hmailserver Data folder, after that is ready to GO.


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-15 19:03 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
FiShBuRn wrote:
Its not need to create, its like a temp collumn for that query...but like i said its not needed for this job but it doesnt hurt either :)

Sure, the only thing that need to be changed is the path to hmailserver Data folder, after that is ready to GO.

Ok cool I'll have to give it a try myself. Be good to have a working downgrade process to help minimize reluctance to try out 5.4 so thanks for the efforts! :) Since this thread is soooo long now & the info is all scattered in many posts might make sense to start a new one with 1st post being step by step how to downgrade. Feel free to create that if you have time since you are the pro on downgrade now. :D
Thx!
Bill

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-16 13:08 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Bill48105 wrote:
FiShBuRn wrote:
Its not need to create, its like a temp collumn for that query...but like i said its not needed for this job but it doesnt hurt either :)

Sure, the only thing that need to be changed is the path to hmailserver Data folder, after that is ready to GO.

Ok cool I'll have to give it a try myself. Be good to have a working downgrade process to help minimize reluctance to try out 5.4 so thanks for the efforts! :) Since this thread is soooo long now & the info is all scattered in many posts might make sense to start a new one with 1st post being step by step how to downgrade. Feel free to create that if you have time since you are the pro on downgrade now. :D
Thx!
Bill


I will do that when i come back from vacations :) hope hmail doesnt crash so i can have good time :P

Thanks Bill for the help to!


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-16 23:53 
Normal user

Joined: 2010-04-27 02:03
Posts: 156
Location: Florida
Here's the issue I had: http://www.hmailserver.com/devnet/?page=issuetracker_display&issueid=354. The only "solution" was to upgrade to 2k3.


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-17 02:02 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
rolaids0 wrote:
Here's the issue I had: http://www.hmailserver.com/devnet/?page=issuetracker_display&issueid=354. The only "solution" was to upgrade to 2k3.


Thanks for you share but i my case hmail has running just fine with earlier releases only with 5.4 i had problems...if i want to use it, yeah i need to upgrade :)

regards


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-17 03:09 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
FiShBuRn wrote:
rolaids0 wrote:
Here's the issue I had: http://www.hmailserver.com/devnet/?page=issuetracker_display&issueid=354. The only "solution" was to upgrade to 2k3.


Thanks for you share but i my case hmail has running just fine with earlier releases only with 5.4 i had problems...if i want to use it, yeah i need to upgrade :)

regards

I think he was pointing out there are issues with windows 2k, even with prior versions of hmail not just with 5.4. You might have been lucky before. :D Anyway, if you happen to have issues after downgrading at least it helps you realize what you need to do.
Bill

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-07-19 11:42 
Normal user

Joined: 2010-07-09 13:16
Posts: 205
@FiShBuRn: I want to upgrade to 5.4, but "mommy I'm scared".
Would you please be so kind to post a summary of your steps to downgrade a 5.4 as HOWTO within "Tips & Tricks"?

(Yes I know, 5.4 works great at some systems. I say some because there aren't enough beta testers. It's just good to have an option if something is not working instead of waiting for a bugfix.)


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-08-01 15:13 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
prisma wrote:
@FiShBuRn: I want to upgrade to 5.4, but "mommy I'm scared".
Would you please be so kind to post a summary of your steps to downgrade a 5.4 as HOWTO within "Tips & Tricks"?

(Yes I know, 5.4 works great at some systems. I say some because there aren't enough beta testers. It's just good to have an option if something is not working instead of waiting for a bugfix.)


This is what ive made:

1 - Stopped hMailServer

2 - Dump the DB using phpmyadmin or cmd prompt.

3 - Zipped hMailserver Folder, to save all stuff.

4 - Executed this script via phpmyadmin to rebuild the path:

Code:
UPDATE
   hm_messages   
SET
   messagefilename = (SELECT CONCAT('C:\\Programas\\hMailServer\\Data\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', -1),'\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', 1),'\\', SUBSTR(hm_messages.messagefilename,2,2),'\\', hm_messages.messagefilename) caminho
               FROM hm_accounts
               WHERE hm_messages.messageaccountid = hm_accounts.accountid and hm_messages.messagetype = 2 and SUBSTR(hm_messages.messagefilename,1,1) = '{'
              )
WHERE EXISTS
  (
     SELECT CONCAT('C:\\Programas\\hMailServer\\Data\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', -1),'\\', SUBSTRING_INDEX(hm_accounts.accountaddress, '@', 1),'\\', SUBSTR(hm_messages.messagefilename,2,2),'\\', hm_messages.messagefilename) caminho
               FROM hm_accounts
               WHERE hm_messages.messageaccountid = hm_accounts.accountid and hm_messages.messagetype = 2 and SUBSTR(hm_messages.messagefilename,1,1) = '{'
  );


5 - Then execute this queries to restore some DB settings:

Code:
update hm_greylisting_whiteaddresses set whiteipaddress = replace(whiteipaddress, '%', '*');

update hm_whitelist set whiteemailaddress = replace(whiteemailaddress, '%', '*');

update hm_dbversion set value = 5320;

INSERT into hm_settings(settingid,settingname,settingstring,settinginteger) values (9,'tarpitdelay','',0),(10,'tarpitcount','',0);

delete from hm_settings where settingname = 'EnableWhitelisting';

delete from hm_settings where settingname = 'MaxNumberOfMXHosts';

delete from hm_settings where settingname = 'ClamAVEnabled';

delete from hm_settings where settingname = 'ClamAVHost';

delete from hm_settings where settingname = 'ClamAVPort';


6 - Install hMailserver v5.3.x

7 - Prey....:P

8 - After the installation hMailserver should be running fine :)

Bill, free to add or remove something soo then we can make a thread.

Regards


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-08-01 18:57 
Developer

Joined: 2010-04-24 23:16
Posts: 5887
Location: Michigan, USA
Thx FiShBuRn. Looks nice & simple actually, thanks mainly to your sql work. :D

I will note that someone doing it should edit the paths in the query though. Besides the fact it appears you are running an international or non-english version of windows some people might not install into the default folder or might end up in C:\Program Files (x86) even on 64bit windows.

Thx!
Bill

_________________
hMailServer build LIVE on my servers: 5.4-B2014011501
Latest test builds: http://www.hmailserver.com/forum/viewtopic.php?f=10&t=21420
Urgent? Bored? JOIN US ON IRC!
DOGE ME: DSqtEcqP3Qv6Tj2XrGNpDmEUkSBcpBsuWk


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-08-02 10:09 
Normal user

Joined: 2007-06-29 16:43
Posts: 88
Bill48105 wrote:
Thx FiShBuRn. Looks nice & simple actually, thanks mainly to your sql work. :D

I will note that someone doing it should edit the paths in the query though. Besides the fact it appears you are running an international or non-english version of windows some people might not install into the default folder or might end up in C:\Program Files (x86) even on 64bit windows.

Thx!
Bill


Indeed, it should be highlighted so people could change that. Yes im running a Portuguese version of windows :)


Top
 Profile  
 
 Post subject: Re: TCPServer::Run() error after upgrading to latest 5.4
PostPosted: 2011-12-10 12:05 
Normal user

Joined: 2006-11-04 18:30
Posts: 63
Location: UK
I have had this issue over the last day.

Yesterday at 8.50am I started getting calls from users saying that they were getting mail errors. On checking hMailServer logs I was seeing HM4316.

To cut a long story short I also was running hMailServer 5.4 on Win 2000 on two servers in two distant locations but had upgraded a number of weeks ago and the issue just started yesterday ON BOTH SERVERS WITHIN MINUTES OF EACH OTHER.

Swapping out the HDD in order to keep files etc I installed Windows XP (I don't have a copy of later server versions yet but will do the job again when I do) before rebuilding everything on it. I restored the latest backup, copied certificates back in etc, and all is well again.

However, I still don't know what caused it and couldn't try anything because everytime I logged into hMailAdmin the server crashed and kicked me out. By the time I had logged in again it crashed and kicked me out so I couldn't troubleshoot any settings.

Anyway - thanks for the info in this thread everyone. Gotta drive over to the other server this morning and do the same job there :-)

_________________
hMailServer 5.4 (1931)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 92 posts ]  Go to page Previous  1, 2


Who is online

Users browsing this forum: No registered users and 0 guests



Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group