EHLO/HELO

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
dan.kotarski
New user
New user
Posts: 14
Joined: 2007-07-13 14:55

EHLO/HELO

Post by dan.kotarski » 2007-07-13 15:06

Currently, i have hMailServer set up and everything is great (nice product, byt the way)

I noticed that, when sending to Hotmail, sometimes it goes to the junk mail folder and other times it goes to nowhere (just disappears).

I host my own DNS servers and have created all of my NS, CName, A, MX, PTR and SPF (v 1.0 only) records checked and verified with DNSStuff.

After much research and log file review I believe that the only thing preventing me from sending to Hotmail successfully is the EHLO/HELO hotname as it shows (in the log file):

... EHLO mfz

mfz if the name of that machine which resides only in a workgroup - I do not have ActiveDirectory installed and do not have any domains or forests set up.

So, the question is.. how do I change what gets sent as the EHLO/HELO hotname so that mfz.mydomainname.com appears instead of just mfz??

running Windows 2003 Server
I have tried playing with the settings under "System Properties" as well as Network settings. I must be missing some thing.

If anyone wants to verify my DNS Settings (which i think are fine), its http://www.landscapemanagementsystem.com

thanks
Last edited by dan.kotarski on 2007-07-21 18:12, edited 1 time in total.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2007-07-13 15:07

hMailServer Administrator:
Settings->Protocols->SMTP->Delivery of e-mail, Hostname.

dan.kotarski
New user
New user
Posts: 14
Joined: 2007-07-13 14:55

Post by dan.kotarski » 2007-07-13 15:11

I have tried that. In fact there is an entry in there already...but it does not show up in the EHLO/HELO

should the entry be
xxxx.com
or
mail.xxxx.com


i have xxxx.com

iprat
Normal user
Normal user
Posts: 247
Joined: 2005-05-20 16:50
Location: Barcelona, EU
Contact:

Post by iprat » 2007-07-13 15:11

Have a look at hMailServer Administrator section:

Configuration>Protocol>SMTP

And in the general folder you have:

"Welcome message" for incoming SMTP

And in the second folder you have:

"Computer name (or something similar)" and I think that's for outgoing SMTP

With all this you can put mfz.mydomainname.com there and I think it will do the job.
My perfect combination:
hMailServer 5.6.1 (B2208), ASSP 1.3.3.8 (antispam), Clamav 0.98.6 (antivirus)

dan.kotarski
New user
New user
Posts: 14
Joined: 2007-07-13 14:55

Post by dan.kotarski » 2007-07-13 15:19

IPRat: I have made that change and here are the log file results

"SMTPD" 4936 6735 "2007-07-13 09:15:36.703" "192.168.1.1" "SENT: 220 mail.landscapemanagementsystem.com ESMTP"
"SMTPD" 4936 6735 "2007-07-13 09:15:36.718" "192.168.1.1" "RECEIVED: EHLO mfz"
"SMTPD" 4936 6735 "2007-07-13 09:15:36.718" "192.168.1.1" "SENT: 250-hmailserver[nl]250-SIZE[nl]250 AUTH LOGIN PLAIN"

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2007-07-13 15:23

Dan, I think you're misreading the log file.

RECEIVED: EHLO mfz means that someone else sent EHLO mfz and hMailServer received that. It does not mean that hMailServer has sent EHLO mfz.

The fifth column shows that the text EHLO mfz was sent from IP address 192.168.1.1 which I assume is localhost? If so it looks like you have some software which forwards SMTP traffic to hMailServer and sends EHLO mfz. Perhaps ASSP or something similar?

iprat
Normal user
Normal user
Posts: 247
Joined: 2005-05-20 16:50
Location: Barcelona, EU
Contact:

Post by iprat » 2007-07-13 15:24

You RECEIVE EHLO mfz so it's not hMailServer who is identifying you with mfz.

This sounds to me an internal SMTP delivery, that means the machine 192.168.1.1 in you LAN wants to send to your server an email and that machine says "EHLO mfz", nothing to do with hMailServer.

iprat
Normal user
Normal user
Posts: 247
Joined: 2005-05-20 16:50
Location: Barcelona, EU
Contact:

Post by iprat » 2007-07-13 15:26

Well.... what else can I say.... we overlaped :D

dan.kotarski
New user
New user
Posts: 14
Joined: 2007-07-13 14:55

Post by dan.kotarski » 2007-07-13 15:28

Does that mean that the server needs to be on a domain (instead of in a workgroup)

Do you happen to know offhand how to rectify this issue (even though it is not related to hMailServer) ?

any suggestions would help

iprat
Normal user
Normal user
Posts: 247
Joined: 2005-05-20 16:50
Location: Barcelona, EU
Contact:

Post by iprat » 2007-07-13 15:30

No idea, the first thing is to identify who sends the message (by the IP)

But all this stuff seems not to be related with your Hotmail problems.

dan.kotarski
New user
New user
Posts: 14
Joined: 2007-07-13 14:55

Post by dan.kotarski » 2007-07-13 15:40

It must be. I say that because...

i enabled the HELO spam check and sent an email to myself. I also set up the hMailServer so that [SPAM] gets added to the subject line but still delivers it (so i can analyze) and add the spam detection reason to the message header (in x-hMailSercer-Reason)

I get the mail (with the [SPAM] tag in the subject line).
and when I view the message source I can see the following:

X-hMailServer-Reason: The host name specified in HELO does not match IP address.

If I remove the HELO check, [SPAM] does not get added to the subject line and X-hMailServer-Reason does not get appended to the messagfe headers.

Am I way off course? Please correct me (if I am wrong).

dan.kotarski
New user
New user
Posts: 14
Joined: 2007-07-13 14:55

UPDATE

Post by dan.kotarski » 2007-07-13 15:53

I have tested sending emial to Hotmail and it WORKS !

WOO HOO!

However, it is still labelled as spam (the [SPAM] tag is added to the subject line) because hMailserver is trying to resolve the ip of the computer who sent it. Of course, this is because the email (sent from a webpage on the same computer) is looking up its own host aka localhost.


i still want to use the HELO check (excellent spam filter) but when i send from my local machine, it must lookup the local name and resolve it to mfz.landscapemanagementsystem.com...so we're not out of the woods yet.

Anyone know how to FORCE a server to do a name lookup and include the domains name instead of just the computer name?

ulas
New user
New user
Posts: 26
Joined: 2006-06-23 14:31

Post by ulas » 2007-07-15 00:48

I didnt understand how did you achive to send an email to hotmail inbox folder. I wonder because I have same problem even I installed and signed mail with DKIM.

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Post by Kaan1983 » 2007-07-15 01:22

dan.kotarski: I wonder how did u success too :) Or did u success to recieve e-mal from hotmail?

ulas: Could you tell me more about DKIM? First time I hear...

dan.kotarski
New user
New user
Posts: 14
Joined: 2007-07-13 14:55

Post by dan.kotarski » 2007-07-16 14:24

ulas and Kaan1983....
due to an error on my part, I still cannot send to Hotmail and get it into the Inbox. However, I sent and email to SenderID@Microsoft.com with my domain name as the body (no subject), and they replied with a message saying that they updated their list (???) and that it may take up to 2 business days to completely propogate through their servers.


sorry for the confusion

Post Reply