Just stopped working

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
lestatve
Normal user
Normal user
Posts: 38
Joined: 2020-05-06 19:22

Just stopped working

Post by lestatve » 2020-06-04 21:36

Hi All,

So, my installation had been working fine. I decided to shut down the computer and move it from 2nd floor to the basement. I hooked it up to the same exact network, hardwired. Rebooted and now server cannot be found.

I had hmailserver running on system startup. I stopped that, for testing, and started it manually.

Domain is contilegal.net. I have dynamic IP. I use noip.com, contilegal.ddns.net is my voip.com server. Their DUC program installed and reporting my current IP to noip.com. My mx records go through dynu.com which takes the mail and transports down port 26. I have an SMTP, port 26, added to hmailserver. Ports 25, 26, 110, 143, 587 forwarded on router. I have dynamic DNS setup in router. Disabled firewall. No VPN.

This was the setup that was working perfectly.

I have full logging enabled. Log doesn't show much:

"TCPIP" 13288 "2020-06-04 14:34:17.690" "DNS MX lookup: contilegal.net"
"TCPIP" 13288 "2020-06-04 14:34:17.692" "DNS - MX Result: 2 IP addresses were found."
"DEBUG" 880 "2020-06-04 14:54:40.926" "Creating session 19"
"TCPIP" 880 "2020-06-04 14:54:40.927" "TCP - 192.168.1.31 connected to 192.168.1.31:25."
"DEBUG" 880 "2020-06-04 14:54:40.930" "TCP connection started for session 14"
"SMTPD" 880 14 "2020-06-04 14:54:40.931" "192.168.1.31" "SENT: 220 mail.contilegal.net ESMTP"
"SMTPD" 12808 14 "2020-06-04 14:54:40.932" "192.168.1.31" "RECEIVED: EHLO 192.168.1.31"
"SMTPD" 12808 14 "2020-06-04 14:54:40.933" "192.168.1.31" "SENT: 250-mail.contilegal.net[nl]250-SIZE 20480000[nl]250-STARTTLS[nl]250-AUTH LOGIN[nl]250 HELP"
"SMTPD" 7440 14 "2020-06-04 14:54:40.933" "192.168.1.31" "RECEIVED: QUIT"
"SMTPD" 7440 14 "2020-06-04 14:54:40.934" "192.168.1.31" "SENT: 221 goodbye"
"DEBUG" 12808 "2020-06-04 14:54:40.934" "Ending session 14"
"DEBUG" 12808 "2020-06-04 14:54:40.935" "Creating session 20"
"TCPIP" 12808 "2020-06-04 14:54:40.935" "TCP - 192.168.1.31 connected to 192.168.1.31:110."
"DEBUG" 12808 "2020-06-04 14:54:40.937" "TCP connection started for session 16"
"POP3D" 12808 16 "2020-06-04 14:54:40.938" "192.168.1.31" "SENT: +OK POP3"
"POP3D" 880 16 "2020-06-04 14:54:40.938" "192.168.1.31" "RECEIVED: CAPA"
"POP3D" 880 16 "2020-06-04 14:54:40.939" "192.168.1.31" "SENT: +OK CAPA list follows[nl]USER[nl]UIDL[nl]TOP[nl]STLS[nl]."
"POP3D" 880 16 "2020-06-04 14:54:40.939" "192.168.1.31" "RECEIVED: AUTH"
"POP3D" 880 16 "2020-06-04 14:54:40.940" "192.168.1.31" "SENT: -ERR Invalid command in current state."
"POP3D" 12808 16 "2020-06-04 14:54:40.940" "192.168.1.31" "RECEIVED: QUIT"
"POP3D" 12808 16 "2020-06-04 14:54:40.941" "192.168.1.31" "SENT: +OK POP3 server saying goodbye..."
"DEBUG" 7440 "2020-06-04 14:54:40.941" "Ending session 16"
"DEBUG" 880 "2020-06-04 14:55:28.360" "Creating session 21"
"TCPIP" 880 "2020-06-04 14:55:28.360" "TCP - 192.168.1.31 connected to 192.168.1.31:25."
"DEBUG" 880 "2020-06-04 14:55:28.362" "TCP connection started for session 19"
"SMTPD" 880 19 "2020-06-04 14:55:28.363" "192.168.1.31" "SENT: 220 mail.contilegal.net ESMTP"
"SMTPD" 7440 19 "2020-06-04 14:55:28.363" "192.168.1.31" "RECEIVED: EHLO 192.168.1.31"
"SMTPD" 7440 19 "2020-06-04 14:55:28.364" "192.168.1.31" "SENT: 250-mail.contilegal.net[nl]250-SIZE 20480000[nl]250-STARTTLS[nl]250-AUTH LOGIN[nl]250 HELP"
"SMTPD" 7440 19 "2020-06-04 14:55:28.364" "192.168.1.31" "RECEIVED: QUIT"
"SMTPD" 7440 19 "2020-06-04 14:55:28.364" "192.168.1.31" "SENT: 221 goodbye"
"DEBUG" 880 "2020-06-04 14:55:28.365" "Ending session 19"
"DEBUG" 12808 "2020-06-04 14:55:28.366" "Creating session 22"
"TCPIP" 12808 "2020-06-04 14:55:28.366" "TCP - 192.168.1.31 connected to 192.168.1.31:110."
"DEBUG" 12808 "2020-06-04 14:55:28.368" "TCP connection started for session 20"
"POP3D" 12808 20 "2020-06-04 14:55:28.368" "192.168.1.31" "SENT: +OK POP3"
"POP3D" 880 20 "2020-06-04 14:55:28.369" "192.168.1.31" "RECEIVED: CAPA"
"POP3D" 880 20 "2020-06-04 14:55:28.369" "192.168.1.31" "SENT: +OK CAPA list follows[nl]USER[nl]UIDL[nl]TOP[nl]STLS[nl]."
"POP3D" 12808 20 "2020-06-04 14:55:28.369" "192.168.1.31" "RECEIVED: AUTH"
"POP3D" 12808 20 "2020-06-04 14:55:28.369" "192.168.1.31" "SENT: -ERR Invalid command in current state."
"POP3D" 12808 20 "2020-06-04 14:55:28.370" "192.168.1.31" "RECEIVED: QUIT"
"POP3D" 12808 20 "2020-06-04 14:55:28.370" "192.168.1.31" "SENT: +OK POP3 server saying goodbye..."
"DEBUG" 7440 "2020-06-04 14:55:28.371" "Ending session 20"
"DEBUG" 880 "2020-06-04 14:55:50.319" "Creating session 23"
"TCPIP" 880 "2020-06-04 14:55:50.320" "TCP - 192.168.1.31 connected to 192.168.1.31:25."
"DEBUG" 880 "2020-06-04 14:55:50.323" "TCP connection started for session 21"
"SMTPD" 880 21 "2020-06-04 14:55:50.324" "192.168.1.31" "SENT: 220 mail.contilegal.net ESMTP"
"SMTPD" 880 21 "2020-06-04 14:55:50.325" "192.168.1.31" "RECEIVED: EHLO 192.168.1.31"
"SMTPD" 880 21 "2020-06-04 14:55:50.325" "192.168.1.31" "SENT: 250-mail.contilegal.net[nl]250-SIZE 20480000[nl]250-STARTTLS[nl]250-AUTH LOGIN[nl]250 HELP"
"SMTPD" 880 21 "2020-06-04 14:55:50.326" "192.168.1.31" "RECEIVED: QUIT"
"SMTPD" 880 21 "2020-06-04 14:55:50.327" "192.168.1.31" "SENT: 221 goodbye"
"DEBUG" 7440 "2020-06-04 14:55:50.328" "Ending session 21"
"DEBUG" 12808 "2020-06-04 14:55:50.329" "Creating session 24"
"TCPIP" 12808 "2020-06-04 14:55:50.330" "TCP - 192.168.1.31 connected to 192.168.1.31:110."
"DEBUG" 12808 "2020-06-04 14:55:50.332" "TCP connection started for session 22"
"POP3D" 12808 22 "2020-06-04 14:55:50.333" "192.168.1.31" "SENT: +OK POP3"
"POP3D" 880 22 "2020-06-04 14:55:50.334" "192.168.1.31" "RECEIVED: CAPA"
"POP3D" 880 22 "2020-06-04 14:55:50.335" "192.168.1.31" "SENT: +OK CAPA list follows[nl]USER[nl]UIDL[nl]TOP[nl]STLS[nl]."
"POP3D" 12808 22 "2020-06-04 14:55:50.336" "192.168.1.31" "RECEIVED: AUTH"
"POP3D" 12808 22 "2020-06-04 14:55:50.336" "192.168.1.31" "SENT: -ERR Invalid command in current state."
"POP3D" 12808 22 "2020-06-04 14:55:50.337" "192.168.1.31" "RECEIVED: QUIT"
"POP3D" 12808 22 "2020-06-04 14:55:50.338" "192.168.1.31" "SENT: +OK POP3 server saying goodbye..."
"DEBUG" 7440 "2020-06-04 14:55:50.338" "Ending session 22"

As I write this it is 15:30 so no real activity.

Diags:

Test: Collect server details
hMailServer version: hMailServer 5.6.7-B2425
Database type: MSSQL Compact

Test: Test IPv6
IPv6 support is available in operating system.

Test: Test outbound port
SMTP relayer is in use.
Trying to connect to host smtp.comcast.net...
Trying to connect to TCP/IP address 96.114.157.81 on port 25.
Received: 421 Cannot connect to SMTP server 96.114.157.81 (96.114.157.81:25), connect error 10060.
Connected successfully.

Test: Test backup directory
Backup directory C:\Users\gconti\Dropbox\hmailserver backup is writable.

Test: Test MX records
Trying to resolve MX records for contilegal.net...
Host name found: store1.dynu.com
Host name found: store2.dynu.com

Test: Test local connect
Connecting to TCP/IP address in MX records for local domain domain contilegal.net...
Trying to connect to host store1.dynu.com...
Trying to connect to TCP/IP address 162.216.241.35 on port 25.
Received: 421 Cannot connect to SMTP server 162.216.241.35 (162.216.241.35:25), connect error 10060.
Connected successfully.

Test: Test message file locations
Relative message paths are stored in the database for all messages.

Test: Test IP range configuration
No problems were found in the IP range configuration.

Any ideas? Thanks in advance!

Les

User avatar
RvdH
Senior user
Senior user
Posts: 1105
Joined: 2008-06-27 14:42
Location: Netherlands

Re: Just stopped working

Post by RvdH » 2020-06-04 21:45

Code: Select all

Received: 421 Cannot connect to SMTP server 96.114.157.81 (96.114.157.81:25), connect error 10060.
Received: 421 Cannot connect to SMTP server 162.216.241.35 (162.216.241.35:25), connect error 10060.
You can't connect to neither of the servers in the test, so check cables, firewall, router.... seems unrelated to hmailserver
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

lestatve
Normal user
Normal user
Posts: 38
Joined: 2020-05-06 19:22

Re: Just stopped working

Post by lestatve » 2020-06-04 22:33

Actually, what you are seeing there is the failure to connect through port 25. I don't see a way to remove that from the diagnostics. It is automatic that diagnostics will test outbound port 25. I have also enabled port 26 which is the port where my mx server sends the emails.

lestatve
Normal user
Normal user
Posts: 38
Joined: 2020-05-06 19:22

Re: Just stopped working

Post by lestatve » 2020-06-04 22:42

This is a message from dynu.com, which routes the emails through port 26:

--SMTP check result--

Connecting to contilegal.ddns.net on port 26

FAIL

User avatar
johang
Senior user
Senior user
Posts: 320
Joined: 2008-09-01 09:20

Re: Just stopped working

Post by johang » 2020-06-04 23:16

lestatve wrote:
2020-06-04 22:42
This is a message from dynu.com, which routes the emails through port 26:

--SMTP check result--

Connecting to contilegal.ddns.net on port 26

FAIL
so RvdH is right ... you have no network connection ?

can you ping anything on your lan ?
can you ping your router ?
can you ping 8.8.8.8


did you get a new local IP by DHCP when rebooting your computer
___________________________________________________________end of the line
spam filter appliance gateway: www.mailcleaner.org

mikedibella
Normal user
Normal user
Posts: 227
Joined: 2016-12-08 02:21

Re: Just stopped working

Post by mikedibella » 2020-06-04 23:36

I haven't seen this approach used much recently, but back in the day some routers used forwarding based on the switch-port instead of destination address. So if you changed the port on the gateway that the host is connects through, your forwarding rules may no longer be valid.

lestatve
Normal user
Normal user
Posts: 38
Joined: 2020-05-06 19:22

Re: Just stopped working

Post by lestatve » 2020-06-05 00:06

johang,

yes, I have a network connection.
yes, I can successfully ping all.

Now, I *might* have received a new DHCP IP Address from the router upon rebooting. I am not sure. How does hmailserver reference my internal network IP address?

Les

lestatve
Normal user
Normal user
Posts: 38
Joined: 2020-05-06 19:22

Re: Just stopped working

Post by lestatve » 2020-06-05 00:09

johang,

you are a genius! I did get a new DHCP IP Address and it screwed up my port forwarding. All fixed now. Thank you!

Les

lestatve
Normal user
Normal user
Posts: 38
Joined: 2020-05-06 19:22

Re: Just stopped working

Post by lestatve » 2020-06-05 00:13

I will damned sure make that IP address reserved now. :-)

Les

User avatar
johang
Senior user
Senior user
Posts: 320
Joined: 2008-09-01 09:20

Re: Just stopped working

Post by johang » 2020-06-05 09:04

lestatve wrote:
2020-06-05 00:13
I will damned sure make that IP address reserved now. :-)

Les
its like the hotell .. if not reserved .. you might end up somewhere else :D
___________________________________________________________end of the line
spam filter appliance gateway: www.mailcleaner.org

Post Reply