5 minute delay in processing queue

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
link_q
New user
New user
Posts: 1
Joined: 2020-06-03 05:02

5 minute delay in processing queue

Post by link_q » 2020-06-03 05:14

When a new message shows up in the delivery queue, it always takes exactly 5 minutes to be processed.

This happens even if it's an internal forward. If it's automatically forwarding a message A → B → C, it'll take exactly 10 minutes from the time of sending for the message to reach C because the message is apparently added to the delivery queue twice! (Once for processing A → B and once for processing B → C.)

I can manually select "Send now" for a message, which works, but I'd like to be able to have hMailServer process messages immediately.

Any help or suggestions would be very appreciated.

User avatar
RvdH
Senior user
Senior user
Posts: 1111
Joined: 2008-06-27 14:42
Location: Netherlands

Re: 5 minute delay in processing queue

Post by RvdH » 2020-06-03 08:49

I doubt that is correct, when you use forwarding the message is delayed for exactly 1 minute
This is a hardcoded value if i am remembering it right, so if this is showstopper for you find yourself another (free) mailserver software package
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

Post Reply