getting blank messages without to, from subject and content

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
shanker
New user
New user
Posts: 4
Joined: 2019-11-28 08:31

getting blank messages without to, from subject and content

Post by shanker » 2019-11-28 08:39

Hi,

I am using hMailServer-5.6.7 and trying to send a mail from cmd to test my smtp server but i am receiving blank mails without to , from subject and content.

Please help

Regards,
Shanker

User avatar
katip
Senior user
Senior user
Posts: 727
Joined: 2006-12-22 07:58
Location: Istanbul

Re: getting blank messages without to, from subject and content

Post by katip » 2019-11-28 08:57

have you tried a decent mail client such as Thunderbird or Outlook to send test mails?
Katip
--
HMS 5.7.0 x64, MariaDB 10.4.10 x64, SA 3.4.2, ClamAV 0.101.2 + SaneS

shanker
New user
New user
Posts: 4
Joined: 2019-11-28 08:31

Re: getting blank messages without to, from subject and content

Post by shanker » 2019-11-28 09:26

yes and it is working fine with outlook client. I am facing issue with only when sending from Cmd line interface

User avatar
mattg
Moderator
Moderator
Posts: 20460
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: getting blank messages without to, from subject and content

Post by mattg » 2019-11-28 10:25

What commands are you using?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

shanker
New user
New user
Posts: 4
Joined: 2019-11-28 08:31

Re: getting blank messages without to, from subject and content

Post by shanker » 2019-11-28 10:40

Hi,

telnet testsmtp.com 25
ehlo testsmtp.com
mail from:shanker@test.com
rcpt to:test@testsmtp.com
data
this test msg to test mail.
.
quit

shanker
New user
New user
Posts: 4
Joined: 2019-11-28 08:31

Re: getting blank messages without to, from subject and content

Post by shanker » 2019-11-28 10:42

i am receiving the mail but it has no to, from and content .. everything is blank

Shanker

User avatar
mattg
Moderator
Moderator
Posts: 20460
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: getting blank messages without to, from subject and content

Post by mattg » 2019-11-28 10:50

The SMTP envelope detail is what you are supplying
The from and to shown in the email clients is part of the message content

They are different things

try something like this

https://www.wormly.com/test-smtp-server
https://mxtoolbox.com/diagnostic.aspx
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

tunis
Normal user
Normal user
Posts: 229
Joined: 2015-01-05 20:22
Location: Sweden

Re: getting blank messages without to, from subject and content

Post by tunis » 2019-11-28 17:59

shanker wrote:
2019-11-28 10:40
Hi,

telnet testsmtp.com 25
ehlo testsmtp.com
mail from:shanker@test.com
rcpt to:test@testsmtp.com
data
this test msg to test mail.
.
quit
You are not sending to, from or subject

Code: Select all

telnet testsmtp.com 25
ehlo testsmtp.com
mail from:shanker@test.com
rcpt to:test@testsmtp.com
data
To: test@testsmtp.com
From: shanker@test.com
Subject: Test mail

this test msg to test mail.
.
quit
HMS 5.6.8 B2437.17 on Windows Server 2019 Core VM.
HMS 5.6.8 B2451.21 on Windows Server 2016 Core VM.
HMS 5.6.7 B2425.16 on Windows Server 2012 R2 Core VM.

Post Reply