error , help

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
koung
New user
New user
Posts: 1
Joined: 2019-09-27 03:40

error , help

Post by koung » 2019-09-27 05:07

hi,
The mail server was running normally for four months. At noon yesterday, the client suddenly could not send and receive mail, check the log:
"ERROR" 3332 "2019-09-27 10:09:23.571" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 3332 "2019-09-27 10:09:23.587" "Severity: 2 (High), Code: HM5017, Source: ScriptServer::LoadScripts, Description: An exception was thrown when loading scripts."

Reinstall, still the same;I am a new user, I don't know how to do it well.

User avatar
jim.bus
Senior user
Senior user
Posts: 304
Joined: 2011-05-28 11:49
Location: US

Re: error , help

Post by jim.bus » 2019-09-27 07:33

Just guessing since not much in way of Log Entries but:
1. Check you Events Folder, EventFolder=C:\Program Files (x86)\hMailServer\Events. All Scripts are supposed to be contained in a file called EventHandlers.vbs.
2. Make sure above folder has at least the EventHandlers.vbs file in it. There should be one automatically placed there (this script was essentially all comments and nothing attempted to actually run) when you
installed hMailServer I believe but an empty Events Folder caused me at least a similar Error. But you must have some .vbs file in the Events Folder otherwise you will generate an Error although in my case it didn't
cause any real problem.
3. If the folder has at least one script in it make sure the Folder Path actually exists or otherwise is present and that hMailServer has Permission/Access to it.
4. If all the above is ok then it might be there is something wrong with the script itself such as running into a condition not allowed for in the script.

If no problems when you check above as indicated look in C:\Program Files x(86)\hMailServer\Bin\hMailServer.ini and look for the Events Folder Path location to make sure it hasn't been changed from the Default Folder Path I indicated above and then recheck this location for the same as I indicated above. The Location of the Events Folder is defined in the .ini file. I'm guessing this hasn't been changed otherwise you probably would know it had been changed but this is one way I would believe you could get the error you are getting.

However, the errors I am familiar with Scripts did not cause me to not be able to Send/Receive Email.

But as I interpret the Error hMailServer could not Load Scripts which means some kind of access problem such as missing file or possibly a hardware error. Whatever the cause I wold guess it can't read the file for whatever the reason.

It seems a similar error occurred a long time ago and it was apparently related to a McAfee (antivirus software problem). Have you made any changes to your system along these lines. This long time ago error problem would have mucked with this Events file causing similar considerations as I indicated above as well.

User avatar
Dravion
Senior user
Senior user
Posts: 1472
Joined: 2015-09-26 11:50
Location: Germany
Contact:

Re: error , help

Post by Dravion » 2019-09-27 09:14

Disable Scripting in hMailAdmin abd try again.
There is an Error in obe if your Scripts.

Post Reply