mails getting lost

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
MM23
New user
New user
Posts: 4
Joined: 2019-05-27 14:25

mails getting lost

Post by MM23 » 2019-05-27 16:28

Hello,

one of our accounts (using POP3) does not receive all emails sent to the associated address.

This concerns e-mails sent directly to the address and those sent to a distribution list containing the address.

Received and lost e-Mails both show up in the log files.

The following reasons can be ruled out as the cause:
- sender address
- subject
- e-mail attachment(s)
- manual deletion of the missing e-mails
- program which retrieves the e-mails
- specific date/day/time

If forwarding is enabled, the lost e-mails do arrive at the forwarding address.
This allowed me to create the following overview that contains a selection of arrived (green) and lost (red) mails:
Unbenannt.PNG

The account has been in use since 07/2016.
The last upgrade to hMail version 5.6.7 was done 11/2018.
The first time the problem was noticed was 03/2019.
Maybe there is a connection(?).

User avatar
mattg
Moderator
Moderator
Posts: 19994
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: mails getting lost

Post by mattg » 2019-05-28 00:31

'Deleting message' indicates a rule action

Would need to see much more of the logs to be certain, and to detail which rule triggered
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

MM23
New user
New user
Posts: 4
Joined: 2019-05-27 14:25

Re: mails getting lost

Post by MM23 » 2019-05-28 09:31

Hello mattg,

thanks very much for your reply.

Here are all the log-data created on May 16 between 06:00:00 and 06:01:59.
Two emails were lost during this period.
The affected clients IP is '10.110.2.101'.
All emails are sent in an internal network.

Logs.zip
(142.08 KiB) Downloaded 22 times

User avatar
mattg
Moderator
Moderator
Posts: 19994
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: mails getting lost

Post by mattg » 2019-05-28 16:33

This is a POP3 session that asked for the messages to be deleted after they were downloaded
(This is the 2 'deleting messages' in the centre of your list).

Code: Select all

Session: 72577121
"POP3D" 3872 72577121 "2019-05-16 06:00:26.843" "10.110.2.101" "SENT: +OK POP3"
"POP3D" 1856 72577121 "2019-05-16 06:00:26.874" "10.110.2.101" "RECEIVED: CAPA"
"POP3D" 1856 72577121 "2019-05-16 06:00:26.874" "10.110.2.101" "SENT: +OK CAPA list follows[nl]USER[nl]UIDL[nl]TOP[nl]."
"POP3D" 1856 72577121 "2019-05-16 06:00:26.890" "10.110.2.101" "RECEIVED: USER fil6010@subdomain.domain.ch"
"POP3D" 1856 72577121 "2019-05-16 06:00:26.890" "10.110.2.101" "SENT: +OK Send your password"
"POP3D" 3872 72577121 "2019-05-16 06:00:26.921" "10.110.2.101" "RECEIVED: PASS ***"
"POP3D" 3872 72577121 "2019-05-16 06:00:26.921" "10.110.2.101" "SENT: +OK Mailbox locked and ready"
"POP3D" 3552 72577121 "2019-05-16 06:00:26.937" "10.110.2.101" "RECEIVED: UIDL"
"POP3D" 3552 72577121 "2019-05-16 06:00:26.937" "10.110.2.101" "SENT: +OK 2 messages (17544 octets)[nl]1 168[nl]2 169[nl]."
"POP3D" 3872 72577121 "2019-05-16 06:00:26.968" "10.110.2.101" "RECEIVED: TOP 1 0"
"POP3D" 3872 72577121 "2019-05-16 06:00:26.968" "10.110.2.101" "SENT: +OK 14709 octets"
"POP3D" 3872 72577121 "2019-05-16 06:00:26.968" "10.110.2.101" "SENT: [nl]."
"POP3D" 3552 72577121 "2019-05-16 06:00:27.218" "10.110.2.101" "RECEIVED: RETR 1"
"POP3D" 3552 72577121 "2019-05-16 06:00:27.218" "10.110.2.101" "SENT: ."
"POP3D" 808 72577121 "2019-05-16 06:00:27.280" "10.110.2.101" "RECEIVED: DELE 1"
"POP3D" 808 72577121 "2019-05-16 06:00:27.280" "10.110.2.101" "SENT: +OK msg deleted"
"POP3D" 3552 72577121 "2019-05-16 06:00:27.296" "10.110.2.101" "RECEIVED: TOP 2 0"
"POP3D" 3552 72577121 "2019-05-16 06:00:27.296" "10.110.2.101" "SENT: +OK 2835 octets"
"POP3D" 3552 72577121 "2019-05-16 06:00:27.296" "10.110.2.101" "SENT: [nl]."
"POP3D" 3872 72577121 "2019-05-16 06:00:27.546" "10.110.2.101" "RECEIVED: RETR 2"
"POP3D" 3872 72577121 "2019-05-16 06:00:27.546" "10.110.2.101" "SENT: ."
"POP3D" 808 72577121 "2019-05-16 06:00:27.593" "10.110.2.101" "RECEIVED: DELE 2"
"POP3D" 808 72577121 "2019-05-16 06:00:27.593" "10.110.2.101" "SENT: +OK msg deleted"
"POP3D" 3552 72577121 "2019-05-16 06:00:27.609" "10.110.2.101" "RECEIVED: QUIT"
"POP3D" 3552 72577121 "2019-05-16 06:00:27.609" "10.110.2.101" "SENT: +OK POP3 server saying goodbye..."
To me that looks normal.

One thing that is different about this than most of the POP3 connections, is that this one gives over a FQDN in the logon

eg "POP3D" 1856 72577121 "2019-05-16 06:00:26.890" "10.110.2.101" "RECEIVED: USER fil6010@subdomain.domain.ch"


Most of the other machines that are logging on via POP only use like 'fil385' without a domain, and they work because you obviously have a default domain set.

THis case is unusual because of the subdomain.
Most email addresses are in the form account@example.com rather than account@subdomain.example.com

I'd check the configuration settings on that mail client, and I'll bet that these messages are handled by a mail client rule that moves or deletes them.
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

MM23
New user
New user
Posts: 4
Joined: 2019-05-27 14:25

Re: mails getting lost

Post by MM23 » 2019-05-29 11:02

Thanks for evaluating the log files.
It helped a lot.
We can now rule out that the cause is server-related.

We will check the configuration of the affected client or possibly install another client to narrow down the problem.

Concerning the domains:
Our default domain is "subdomain.domain.de" for the german mailboxes.
Furthermore, we use "subdomain.domain.ch" for the swiss ones.

That is why the swiss accounts use the FQDNs in the clients.

If there is any news, I'll let you know.

MM23
New user
New user
Posts: 4
Joined: 2019-05-27 14:25

Re: mails getting lost

Post by MM23 » 2019-07-30 11:56

The cause was found.
Contrary to the information originally given to me, the cause was a second client which retrieved the e-mails before the "right" client did.

Thanks again.
The thread can be closed.

Post Reply