Mail from delivery queue not sent

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
lazna
Normal user
Normal user
Posts: 46
Joined: 2010-01-27 22:11

Mail from delivery queue not sent

Post by lazna » 2016-04-03 12:26

Mail from Delivery queue not sent, even on Right-click -> Send now is clicked. Number of retries is still '0'. If logging in next window is enabled, nothing happens. What could be wrong?

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2016-04-03 14:48

are you viewing in the PHPWebAdmin, or in the admin GUI?
The re-tries in the PHPWebAdmin was broken, but I think fixed recently. What version of hMaislerver?

logs should be created in the directory in the hmailsevrer.ini, typically the c:\program files (x86)\hmailserver\logs\ in a 64 bit system

Please post some logs of you trying to send a message...
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

lazna
Normal user
Normal user
Posts: 46
Joined: 2010-01-27 22:11

Re: Mail from delivery queue not sent

Post by lazna » 2016-04-03 21:18

Using GUI.

Version 5.6.4-B2283

There is two section of SMTPD with specific email address, there is zero sections of SMTPC related to this email address in the log file. Both sender and recipient have same domain, hosted on this server (both sender and recipient are local accounts). Trying to click "Send now" from message context menu, did nothing even write any record into log file (just tested few times).

L.

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2016-04-03 23:49

Please enable all logging, recreate the issue, and post all logs created
ALSO, please do the hmailserver diagnostics for your domain and post the results here

And finally, what do you in the SMTP relayer field?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

lazna
Normal user
Normal user
Posts: 46
Joined: 2010-01-27 22:11

Re: Mail from delivery queue not sent

Post by lazna » 2016-04-04 01:46

Each tries to send message from queue generate following two line into log file:

"DEBUG" 2388 "2016-04-04 01:38:11.368" "PersistentMessage::SetNextTryTime()"
"DEBUG" 2388 "2016-04-04 01:38:11.399" "PersistentMessage::~SetNextTryTime()"

For the range the senders IP from, have allowed averything under 'Allow deliveries from'



Test: Collect server details
hMailServer version: hMailServer 5.6.4-B2283
Database type: MySQL

Test: Test IPv6
IPv6 support is not available in operating system.

Test: Test outbound port
SMTP relayer not in use. Attempting mail.hmailserver.com:25...
Local address is 10.12.49.251.
Trying to connect to host mail.hmailserver.com...
Trying to connect to TCP/IP address 46.163.109.39 on port 25.
Received: 220 mail.hmailserver.com ESMTP.
Connected successfully.

Test: Test backup directory
ERROR: Backup directory E:\hmailserver-backup is not writable.

Test: Test MX records
Trying to resolve MX records for svobodnasit.cz...
ERROR: MX records for domain svobodnasit.cz could not be resolved

Test: Test local connect
Connecting to TCP/IP address in MX records for local domain domain svobodnasit.cz...
ERROR: MX records for local domain svobodnasit.cz could not be resolved

Test: Test message file locations
ERROR: Full paths are stored in the database.

Test: Test IP range configuration
No problems were found in the IP range configuration.

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2016-04-04 02:16

What do you have in TCP/IP ports?
What do you have in Performnace >> Threading
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Hsia
Normal user
Normal user
Posts: 66
Joined: 2015-03-24 04:30
Contact:

Re: Mail from delivery queue not sent

Post by Hsia » 2016-04-04 04:26

Mx??????
卧槽我手机丢……哦在这儿。

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2016-04-04 07:49

Yep I thought that it could be DNS issue too, but it resolved hMailsevrer.com

Their domain doesn't have any MX records, but that will only stop incoming mail get to them, it should not affect local to local mail
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

lazna
Normal user
Normal user
Posts: 46
Joined: 2010-01-27 22:11

Re: Mail from delivery queue not sent

Post by lazna » 2016-04-04 11:06

mattg wrote:What do you have in TCP/IP ports?
What do you have in Performnace >> Threading
0.0.0.0/25/SMTP
0.0.0.0/110/POP3
0.0.0.0/143/IMAP

15
10
15
Normal

lazna
Normal user
Normal user
Posts: 46
Joined: 2010-01-27 22:11

Re: Mail from delivery queue not sent

Post by lazna » 2016-04-04 11:10

mattg wrote:Yep I thought that it could be DNS issue too, but it resolved hMailsevrer.com

Their domain doesn't have any MX records, but that will only stop incoming mail get to them, it should not affect local to local mail
C:\scripts>nslookup -type=mx svobodnasit.cz
Server: ns.pankrac.czf
Address: 10.12.49.251

svobodnasit.cz
primary name server = svobodnasit.cz
responsible mail addr = (root)
serial = 216
refresh = 3600 (1 hour)
retry = 900 (15 mins)
expire = 86400 (1 day)
default TTL = 3600 (1 hour)

User avatar
SorenR
Senior user
Senior user
Posts: 3215
Joined: 2006-08-21 15:38
Location: Denmark

Re: Mail from delivery queue not sent

Post by SorenR » 2016-04-04 12:13

mattg wrote:Their domain doesn't have any MX records, but that will only stop incoming mail get to them, it should not affect local to local mail
Ahem... MX is NOT a requirement, a simple A record is sufficient.
SørenR.

“With age comes wisdom, but sometimes age comes alone.”
- Oscar Wilde

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2016-04-04 13:06

lazna wrote:Each tries to send message from queue generate following two line into log file:

"DEBUG" 2388 "2016-04-04 01:38:11.368" "PersistentMessage::SetNextTryTime()"
"DEBUG" 2388 "2016-04-04 01:38:11.399" "PersistentMessage::~SetNextTryTime()"

For the range the senders IP from, have allowed averything under 'Allow deliveries from'
Is ALL logging enabled?
Is there no SMTPC logs?

Can you show this IP range, and all other IP ranges, including all settings (especially priority)
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

lazna
Normal user
Normal user
Posts: 46
Joined: 2010-01-27 22:11

Re: Mail from delivery queue not sent

Post by lazna » 2016-04-04 22:44

None of SMTPC lines, as I already wrote in my second post.

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2016-04-05 14:57

sure then post all logs creasted

ALSO
mattg wrote:Is ALL logging enabled?
and
mattg wrote:Can you show this IP range, and all other IP ranges, including all settings (especially priority)
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2016-04-06 05:30

AND do you have DKIM setup for this domain?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

lazna
Normal user
Normal user
Posts: 46
Joined: 2010-01-27 22:11

Re: Mail from delivery queue not sent

Post by lazna » 2016-04-06 08:44

mattg wrote:AND do you have DKIM setup for this domain?
nope

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2016-04-06 13:43

I still like to see these please
mattg wrote:Can you show this IP range, and all other IP ranges, including all settings (especially priority)
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

lazna
Normal user
Normal user
Posts: 46
Joined: 2010-01-27 22:11

Re: Mail from delivery queue not sent

Post by lazna » 2016-04-07 10:51

mattg wrote:I still like to see these please
mattg wrote:Can you show this IP range, and all other IP ranges, including all settings (especially priority)
range1.png
range1.png (10.19 KiB) Viewed 3705 times
range2.png
range2.png (10.3 KiB) Viewed 3705 times
range3.png
range3.png (10.48 KiB) Viewed 3705 times

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2016-04-07 14:48

lazna wrote:Both sender and recipient have same domain, hosted on this server (both sender and recipient are local accounts). Trying to click "Send now" from message context menu, did nothing even write any record into log file (just tested few times).
What IP address is sending this mail?

Does this issue still occur if you use a mail client like say thunderbird on the computer with hMailserver installed?

Why are you allowing external to external in the Cloud10.12 range (I'm guessing that this is your LAN subnet??)
Why did you change the internet range?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

GeoffM
New user
New user
Posts: 12
Joined: 2016-11-29 20:24

Re: Mail from delivery queue not sent

Post by GeoffM » 2019-10-04 17:01

I realise I'm necroposting here but since I had the same problem and found this thread in the search for a solution, perhaps others will too.

I (re)moved the DKIM Signing file. That was enough to stop email being sent, and I didn't see anything in any logging (though it may have been there). Yes I feel silly. HTH someone.

User avatar
mattg
Moderator
Moderator
Posts: 20239
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Mail from delivery queue not sent

Post by mattg » 2019-10-05 08:00

That SHOULD log in the error log (a separate log file)
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Post Reply