[help] configure ip range to avoid spam

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
Thomas Parvais
Normal user
Normal user
Posts: 111
Joined: 2004-12-17 12:21
Contact:

[help] configure ip range to avoid spam

Post by Thomas Parvais » 2013-11-04 11:28

Hello

I've some problem with my HMS configuration. I'm bit lost with the configuration of IP ranges and what is authorized and not regarding SMTP. I had a spam attack and I change my config to force smtp authentication. But then some of my users are blocked.

I've customers using an ISP who is blocking SMTP sending on others IP than ISP SMTP servers.

I've created 3 IP ranges:

1. Local (priority 15): local IP address
==>allow deliveries from local to local (no SMTP auth), local to external (no SMTP auth), external to local (no auth)

2. ISP-SMTP block, with IP range = ISP SMTP IP addresses (priority 10)
==>allow deliveries from local to local (no SMTP auth), local to external (no SMTP auth), external to local (no auth)

3. internet (priority 5): 0.0.0.0-255.255.255.255
==>allow deliveries from local to local (no SMTP auth), local to external (no SMTP auth), external to local (no auth), external to external (with SMTP auth)


Do you think this configuration is correct for spam protection ?

when I try to send a message from google to local account, it is blocked because "smtp auth is required" and I don't understand why

Thank you for help

Thomas
Interrested by Law & new technologies ?
Intéressé par le droit de l'internet et des nouvelles technologies ?
Visit/Visitez http://www.droit-technologie.org

User avatar
mattg
Moderator
Moderator
Posts: 20224
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: [help] configure ip range to avoid spam

Post by mattg » 2013-11-04 11:56

I'd make both of the first 2 have a higher range than 20, ie 30 and 25 (This way AutoBan won't block them)

With all 3 ranges not requiring AUthentication for External to local, are you sure that gMail is actually connecting to your server?
Can you enable all logging, try and send from gMail to your local account again, and then when you get the error message, please post the logs

ALSO what connections are allowed for each range?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Post Reply