clamdscan.exe Returned 2 ?

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
cgountanis
Normal user
Normal user
Posts: 105
Joined: 2005-07-01 00:54
Location: USA

clamdscan.exe Returned 2 ?

Post by cgountanis » 2005-07-15 05:13

What is 2? ANyone have a manual on using clamd with hMail for lower cpu usage.


"DEBUG" 2412 "2005-07-14 22:10:08.406" "ClamWinVirusScanner::Scan()"
"DEBUG" 3020 "2005-07-14 22:10:08.421" "SocketConnection::~SocketConnection()"
"DEBUG" 2412 "2005-07-14 22:10:08.437" "ClamWinVirusScanner::Scan() - C:\ClamAV\bin\clamdscan.exe --database='C:\ClamAV\share\clamav' '{2382597E-E10A-4EFA-BD54-A0F4266F56F0}.eml' --tempdir='C:\WINNT\Temp' - Returned 2"
"DEBUG" 2412 "2005-07-14 22:10:08.453" "ClamWinVirusScanner::~Scan()"
"DEBUG" 2412 "2005-07-14 22:10:08.453" "ClamWinVirusScanner::Scan()"
"DEBUG" 3020 "2005-07-14 22:10:08.468" "SocketConnection::SocketConnection()"
"DEBUG" 2412 "2005-07-14 22:10:08.468" "ClamWinVirusScanner::Scan() - C:\ClamAV\bin\clamdscan.exe --database='C:\ClamAV\share\clamav' '{9E20C12D-C8B9-45F2-847E-F77BF4374F2E}.tmp' --tempdir='C:\WINNT\Temp' - Returned 2"
"DEBUG" 2412 "2005-07-14 22:10:08.484" "ClamWinVirusScanner::~Scan()"
"DEBUG" 2412 "2005-07-14 22:10:08.484" "RuleApplier::ApplyRules"
"DEBUG" 2412 "2005-07-14 22:10:08.484" "RuleApplier::~ApplyRules"
"DEBUG" 2128 "2005-07-14 22:10:08.484" "PMADO:SaveObject()"

cmurphy54
Senior user
Senior user
Posts: 550
Joined: 2004-09-25 22:11
Location: Atlanta, GA
Contact:

Post by cmurphy54 » 2005-07-15 05:27

This link lists the return codes a bit of the ways down

http://www.die.net/doc/linux/man/man1/clamdscan.1.html

2 is the uber descriptive, "An error occured."

cgountanis
Normal user
Normal user
Posts: 105
Joined: 2005-07-01 00:54
Location: USA

Post by cgountanis » 2005-07-15 06:15

How do you run in clamDscan hMail? I have the clamd running on 127.0.0.1 and start OK fromt he logs. Is there anything special I have to do in hMailServer EXE DB?


"DEBUG" 1456 "2005-07-14 23:13:01.000" "ADORecordset::~_GetRevertedIP()"
"DEBUG" 3208 "2005-07-14 23:13:01.000" "ClamWinVirusScanner::Scan() - C:\ClamAV\bin\clamdscan.exe --no-summary --stdout --database='C:\ClamAV\share\clamav' '{F7BD1C6A-BF1A-4405-8344-210BE68821DE}.eml' --tempdir='C:\WINNT\Temp' - Returned 2"
"DEBUG" 2172 "2005-07-14 23:13:01.000" "ClamWinVirusScanner::Scan() - C:\ClamAV\bin\clamdscan.exe --no-summary --stdout --database='C:\ClamAV\share\clamav' '{C571E23B-7F3B-49DE-B2DD-5836499B89D3}.tmp' --tempdir='C:\WINNT\Temp' - Returned 2"
"DEBUG" 1456 "2005-07-14 23:13:01.000" "BLCheck::~ClientExistsInDNSBL()"




USER CLAMWIN:
C:\ClamAV\bin\clamdscan.exe --no-summary --stdout
C:\ClamAV\share\clamav

cgountanis
Normal user
Normal user
Posts: 105
Joined: 2005-07-01 00:54
Location: USA

Post by cgountanis » 2005-07-15 06:27

Starting clamd just fine:
Thu Jul 14 23:12:44 2005 -> +++ Started at Thu Jul 14 23:12:44 2005

Thu Jul 14 23:12:44 2005 -> clamd daemon devel-20050712 (OS: cygwin, ARCH: i386, CPU: i686)

Thu Jul 14 23:12:44 2005 -> Log file size limited to 2097152 bytes.

Thu Jul 14 23:12:44 2005 -> Reading databases from C:\ClamAV\share\clamav

Thu Jul 14 23:12:47 2005 -> Protecting against 36446 viruses.

Thu Jul 14 23:12:47 2005 -> Bound to address 127.0.0.1 on tcp port 3310

Thu Jul 14 23:12:47 2005 -> Setting connection queue length to 30

Thu Jul 14 23:12:47 2005 -> Archive: Archived file size limit set to 15728640 bytes.

Thu Jul 14 23:12:47 2005 -> Archive: Recursion level limit set to 10.

Thu Jul 14 23:12:47 2005 -> Archive: Files limit set to 1000.

Thu Jul 14 23:12:47 2005 -> Archive: Compression ratio limit set to 250.

Thu Jul 14 23:12:47 2005 -> Archive support enabled.

Thu Jul 14 23:12:47 2005 -> Portable Executable support enabled.

Thu Jul 14 23:12:47 2005 -> Detection of broken executables enabled.

Thu Jul 14 23:12:47 2005 -> Mail files support enabled.

Thu Jul 14 23:12:47 2005 -> OLE2 support enabled.

Thu Jul 14 23:12:47 2005 -> HTML support enabled.

Thu Jul 14 23:12:47 2005 -> Self checking every 1800 seconds.

Thu Jul 14 23:23:23 2005 -> Exiting (clean)

Thu Jul 14 23:23:23 2005 -> --- Stopped at Thu Jul 14 23:23:23 2005



If clamscan works clamdscan shoud as well. Scanning with command lines that work with clamscan just fine but getting Returned 2 from hMailServer logs:

"ClamWinVirusScanner::Scan() - C:\ClamAV\bin\clamdscan.exe --no-summary --stdout --database='C:\ClamAV\share\clamav' '{7A087A84-4D96-4D71-ABD9-CFEC215D3FB9}.tmp' --tempdir='C:\WINNT\Temp' - Returned 2"







What am I doing wrong. One thing I can think of is how does clamdscan know what port to connect to? IS there a config or a command line param I should be using. I need returned 1 on the virus tests not 2 (error).

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2005-07-15 08:29

Can you try to run the exact same from the command line to see what happens then?

cgountanis
Normal user
Normal user
Posts: 105
Joined: 2005-07-01 00:54
Location: USA

Post by cgountanis » 2005-07-15 08:32

since the temp file is gone i do it on the user folder\23\{qwerweqrwer}.eml file I get 1 as supposed to. I am thinking this might be a user rights issue or something.

cgountanis
Normal user
Normal user
Posts: 105
Joined: 2005-07-01 00:54
Location: USA

Post by cgountanis » 2005-07-15 11:17


Post Reply