Russian letters in Subject and AntiSPAM settings

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
mns17
Normal user
Normal user
Posts: 124
Joined: 2008-06-18 11:13

Russian letters in Subject and AntiSPAM settings

Post by mns17 » 2011-04-13 09:51

Hi, All.

If in the message subject there are Russian letters then:
Message subject before AntiSPAM "йцук енгш щзхъ фыва пролджэ ячсм итьбю"
This message - SPAM
In Hmailserver settings - AntiSpam - General
Add to message subject - [SPAM]
Message subject after AntiSPAM - "[SPAM]"

If in the message subject there are English letters then:
Message subject before AntiSPAM "test message for antispam"
This message - SPAM
In Hmailserver settings - AntiSpam - General
Add to message subject - [SPAM]
Message subject after AntiSPAM- "test message for antispam"

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: Russian letters in Subject and AntiSPAM settings

Post by ^DooM^ » 2011-04-13 10:09

Is there a question in there or are we just meant to guess what you are talking about?
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

mns17
Normal user
Normal user
Posts: 124
Joined: 2008-06-18 11:13

Re: Russian letters in Subject and AntiSPAM settings

Post by mns17 » 2011-04-13 10:18

Question: How it can be corrected?
Or is a BAG?

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: Russian letters in Subject and AntiSPAM settings

Post by ^DooM^ » 2011-04-13 14:28

How can what be corrected? Are you talking about how the russian characters are not displayed when the word [SPAM] is prepended?
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

mns17
Normal user
Normal user
Posts: 124
Joined: 2008-06-18 11:13

Re: Russian letters in Subject and AntiSPAM settings

Post by mns17 » 2011-04-13 16:12

How can what be corrected? Are you talking about how the russian characters are not displayed when the word [SPAM] is prepended?
Yes!

hMailServer 5.3.3 - Build 1879

NOW:

If in the message subject there are Russian letters then:
Message subject before AntiSPAM "йцук енгш щзхъ фыва пролджэ ячсм итьбю"This message - SPAM
In Hmailserver settings - AntiSpam - General
Add to message subject - [SPAM]
Message subject after AntiSPAM - "[SPAM]"

MUST BE:

If in the message subject there are Russian letters then:
Message subject before AntiSPAM "йцук енгш щзхъ фыва пролджэ ячсм итьбю"
This message - SPAM
In Hmailserver settings - AntiSpam - General
Add to message subject - [SPAM]
Message subject after AntiSPAM - "[SPAM]йцук енгш щзхъ фыва пролджэ ячсм итьбю"

User avatar
dzekas
Senior user
Senior user
Posts: 2486
Joined: 2005-10-13 21:28
Location: Lithuania

Re: Russian letters in Subject and AntiSPAM settings

Post by dzekas » 2011-04-13 17:57

Can't reproduce it with correctly formated email in hMailServer 5.4 B1913

Code: Select all

telnet 192.168.59.134 25
Trying 192.168.59.134...
Connected to 192.168.59.134.
Escape character is '^]'.
220 X-TKIBBVWPCNGAB ESMTP
ehlo tomas
250-X-TKIBBVWPCNGAB
250-SIZE 20480000
250 AUTH LOGIN
mail from: test@example.com
250 OK
rcpt to: test@example.org
250 OK
data
354 OK, send.
Date: Wed, 13 Apr 2011 18:47:34 +0300 (EEST)
Subject: =?utf-8?B?0YLQtdGB0YI=?=
From: =?utf-8?B?0YLQtdGB0YI=?= <test@example.com>

XJS*C4JDBQADN1.NSBN3*2IDNEN*GTUBE-STANDARD-ANTI-UBE-TEST-EMAIL*C.34X

.
250 Queued (6.312 seconds)
Image

Please show headers of your Russian email. Before subject is corrupted.

mns17
Normal user
Normal user
Posts: 124
Joined: 2008-06-18 11:13

Re: Russian letters in Subject and AntiSPAM settings

Post by mns17 » 2011-04-14 04:11

Variant #1:

From: <test@domain.ru>
To: <info@domain.ru>
Subject: =?windows-1251?B?6fbz6iDl7eMg+Pnn9fog9Pvi4CDv8O7rIOTm/SD/9/HsIOjy/OH+?=
Date: Thu, 14 Apr 2011 09:08:06 +0700
Message-ID: <001701cbfa48$cbd05ad0$63711070$@doroshkevich@softnsk.ru>
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0013_01CBFA83.782A77E0"
X-Mailer: Microsoft Office Outlook 12.0
Thread-Index: Acv6SMqF31wKD87MQ66JN/Jkmp0r0g==
Content-Language: ru
X-OlkEid: 09049B46CAC14E18BE6F5B42976B7EAB566268B8

This is a multi-part message in MIME format.

------=_NextPart_000_0013_01CBFA83.782A77E0
Content-Type: text/plain;
charset="windows-1251"
Content-Transfer-Encoding: 8bit


Variant #2:

MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="=_d1a63819e2c9b594198792b78ee4e08f"
Date: Thu, 14 Apr 2011 09:11:02 +0700
From: test@domain.ru
To: <info@domain.ru>
Subject: =?UTF-8?Q?=D0=B9=D1=86=D1=83=20=D0=BA=D0=B5=D0=BD=20=D0=B3=D1=88?=
=?UTF-8?Q?=D1=89=D0=B7=D1=85=D1=8A=20=D1=84=D1=8B=D0=B2=D0=B0=20=D0=BF?=
=?UTF-8?Q?=D1=80=D0=BE=D0=BB=20=D0=B4=D0=B6=D1=8D=20=D1=8F=D1=87=D1=81?=
=?UTF-8?Q?=D0=BC=20=D0=B8=D1=82=D1=8C=20=D0=B1=D1=8E?=
Message-ID: <0f23d4e56a54bf4cd9c5bd0f57534ae9@softnsk.ru>
X-Sender: test@domain.ru

User-Agent: RoundCube Webmail/0.5.1

--=_d1a63819e2c9b594198792b78ee4e08f
Content-Transfer-Encoding: 8bit
Content-Type: text/plain; charset=UTF-8

Result after AntiSpam Filtr = [SPAM]

User avatar
dzekas
Senior user
Senior user
Posts: 2486
Joined: 2005-10-13 21:28
Location: Lithuania

Re: Russian letters in Subject and AntiSPAM settings

Post by dzekas » 2011-04-14 20:25

mns17 wrote:Variant #1:

From: <test@domain.ru>
To: <info@domain.ru>
Subject: =?windows-1251?B?6fbz6iDl7eMg+Pnn9fog9Pvi4CDv8O7rIOTm/SD/9/HsIOjy/OH+?=
reproduced in 5.3.3. Looks like it is fixed in dev. version.

mns17
Normal user
Normal user
Posts: 124
Joined: 2008-06-18 11:13

Re: Russian letters in Subject and AntiSPAM settings

Post by mns17 » 2011-04-15 04:25

dzekas wrote: reproduced in 5.3.3. Looks like it is fixed in dev. version.
I`m using hMailServer 5.3.3 - Build 1879

User avatar
dzekas
Senior user
Senior user
Posts: 2486
Joined: 2005-10-13 21:28
Location: Lithuania

Re: Russian letters in Subject and AntiSPAM settings

Post by dzekas » 2011-04-15 06:37

mns17 wrote:
dzekas wrote: reproduced in 5.3.3. Looks like it is fixed in dev. version.
I`m using hMailServer 5.3.3 - Build 1879
You have two options.

1. Change the way spamassassin is integrated and call it in a script. I think "tips and tricks" section has some article about it. Now [spam] part is added by hMailServer. If spamasassin is called in a script, Subject will be modified by spamassassin.

2. Upgrade to unstable dev version which you can find on "Development and alpha" section. 5.4 is not officially supported and for such unknown reason developer removed one of antispam options.

Post Reply