server stop working after windows update

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
jano
New user
New user
Posts: 6
Joined: 2009-07-29 09:28

server stop working after windows update

Post by jano » 2009-07-29 09:35

Hello Everybody,

My hmail server installation stop working this morning. SMTP, IMAP and POP3 service do not work. In the server long repeats this message:
"APPLICATION" 3216 "2009-07-29 09:09:06.312" "Severity: 3 (Medium), Code: HM4310, Source: Thread::Start, Description: Worker thread could not be created. Error: 8"

It stops about 3:00 am and about the same time some windows update was installed. I have uninstalled that windows update, but the problem still persist. Please advice anyone.

hMailServer version 5.2-B356

Keba
Normal user
Normal user
Posts: 126
Joined: 2009-04-11 11:43

Re: server stop working after windows update

Post by Keba » 2009-07-29 10:19

I've installed both of the out-of-band hotfixes on two different hMail production machines with no issues. I've not had to uninstall them.

1 server uses MSSQL 2005 Standard, and the other the inbuilt MSSQL 2005 express. Both are currently running hMail 5.2 b356.
Keba

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: server stop working after windows update

Post by ^DooM^ » 2009-07-29 10:54

Backup the whole hMailServer Directory and your database if you are using an external database before you do anything else.

I assume you have already tried to restart the hMail service?

If you have a backup you could try re-installing hMail over the top of your old install (make sure to use the same version).
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

jano
New user
New user
Posts: 6
Joined: 2009-07-29 09:28

Re: server stop working after windows update

Post by jano » 2009-07-29 10:55

ok, maybe this has nothing to do with windows update. The server just stopped working at 03:01am. This confused me because it is usual time for windows update.

The symptoms are:

- The SMTP, POP3 and IMAPT service do not work. Server do not receive any new message and any old message can not be downloaded through POP3
- I am unable to login to administration console using administrator password. But I can log in using blank password!!!
- in the server log there are many lines with the same message. I have written it above. Tens of messages every minute are added to the log.

Does anyone know what this message stands for?

I run this hmail server installation on Windows XP SP3. I have checked windows log in even viewer but i have not seen any suspicious message.


mysql version is 5.1.32

jano
New user
New user
Posts: 6
Joined: 2009-07-29 09:28

Re: server stop working after windows update

Post by jano » 2009-07-29 10:58

to ^DooM^:

Yes, I tried to restart and I also have reinstalled on the top of old installation. It did not help.

User avatar
mattg
Moderator
Moderator
Posts: 19979
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: server stop working after windows update

Post by mattg » 2009-07-29 11:01

SO is mySQL service running?

What happens when you try to manually start the hMailserver service?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

jano
New user
New user
Posts: 6
Joined: 2009-07-29 09:28

Re: server stop working after windows update

Post by jano » 2009-07-29 11:07

to mattg:

the service appears as running. I can stop it and start it through administration console or through windows service manager.

It just do not work. I test SMTP service by doing "telnet localhost 25", and there is no response.

User avatar
mattg
Moderator
Moderator
Posts: 19979
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: server stop working after windows update

Post by mattg » 2009-07-29 11:09

which service is running?
MySQL or hMailserver or both?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

jano
New user
New user
Posts: 6
Joined: 2009-07-29 09:28

Re: server stop working after windows update

Post by jano » 2009-07-29 11:10

to mattg:

The mysql service is running.

User avatar
mattg
Moderator
Moderator
Posts: 19979
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: server stop working after windows update

Post by mattg » 2009-07-29 11:11

mattg wrote:What happens when you try to manually start the hMailserver service?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

jano
New user
New user
Posts: 6
Joined: 2009-07-29 09:28

Re: server stop working after windows update

Post by jano » 2009-07-29 11:13

to mattg:

both hmail and mysql services appears as running.

I can restart them manually. However the server still does not work.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: server stop working after windows update

Post by martin » 2009-07-29 17:12

So have you temporarily uninstalled the hotfix to see if that solves it?

hMailServer calls CreateThread to create new Windows threads. 8 means that there was no more memory available.

If you get this directly after starting the hMailServer service, I would almost guess that something has been broken in your Windows installation. :-\

Is it possible for you to uninstall hMailServer, wipe the \hMailServer directory and try to reinstall it again and see if that has any effect? Or would you loose to much email by doing that?

Post Reply