Page 1 of 1

Intermittent failure to connect on 25 &110 from outside host

Posted: 2009-07-07 18:04
by bulbous
I have a new installation on a dedicated remote server running Windows 2003 and MySQL.
I can connect perfectly with telnet every time from the server itself and hMailServer works just fine
But from an external host I am unable to connect to ports 25 or 110 except sometimes!
Sometimes (about 5% of the time) it just works perfectly and I can connect as expected from telnet and Thunderbird before it goes off again.
Wireshark tells me that the server is not responding or not responding quickly enough and the hMailServer log shows just a connection but no communication with the client.
All other ports work just fine. I can connect to ftp or mysql immediately without any difficulty. Problem is only with 25 and 110 and then only sometimes.
Does anybody have any idea what the problem might be?
Tearing my hair out
All your help greatly appreciated and apologies if this is a known issue that I haven't unearthed yet.
Thanks in advance
Nigel (fast and bulbous!)

Re: Intermittent failure to connect on 25 &110 from outside host

Posted: 2009-07-07 18:10
by Keba
It sounds like a firewall or network issue - contact the support for your remote server and ask them to take a look.

More information to above post

Posted: 2009-07-07 19:06
by bulbous
The server running hMailServer is in London UK. I am in Thailand with a fairly crappy internet connection. I have just had somebody telnet in to both ports from a UK connection with no problems.
This issue is connected with the quality of the physical connection.
Still puzzling since I can connect reliably to my regular eircom.net email account.
We all know a lot but we don't know everything! All of your input will be greatly appreciated

Resolved: Intermittent failure to connect from outside host

Posted: 2009-07-10 10:53
by bulbous
This issue was resolved by downgrading to hMailServer 5.1 - Build 340 (2945) - 2009-04-06
Could it be a bug? Didn't hear anybody else complaining about it although it was only from our poor connection in Asia that we were able to make it fail

Re: Intermittent failure to connect on 25 &110 from outside host

Posted: 2009-07-10 12:19
by Keba
Downgrading from which version?

Re: Intermittent failure to connect on 25 &110 from outside host

Posted: 2009-07-10 12:20
by ^DooM^
Which version where you running before the downgrade and did you have logging enabled?

Re: Intermittent failure to connect on 25 &110 from outside host

Posted: 2009-07-28 04:27
by bulbous
I downgraded from 5.1.2 B346 to 5.1 B340
I did not have logging enabled but can do this if it will help to understand what is happening

Re: Intermittent failure to connect on 25 &110 from outside host

Posted: 2009-07-28 18:01
by martin
> This issue is connected with the quality of the physical connection.

> This issue was resolved by downgrading to hMailServer 5.1 - Build 340

Are you sure it's related to the quality of the physical connection?

Without seeing logs it's hard to say what the problem is..