Intermittent failure to connect on 25 &110 from outside host

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
bulbous
New user
New user
Posts: 5
Joined: 2009-07-07 17:17

Intermittent failure to connect on 25 &110 from outside host

Post by bulbous » 2009-07-07 18:04

I have a new installation on a dedicated remote server running Windows 2003 and MySQL.
I can connect perfectly with telnet every time from the server itself and hMailServer works just fine
But from an external host I am unable to connect to ports 25 or 110 except sometimes!
Sometimes (about 5% of the time) it just works perfectly and I can connect as expected from telnet and Thunderbird before it goes off again.
Wireshark tells me that the server is not responding or not responding quickly enough and the hMailServer log shows just a connection but no communication with the client.
All other ports work just fine. I can connect to ftp or mysql immediately without any difficulty. Problem is only with 25 and 110 and then only sometimes.
Does anybody have any idea what the problem might be?
Tearing my hair out
All your help greatly appreciated and apologies if this is a known issue that I haven't unearthed yet.
Thanks in advance
Nigel (fast and bulbous!)

Keba
Normal user
Normal user
Posts: 126
Joined: 2009-04-11 11:43

Re: Intermittent failure to connect on 25 &110 from outside host

Post by Keba » 2009-07-07 18:10

It sounds like a firewall or network issue - contact the support for your remote server and ask them to take a look.
Keba

bulbous
New user
New user
Posts: 5
Joined: 2009-07-07 17:17

More information to above post

Post by bulbous » 2009-07-07 19:06

The server running hMailServer is in London UK. I am in Thailand with a fairly crappy internet connection. I have just had somebody telnet in to both ports from a UK connection with no problems.
This issue is connected with the quality of the physical connection.
Still puzzling since I can connect reliably to my regular eircom.net email account.
We all know a lot but we don't know everything! All of your input will be greatly appreciated

bulbous
New user
New user
Posts: 5
Joined: 2009-07-07 17:17

Resolved: Intermittent failure to connect from outside host

Post by bulbous » 2009-07-10 10:53

This issue was resolved by downgrading to hMailServer 5.1 - Build 340 (2945) - 2009-04-06
Could it be a bug? Didn't hear anybody else complaining about it although it was only from our poor connection in Asia that we were able to make it fail

Keba
Normal user
Normal user
Posts: 126
Joined: 2009-04-11 11:43

Re: Intermittent failure to connect on 25 &110 from outside host

Post by Keba » 2009-07-10 12:19

Downgrading from which version?
Keba

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: Intermittent failure to connect on 25 &110 from outside host

Post by ^DooM^ » 2009-07-10 12:20

Which version where you running before the downgrade and did you have logging enabled?
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

bulbous
New user
New user
Posts: 5
Joined: 2009-07-07 17:17

Re: Intermittent failure to connect on 25 &110 from outside host

Post by bulbous » 2009-07-28 04:27

I downgraded from 5.1.2 B346 to 5.1 B340
I did not have logging enabled but can do this if it will help to understand what is happening

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: Intermittent failure to connect on 25 &110 from outside host

Post by martin » 2009-07-28 18:01

> This issue is connected with the quality of the physical connection.

> This issue was resolved by downgrading to hMailServer 5.1 - Build 340

Are you sure it's related to the quality of the physical connection?

Without seeing logs it's hard to say what the problem is..

Post Reply