problem between jmail & Hmailserver

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
Thomas Parvais
Normal user
Normal user
Posts: 111
Joined: 2004-12-17 12:21
Contact:

problem between jmail & Hmailserver

Post by Thomas Parvais » 2008-02-27 21:05

Hello,

I'm using last stable release of HMS. I also use Jmail componants (V4.5) to send mail from my website on a contact-form. HMS , jmail, web on the same machine.

When I want to send a mail to an email not declared in Hmailserver, it is refused.

The sender of the email in ASP script is of course a valid local email address existing in Hmailserver.

I've not activted SMTP authentication.

Here is the Jmail log:

Can you help ?

Code: Select all

The message was undeliverable. All servers failed to receive the message
Number of attachments: 1
  attachments: 
  {
    Encoding "C:\Inetpub\wwwroot\dt-4\www\html\img\logo3.gif"
  }
.execute()
{
  Trying server mail:mail.droit-technologie.org
  <- 220 serveur.maxetzoe.com
  -> EHLO serveur.maxetzoe.com
  <- 250-hmailserver
250-SIZE
250 AUTH LOGIN
  -> MAIL FROM:
  <- 250 OK
  -> RCPT TO:tparvais@gmail.com
 <- 530 SMTP authentication is required.
  -> DATA
 <- 503 Must have sender and recipient first.
Error: 503 Must have sender and recipient first.
Number of attachments: 1
  attachments: 
  {
    Encoding "C:\Inetpub\wwwroot\dt-4\www\html\img\logo3.gif"
  }
.execute()
{
  Trying server mail:mail.droit-technologie.org
  <- 220 serveur.maxetzoe.com
  -> EHLO serveur.maxetzoe.com
  <- 250-hmailserver
250-SIZE
250 AUTH LOGIN
  -> MAIL FROM:
  <- 250 OK
  -> RCPT TO:tparvais@gmail.com
 <- 530 SMTP authentication is required.
  -> DATA
 <- 503 Must have sender and recipient first.
Error: 503 Must have sender and recipient first.

  1 of 1 servers failed
Hmail log:

Code: Select all

"SMTPD"	2696	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"SENT: 220 serveur.maxetzoe.com"
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"RECEIVED: EHLO serveur.maxetzoe.com"
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"SENT: 250-hmailserver[nl]250-SIZE[nl]250 AUTH LOGIN"
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"RECEIVED: MAIL FROM:<info@droit-technologie.org>"
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"SENT: 250 OK"
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"RECEIVED: RCPT TO:<tparvais@gmail.com>"
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"SENT: 530 SMTP authentication is required."
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"RECEIVED: DATA"
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"SENT: 503 Must have sender and recipient first."
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"RECEIVED: RSET"
"SMTPD"	2680	26958	"2008-02-27 20:00:48.162"	"217.112.181.130"	"SENT: 250 OK"
Interrested by Law & new technologies ?
Intéressé par le droit de l'internet et des nouvelles technologies ?
Visit/Visitez http://www.droit-technologie.org

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-27 21:11

As it says in the log, SMTP authenticaiton is required. You should configure JMail to use SMTP authentication (don't know how to do that).

Thomas Parvais
Normal user
Normal user
Posts: 111
Joined: 2004-12-17 12:21
Contact:

Post by Thomas Parvais » 2008-02-27 22:34

martin wrote:As it says in the log, SMTP authenticaiton is required. You should configure JMail to use SMTP authentication (don't know how to do that).
Strange as I don't configure Hmailserver to ask authentication

BTW I change my code to do it and it works

Thank you
Interrested by Law & new technologies ?
Intéressé par le droit de l'internet et des nouvelles technologies ?
Visit/Visitez http://www.droit-technologie.org

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-28 00:15

So you have disabled authentication in the IP ranges in hMailServer? This is enabled by default in hMailServer, because not requiring SMTP authentication would open up the servers for spammers.

Post Reply