SMTP delivery of email bind to local ip address not working

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
computerateitleat
New user
New user
Posts: 16
Joined: 2011-03-05 02:22

SMTP delivery of email bind to local ip address not working

Post by computerateitleat » 2011-03-08 19:53

Hello!

On my server (windows 7 pro) sending of Email is not possible, because hmailserver uses the wrong nic (if I deactivate this nic, hmailserver works fine).

So I need to use the feature SMTP delivery of email bind to local ip address BUT the problem remains - hmailserver trys to use my lan NIC. How can I get this feature to work on Windows 7?

NIC 1 (WAN): IP 195.202.171.67 (apache, hmailserver, bind...)
NIC 2 (LAN): IP 192.168.0.57 (filesharing, vnc)

All other programs use the WAN Nic correctly, just hmailserver trys to send over LAN nic (other services are fine with WAN nic)

NOTE: If I disconneced the LAN nic cable hmailserver works IF I remove the IP Adress from the bind to field within smtp settings.

Message: The requested address is not valid in its context

see my screenprint

greetings daniel
Attachments
Zwischenablage02.jpg

daddy_dandy
New user
New user
Posts: 11
Joined: 2011-03-07 22:35

Re: SMTP delivery of email bind to local ip address not wor

Post by daddy_dandy » 2011-03-08 22:01

I'm running 7 Ultimate and can't get SMTP to send out either. http://www.hmailserver.com/forum/viewto ... =6&t=20134 Maybe hMailServer isn't yet compatible with Windows 7?

User avatar
mattg
Moderator
Moderator
Posts: 21186
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: SMTP delivery of email bind to local ip address not wor

Post by mattg » 2011-03-08 23:24

Windows 7 isn't on the approved software list, but I am fairly sure others have it working

http://www.hmailserver.com/documentatio ... quirements
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
daz69
Normal user
Normal user
Posts: 128
Joined: 2010-07-20 15:22
Location: Cornwall

Re: SMTP delivery of email bind to local ip address not wor

Post by daz69 » 2011-03-09 00:21

I've had 2 win 7 pro servers running for 6 months with no major problems.

User avatar
mattg
Moderator
Moderator
Posts: 21186
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: SMTP delivery of email bind to local ip address not wor

Post by mattg » 2011-03-09 01:26

computerateitleat wrote:On my server (windows 7 pro) sending of Email is not possible, because hmailserver uses the wrong nic (if I deactivate this nic, hmailserver works fine).
I suspect that this is more about how the NICs are handled, rather than being an issue between hmailserver and windows 7.

I'm not sure of a solution though, other than to use just the one NIC, but I'm guessing that that is not practical in your setup...
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

computerateitleat
New user
New user
Posts: 16
Joined: 2011-03-05 02:22

Re: SMTP delivery of email bind to local ip address not wor

Post by computerateitleat » 2011-03-09 09:31

Thank you for your reactions!

I just want to add: IF i configure a falid DNS and Gateway on LAN NIC hmailserver CAN send MOST of the time - but then, after 10 mails or so, suddenly the problem is there again.

I deactivted any Firewall for testing - no difference.

Is here anyone who actuelly uses Win7 AND 2 NICs in the server?
Is there a way to ask the developers about?
Is here anyone who actuelly USES the feature SMTP bind to IP - and it works? (usually that is not needed)

greetings daniel

computerateitleat
New user
New user
Posts: 16
Joined: 2011-03-05 02:22

Re: SMTP delivery of email bind to local ip address not wor

Post by computerateitleat » 2011-03-09 10:06

Hello again!

I found the problem! I used Symantic Norton AntiVirus - after I removed it (deactivat dindn't help) teh BIND to IP feature worked!

Of course that dose not solve my problem (since NAV is the single AV that I really know, and on my server I don't want any AV that I do not know) - but so I will find any way to work around.

greetnings daniel

ObiWan
Senior user
Senior user
Posts: 280
Joined: 2010-07-21 14:30
Location: Halfway between Germany and Egypt

Re: SMTP delivery of email bind to local ip address not wor

Post by ObiWan » 2011-03-09 14:17

computerateitleat wrote:Hello again!

I found the problem! I used Symantic Norton AntiVirus - after I removed it (deactivat dindn't help) teh BIND to IP feature worked!

Of course that dose not solve my problem (since NAV is the single AV that I really know, and on my server I don't want any AV that I do not know) - but so I will find any way to work around.

greetnings daniel
NAV isn't an antivirus, it's a virus :) - seriously, throw away NAV and get yourself a real AV

ObiWan
Senior user
Senior user
Posts: 280
Joined: 2010-07-21 14:30
Location: Halfway between Germany and Egypt

Re: SMTP delivery of email bind to local ip address not wor

Post by ObiWan » 2011-03-09 14:18

computerateitleat wrote:Hello!

On my server (windows 7 pro) sending of Email is not possible, because hmailserver uses the wrong nic (if I deactivate this nic, hmailserver works fine).

So I need to use the feature SMTP delivery of email bind to local ip address BUT the problem remains - hmailserver trys to use my lan NIC. How can I get this feature to work on Windows 7?

NIC 1 (WAN): IP 195.202.171.67 (apache, hmailserver, bind...)
NIC 2 (LAN): IP 192.168.0.57 (filesharing, vnc)

All other programs use the WAN Nic correctly, just hmailserver trys to send over LAN nic (other services are fine with WAN nic)

NOTE: If I disconneced the LAN nic cable hmailserver works IF I remove the IP Adress from the bind to field within smtp settings.

Message: The requested address is not valid in its context

see my screenprint

greetings daniel
in network advanced settings, change the bind order for the NICs and ensure
that the "WAN" comes first

computerateitleat
New user
New user
Posts: 16
Joined: 2011-03-05 02:22

Re: SMTP delivery of email bind to local ip address not wor

Post by computerateitleat » 2011-03-09 18:16

Hello Again!

First: I will not start an discussion about software, we all know, the everyone likes different kind of software, and we all know, that everyone has different experiences with it - there are people that use linux! *s*

Second: the priorisation of NICs is clear to me and I tryed that - since the deinstallation of NAV made everything working - so that could not be the reason

Third: the workaround/solution
It was clear, that NAV is the problem. After research it was clear for me, that de "outgoing email scanner" has to be the problem because it acts within the Network Connection in port 25 and cannot different between two NICS in this matter (NAV is a home product).

The workaround is, to JUST DEACTIVATE OUTGOING EMAIL SCAN in NAV Settings (Network settings - Email - configuration) by removing the chek from the checkbox.
But then in the Mainwindow of NAV the message "your computer needs attantion" and if you click on "repair" the email scan will be activated again.
For this reason I contacted Symantec today, and the told me, how to Ignore Email Settings in NAV Control, so the will not be activated automaticly: Open NAV Main Window - Point (just point, dont click) on "Email" in the right Window Area - a mall box will appear in wich you can click "ignore" .

So everything is fine for me - hope someone can use this information

greetings daniel

Post Reply