Page 1 of 1

hmail stops connecting with imap.

Posted: 2012-05-30 23:15
by huntor
This issue has just started with the last few weeks. I am running the most current version of 5.4 posted the other day. However this problem was happening before that issue.

It seems hmail will not connect with my webmail.

ERROR: Connection dropped by IMAP server.

I looked in the hmail log and I get this everytime I try to login.
"TCPIP" 3772 "2012-05-30 15:58:53.269" "TCP - 127.0.0.1 connected to 127.0.0.1:143."
"TCPIP" 3772 "2012-05-30 15:58:59.956" "TCP - 127.0.0.1 connected to 127.0.0.1:143."
"TCPIP" 3772 "2012-05-30 15:59:01.342" "TCP - 127.0.0.1 connected to 127.0.0.1:143."
"TCPIP" 3772 "2012-05-30 15:59:20.106" "TCP - 127.0.0.1 connected to 127.0.0.1:143."
"TCPIP" 3772 "2012-05-30 16:02:40.862" "TCP - 127.0.0.1 connected to 127.0.0.1:143."
"TCPIP" 3772 "2012-05-30 16:02:45.206" "TCP - 127.0.0.1 connected to 127.0.0.1:143."
"TCPIP" 3772 "2012-05-30 16:06:16.592" "TCP - 127.0.0.1 connected to 127.0.0.1:143."

Now if I shut the service down and start it back up I can login again.
Any help on this will be great. Like I said all out of the blue it started happening. I also see there is a period after the 143????

Re: hmail stops connecting with imap.

Posted: 2012-05-30 23:25
by ^DooM^
Change your my computer ip range priority to 25, you are probably getting auto banned.

Re: hmail stops connecting with imap.

Posted: 2012-05-31 03:39
by huntor
It was set to 30 would this make any difference?

Re: hmail stops connecting with imap.

Posted: 2012-05-31 03:45
by Bill48105
huntor wrote:It was set to 30 would this make any difference?
30 is higher than 20 so 30 take precedence over one that is 20.

Re: hmail stops connecting with imap.

Posted: 2012-05-31 06:24
by huntor
I only have two listed in that field and the 127.0.0.1 was listed 30 and now is 20 which is still higher then the other one. I don't think this will fix the issue. Like I said been running it for a couple of years now and this is the first time I started having this issue. Weird!!!

Re: hmail stops connecting with imap.

Posted: 2012-05-31 06:32
by Bill48105
DooM likely suggested ip range autoban because it is common thing to happen 'out of the blue' where it was working before. Doesn't mean it is the case with you.

Do you have real-time antivirus or firewall on the server? Maybe one of those is the cause. Do you have other services like http/dns etc that could be using up all your sockets? (I noted you said webmail so that is partially answered but what about a public web site)

Anyway just a few ideas to help you try & narrow it down.
Bill

Re: hmail stops connecting with imap.

Posted: 2012-05-31 22:13
by huntor
Windows firewall. ClamAV Only runs with hmail. Microsoft Security Essentials. Abyss Web Server.

But all of these I have been running for a few years now with very little changed.

I haven't had connection issues with any other service as webmail will load up. The issue just comes to login.
So far hasn't stopped working correctly.

Would hmail ever block 127.0.0.1 if to many connections???

Update
P.S. I changed my imap Connections from 10 to 50.
I think that might have been what was causing it.

Re: hmail stops connecting with imap.

Posted: 2012-05-31 22:51
by Bill48105
huntor wrote:Windows firewall. ClamAV Only runs with hmail. Microsoft Security Essentials. Abyss Web Server.

But all of these I have been running for a few years now with very little changed.

I haven't had connection issues with any other service as webmail will load up. The issue just comes to login.
So far hasn't stopped working correctly.

Would hmail ever block 127.0.0.1 if to many connections???

Update
P.S. I changed my imap Connections from 10 to 50.
I think that might have been what was causing it.
Ahh yeah if you have only 10 connections set & 11th comes it then it just gets dropped BUT it gets logged that it connection limit was reached too.
Bill