Search found 300 matches

by gruenie
2013-04-20 07:44
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Bill, thanx for the explanation. But that sounds far frm being easy and without problems. I think its a better idea to do a fresh and clean installation of ASSP V2. But the other question I have was: Will your changings of the assp.pl and in hmailservers EventHandlers.vbs to avoid attacks also...
by gruenie
2013-04-19 16:50
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hi Bill, I have in mind to ugrade from ASSP 1.98 to the current version 2.2.1. Can you tell me in some words how to upgrade on a windows-server without losing my current settings? Will your changings of the assp.pl and in hmailservers EventHandlers.vbs also work with this version of ASSP? Thanx for ...
by gruenie
2013-04-15 00:45
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

@ Bill48105: Hello Bill, after some days of testing the new security-settings it seems as it would work. I did not have any new entries in the autobanned IP-ranges which pointed to the IP of ASSP. There were some new entries but all with outside IPs (probably someone tried to use the port 587 in hM...
by gruenie
2013-04-11 13:04
Forum: General discussions
Topic: "Use SSL" with external Account not working
Replies: 44
Views: 28356

Re: "Use SSL" with external Account not working

Hi Caspar, lets sum your last explanations: 1. Put the private key and the un edited server-certificate which I got from "StartSSL" in one folder (f.e. D:\certificates) and point to the 2 files in the SSL-settings of hmailserver. 2. Looking for the hash-value of the Root-certificate and rename that ...
by gruenie
2013-04-11 09:39
Forum: General discussions
Topic: "Use SSL" with external Account not working
Replies: 44
Views: 28356

Re: "Use SSL" with external Account not working

Hi Caspar, thanx again for the answer. What i meant: <hashcode>.o needs to have the information of the intermediate, and the root. Ok, but the hash-value I takre from the root certificate?!. And this file I have to place into the folder <hMailServer>\Externals\CA? Just want to be sure. How can I che...
by gruenie
2013-04-10 19:37
Forum: General discussions
Topic: "Use SSL" with external Account not working
Replies: 44
Views: 28356

Re: "Use SSL" with external Account not working

Hi again Caspar,
about which file you are speaking? Which file I have to rename to <hash_value>.0 - is it the CA.pem or my server.CRT?

I added the content of the intermediate certificate to my server.CRT (by the way that only worked in the opposite order as in the howto).
by gruenie
2013-04-10 19:28
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hi Bill, LOL, no I did not speak about the changes in ASSP which could make any trouble with fetching external ssl-accounts because ASSP is not involved, but we did some changes in hmailserver too. Just wanted to be sure in the moment when I asked. I had some new entries in hmailservers Auto-ban-tab...
by gruenie
2013-04-10 12:30
Forum: General discussions
Topic: "Use SSL" with external Account not working
Replies: 44
Views: 28356

Re: "Use SSL" with external Account not working

Hi Caspar, now I'm confused completely. I have an official certificate from startssl.com and not a self signed. From there I got my server certificate (let me say mail_mydomain_de.crt), an intermediate certificate (sub.class1.server.ca.pem) and a root-certificate (ca.pem). As described in the howto ...
by gruenie
2013-04-10 10:47
Forum: General discussions
Topic: "Use SSL" with external Account not working
Replies: 44
Views: 28356

Re: "Use SSL" with external Account not working

Hi Martin, since I installed my certificates in hmailserver I have the same problems to connect to/fetch from external accounts which have ssl enabled (gmail, hotmail). In the following topic here in the forum is an explanation how to set up certifiates in hamailserver: http://www.hmailserver.com/fo...
by gruenie
2013-04-10 10:45
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Problem with fetching external ssl-acounts is solved! There is a wrong description for setting up own SSL-certificates in the following topic: http://www.hmailserver.com/forum/viewtopic.php?f=12&t=22371 There is explained to rename the external ca.cert to <hash_value>.0 and to place that file in th...
by gruenie
2013-04-10 10:15
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hi Bill, with additional enabling TCP/IP-Logging I got a result: for Gmail: "DEBUG" 4984 "2013-04-10 09:47:29.466" "Creating session 241" "TCPIP" 4984 "2013-04-10 09:47:29.466" "Connecting to pop.gmail.com..." "TCPIP" 2032 "2013-04-10 09:47:29.560" "TCPConnection - SSL handshake with client failed. ...
by gruenie
2013-04-10 09:40
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

@ tko2003: Ok, I will publish the German version of it if I'm absolutely sure that it works without any problems. Btw I'm from Halle (Saxonia-Anhalt). @ Bill48105: Hi Bill, since yesterday hmailserver does not fetch my mails from external gmail- and hotmail-accounts any more; before it worked. Fetch...
by gruenie
2013-04-09 22:32
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

@ Bill48105: Ok, thanx for the advice, I just added the IP to the lists you told me. :-) @ tko2003: Are you from Germany too? ;-) But the language of this board is just english. Where you want to publish this tutorial in German language? Are you sure it is necessary because now after discussing all ...
by gruenie
2013-04-09 21:33
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Bill,

after changing the code back and restarting ASSP it seems to work.
At least all my emails I sent from 3 different mailaccounts and servers arrived.

Hope that it has been the solution.

Thanx again for your time you spent to solve my problem.
Gruenie
by gruenie
2013-04-09 20:41
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Bill, today I finished all the changings in ASSP as you adviced me. But unfortunately there seems to be a wrong setting, because after doing all the changes no email from outside have been arrived any more. The sender got the message: Your message did not reach some or all of the intended reci...
by gruenie
2013-04-08 21:30
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Bill, I created a subdomain (let me say "assp.mydomain.de"), added this domain as local in ASSP and added a route to hmailserver to forward all messages to this subdomain to ASSP. It seems to work. So all the users can use the email-interface of ASSP if they want to. In addition I added SSL-su...
by gruenie
2013-04-08 01:09
Forum: General discussions
Topic: Unable to rename account names after upgrading to 5.4
Replies: 6
Views: 3430

Re: Unable to rename account names after upgrading to 5.4

Hi Matt,
thanx again for the fast reply.
Now I got it. :-)
There have been really 2 messages within the some thousands where I found an absolute path in front of the file name. After I fixed it I could rename the accounts.

Thanx again!
by gruenie
2013-04-08 01:02
Forum: General discussions
Topic: Unable to rename account names after upgrading to 5.4
Replies: 6
Views: 3430

Re: Unable to rename account names after upgrading to 5.4

Hello Matt,

thanx for the fast reply.
Yes, I have access to the mysql-server.

But in the table "HM_messages" are just filenames like {08578D52-D93C-4EBC-85A2-432B8616BB79}.eml and no path-informations in the field "messagefilename".
by gruenie
2013-04-08 00:47
Forum: General discussions
Topic: Unable to rename account names after upgrading to 5.4
Replies: 6
Views: 3430

Unable to rename account names after upgrading to 5.4

After upgrading from hMailServer 5.3.3 to 5.4 - b. 1942 I have been unable to rename current accounts. I'm always get the error-message like shown in the screenshot below. I'm using hMailserver with exxternal MySQL. hMS_error_renameAccount.jpg I was running the DataDirectorySynchronizer but it still...
by gruenie
2013-04-07 19:47
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Bill, I downgraded my hmailserver to version 5.4-b1942. Of course the security is much more important then functionality of ASSP. But the sense of ASSP is to avoid as much spam as possible. And so the email-interface in my view is an important feature to enable users to put senders to their ow...
by gruenie
2013-04-07 17:30
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Bill, thanx again for your answer. If you don't do any forwarding in hmail (aliases, forwards, rules, scripts) then the bug wouldn't matter to you. Of course I have many aliases, forwards and ruls in my hmailserver-installation. If I understood you right, the forwarding-bugs are fixed in your ...
by gruenie
2013-04-07 10:41
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Bill, I upgraded to version 5.4 - b1946 yesterday - so could you tell me please where I can download the version in which the forwarding issues are fixed? Which adjustments I should do so that the users can send mails using port 25 of ASSP but nevertheless I could use your suggestion for ASSP ...
by gruenie
2013-04-07 02:29
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Bill, again thanx for your answer and your help. First to answer your questions: I'm using hmailserver 5.3.3 - Build 1879 and ASSP 1.98. Should I update to hmailserver 5.4 in a production environment? Before I use your suggestions I try to understand all what you wanted to tell me. Thats why f...
by gruenie
2013-04-06 21:08
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Bill, thanx for the answer and th help. No, I set the public IP of the mailserver in assp and hmailserver, so the incoming emails are forwarded from the public IP port 25 to the public IP pot 2525. So the logs in hmail show the public IP for incoming mails - and this is the same IP as shown in...
by gruenie
2013-04-06 19:45
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Re: Permanently attacks from the mailservers own public IP

Hello Mattg, thanx for the reply and the first suggestions. But I fear nothing of your ideas is matching the problem exactly. But let me answer step by step: A webmail-user cannot be the reason, because all these still happens after disabling the completely webmail-system at all. A terminal-service-...
by gruenie
2013-04-06 12:34
Forum: General discussions
Topic: Permanently attacks from the mailservers own public IP
Replies: 62
Views: 32376

Permanently attacks from the mailservers own public IP

Hi guys, after a longer time again greetings from Germany and a question: Since some days I realized permanent attacks probably from hackers who ty to hack mail-accounts. I have Auto-ban enabled and after 3 failed login-tries the IP of the user should be banned. The starnge thing is that there is al...
by gruenie
2009-05-13 23:08
Forum: General discussions
Topic: Deleted messages appear again in Thunderbird
Replies: 14
Views: 4562

Re: Deleted messages appear again in Thunderbird

The problem still exists here at 2 different servers (as already explained). The messages are not only reappearing after beeing deleted, but also if I move them to another folder. In this case they are really moved and exist in the target folder, but reapper in the inbox too. Sometimes it happens im...
by gruenie
2009-04-27 05:50
Forum: General discussions
Topic: Deleted messages appear again in Thunderbird
Replies: 14
Views: 4562

Re: Deleted messages appear again in Thunderbird

I will monitor it again tomorrow and see if I can find out something more.
Especially at one of the servers are about 20 people who are all using
Thunderbird with IMAP. I'm curiou if I get same informations from them
after the upgrade this weekend....
by gruenie
2009-04-27 04:25
Forum: General discussions
Topic: Deleted messages appear again in Thunderbird
Replies: 14
Views: 4562

Re: Deleted messages appear again in Thunderbird

Both laptops are connected to all 3 servers with IMAP. But I'm using only one of the laptops in the same time. But if I'm using one of the laptops, they are always online. Nevertheless it makes no difference if Thunderbird is running or ended; the deleted messages reappear in both cases (not always,...
by gruenie
2009-04-27 04:08
Forum: General discussions
Topic: Deleted messages appear again in Thunderbird
Replies: 14
Views: 4562

Re: Deleted messages appear again in Thunderbird

Ok, a little bit more detailed: - 3 Servers at 3 different locations were running hmailserver 4.4.4 - 2 of my laptops with 2 Thunderbird-Installations (and in both I have mail-accounts to the 3 hmailservers All worked fine for a long time. (Btw: I'm using hmailserver and Thunderbird for many years a...
by gruenie
2009-04-26 17:38
Forum: General discussions
Topic: Deleted messages appear again in Thunderbird
Replies: 14
Views: 4562

Re: Deleted messages appear again in Thunderbird

Nobody knows the problem of reappearing messages with Thunderbird?? :o But it happenes in 2 different mailservers after upgrading to version 5.1.x Do you have any ideas, what I could do or check??? To the PHPWebadmin-problem. If I'm right, in the version 4.x there was a german language file included...
by gruenie
2009-04-26 16:41
Forum: General discussions
Topic: Deleted messages appear again in Thunderbird
Replies: 14
Views: 4562

Deleted messages appear again in Thunderbird

Hi Martin, hi to all, since I upgraded to version 5.1.1 I have the problem, that in Thunderbird deleted messages appear again when I restart Thunderbird. When I delete the message they appear in the trash- folder (like it should be). Then I empty the trash and later I start Thunderbird again and the...
by gruenie
2007-06-12 14:14
Forum: General discussions
Topic: 550 error
Replies: 3
Views: 2494

Hi hawk007,
in addition to this please make sure, that you are editing the right (active) php.ini. In installations like XAMPP you have multiple php.ini's on different places, but only one is used.
The php.ini_dist is only an example, you do not need to edit it.
Gruenie
by gruenie
2007-06-10 17:51
Forum: General discussions
Topic: accessing phpwebadmin
Replies: 10
Views: 5403

Who is "he"? Are you talking about me or sleepydeepeyed?
by gruenie
2007-06-10 15:18
Forum: General discussions
Topic: accessing phpwebadmin
Replies: 10
Views: 5403

If you type in: http://localhost/phpwebadmin/ (with the slash at the end) it should work too.
Gruenie
by gruenie
2007-06-08 14:22
Forum: Off-topic discussions
Topic: BEER
Replies: 31
Views: 18511

Three friends have been going to camp together to have fun and to play cards the whole days. On the next morning the first of them went to the supermarket to supply all with food. He came back with a crate of beer and one bread. The other two friends stared to the bread... .. until one of the both w...
by gruenie
2007-05-20 13:37
Forum: Archived feature requests
Topic: Shared folders when using IMAP
Replies: 89
Views: 92417

AVM Ken! is a German all-in-one-product for internet-services:

http://www.avm.de/de/Produkte/Fuer_Unte ... index.html
by gruenie
2007-05-20 01:54
Forum: General discussions
Topic: missed icon: icon_pm.gif
Replies: 2
Views: 1171

missed icon: icon_pm.gif

Hi Martin,

it seems, that the icon "icon_pm.gif" inside the posts is missed, maybe you deleted it by accident?

Gruenie
by gruenie
2007-05-19 02:06
Forum: General discussions
Topic: What does the setting Primary Domain do?
Replies: 4
Views: 2401

Normally the users have to enter username@yourdomain.com as login-name (f.e. in mailclients, PHPWebAdmin). If you enter a "primery domain" there (f.e. "domain2.de"), it is used, if the user only enters his name (without the domain-part). This "primary domain" must be of course existent on your serve...
by gruenie
2007-04-26 14:31
Forum: General discussions
Topic: squirrelmail vacation 4.4 B270 crashes xampp?
Replies: 5
Views: 3150

Hi nikolajhendel, what exactly happens, when you "try to use" (sure you mean open it?!) the vacation-plugin: Apache crashes or you get a timeout? Did you enable "error_reporting" (set to E_ALL), "display_errors", "com.allow_dcom" in your php.ini (be sure, that you are using the right php.ini, becaus...
by gruenie
2007-04-16 08:47
Forum: Development & alpha discussions
Topic: hMailServer 4.4 = stable?
Replies: 30
Views: 20867

Running on 3 servers without any problems!
by gruenie
2007-04-16 08:45
Forum: Development & alpha discussions
Topic: hMailServer 5 - hMailServer Administrator
Replies: 49
Views: 42610

Any ideas to use it remotely (I mean ouside the LAN over the internet) in a simple way for people, who are not programmers :-) (I know, he problem are ports/permissions for DCOm)?
by gruenie
2007-04-16 08:35
Forum: Archived feature requests
Topic: Vacation: Set start-date/time
Replies: 0
Views: 1825

Vacation: Set start-date/time

We already have an automatic expirations-date for vacation-messages, but wouldn't it be a good idea to also be able to set a start-date/time, so we could set the vacation-message for a whole period in the future (like holidays etc.) and we could be sure not to forget it?

Gruenie
by gruenie
2007-04-12 14:31
Forum: General discussions
Topic: Vacation/Autoresponder - blank page?
Replies: 36
Views: 16431

LOL
by gruenie
2007-04-12 14:20
Forum: General discussions
Topic: Vacation/Autoresponder - blank page?
Replies: 36
Views: 16431

Nit-picker, you! :P Colloquial we are saying, that md5 is a "one-way-encryption", aren't we? Colloquial, I know. In the RFC 1321 you will nowhere find the term "hash", so to be exact, it is a MD=message digest - to be a bigger nit-picker than you! :P RFC 1321: ... 1. Executive Summary This document ...
by gruenie
2007-04-12 03:41
Forum: General discussions
Topic: Vacation/Autoresponder - blank page?
Replies: 36
Views: 16431

Its late and I'm right back home, but I see, that you fixed the problem of Phr0zen. Cool. Martin, I didn't say to Phr0zen, that he should enter the md5-encrypted password in the config.php of the plugin. I only wanted to find out, if both settings (in the config.php and in the hmailserver.ini) match...
by gruenie
2007-04-11 01:22
Forum: General discussions
Topic: Vacation/Autoresponder - blank page?
Replies: 36
Views: 16431

Hi Phr0zen, your posted error-message: [10-Apr-2007 17:13:44] PHP Fatal error: Uncaught exception 'com_exception' with message '<b>Source:</b> hMailServer COM library<br/><b>Description:</b> You do not have access to this property / method. Ensure that hMailServer.Application.Authenticate() is calle...
by gruenie
2007-04-10 14:17
Forum: Archived feature requests
Topic: recive email fom IMAP folder with pop
Replies: 4
Views: 3337

All incoming mails will autmatically "forwarded" to the users INBOX (and that is the current folder, where pop3 is fetching the mails), besides you were creating a rule, that the incoming mails are forwarded to another folder. In my eyes it makes no sense to setup a rule to forward incoming mails to...
by gruenie
2007-04-10 14:02
Forum: General discussions
Topic: Vacation/Autoresponder - blank page?
Replies: 36
Views: 16431

Hi Phr0zen, your last post here is from April 5th, what is the current state? Could you fix the problem, and if yes, what was the reason? Because I made some changes in the SM-hMS-vacation-plugin (which is included in the newer hMailServer-downloads), I'm also interested to know, where could be the ...
by gruenie
2007-04-09 18:47
Forum: Archived feature requests
Topic: Unicode support
Replies: 6
Views: 4202

You are right, Martin, it is the job of the mailclient to convert the IDN-domainnames into the coded xn--...-xxx-structure and not the job of the server; there you have to add the domains in the coded version. It was my fault. And most of the existing clients do not support IDN-domain-names yet (nei...
by gruenie
2007-04-09 18:06
Forum: Archived feature requests
Topic: recive email fom IMAP folder with pop
Replies: 4
Views: 3337

Why not simply using IMAP, so you have access to all of your folders whenever you want?
by gruenie
2007-04-09 18:02
Forum: Archived feature requests
Topic: Unicode support
Replies: 6
Views: 4202

Unicode-support would be great. We have 4 special characters in German (3 of them in lower and in upper case) and there id the Euro-Symbol as well f.e. Does hMailserver support domain-names including special characters? In Germany we have so called IDN-Domains (*.de-Domains) which support any German...
by gruenie
2007-03-20 14:14
Forum: General discussions
Topic: [deutsch] Bug im hMailServer bei meinem Provider?
Replies: 4
Views: 2618

Hi Sven, soweit ich das weiß, gibt es keine Mechanismen, das Löschen des letzten Kontos innerhalb einer Domain zu verhindern. Um aber Deine generelle Frage über Art und Umfang von Berechtigungen innerhalb von hmailserver zu beantworten, mal folgendes: 1. Es gibt 3 Level von Berechtigungen: Administr...
by gruenie
2007-03-20 02:30
Forum: General discussions
Topic: [deutsch] Bug im hMailServer bei meinem Provider?
Replies: 4
Views: 2618

Hallo Svenaldo2, eigentlich geht es ja hier um zwei Dinge: Einmal willst Du eine Meinung (von uns hier) haben, wie man das Verhalten Deines Providers bewertet, andererseits möchtest Du aber auch das Problem gelöst haben, oder? Zu 1.: Das Verhalten deines Providers finde ich - mit verlaub -. bescheue...
by gruenie
2007-03-16 02:14
Forum: Development & alpha discussions
Topic: hMailServer 4.4, Build 263 (Beta!)
Replies: 1
Views: 2087

Congratiolations to the first 4.4-beta! :-)
Version 262 is running on 3 different servers without any problem here.
Gruenie
by gruenie
2007-03-14 01:19
Forum: General discussions
Topic: Problem mit Hmail Server V4.3.1
Replies: 27
Views: 34413

Hallo Eddye, wieso Du nun Windows 2000 nach den Schritten, die ich hier geschrieben habe (hast Du es wirklich in der Reihenfolge gemacht und nichts ausgelassen???), nicht installieren konntest, verstehe ich überhaupt nicht, aber wenn Du es nun anders hinbekommen hast, ist es ja OK. Wieso eine Deiner...
by gruenie
2007-03-11 02:16
Forum: Development & alpha discussions
Topic: Stable version
Replies: 6
Views: 4475

Running hmailserver 4.4-b262 on 3 different servers without any problems!
Martin, did you get my latest version of the SM-plugin for hms-vacation, which I sent you some days before by mail?
Gruenie
by gruenie
2007-03-10 01:56
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 220678

Hi ^DooM^: You are welcome! Hi pccsq1: You are welcome! :lol: Nevertheless we could carry the script to extremes: 1. Only send admin-mail, if a (valid) admin-mailaddress is entered 2. Add language support for the messages and form-fields 3. Add rules for the accont-name and check the input 4. Add ru...
by gruenie
2007-03-09 20:41
Forum: User contributed hMailServer 4 scripts
Topic: Let Users create their own accounts (Upgraded for 4.3)
Replies: 178
Views: 220678

Hi pccsq1, the dcom-error, which you posted cannot come from using that script, because - like ^DooM^ said - there is not one COM-element in it. Nevertheless I had a look at the script you posted here and found some php- and logical errors in it. I made some changes and hope, it is working for you n...
by gruenie
2007-03-09 03:39
Forum: Development & alpha discussions
Topic: hMailServer 4.4, Build 262 (Alpha)
Replies: 33
Views: 22550

Hi pccsq1, congratulations, I'm happy, that you got it fixed now! ;-) Nevertheless I would like to know, which (wrong) setting in the active php.ini was the reason for the problem you had. Was it the "com.allow_dcom"-setting or what else? Maybe that knowledge could help, if others have a similar pro...