Search found 39 matches

by Kriztan
2019-04-08 21:29
Forum: Development & alpha discussions
Topic: hMailServer web-interface redesign
Replies: 162
Views: 50883

Re: hMailServer web-interface redesign

I've tried to reproduce your issue but I couldn't, it might be something wrong with your installation. Also, you mention "hmailadmin on the server" and "remote webadmin" - which is which? There is "hMailServer Administrator" (GUI executable on server), there is "PHPWebAdmin" (stock web admin) and "...
by Kriztan
2019-02-26 21:29
Forum: Development & alpha discussions
Topic: hMailServer web-interface redesign
Replies: 162
Views: 50883

Re: hMailServer web-interface redesign

Sorry for my late response. I've tested it again and created a new rule with one criteria and one action. Not only the action is created twice, also the new rule was created twice. I've checked it with hmailadmin on the server, not via the remote webadmin. I've recognized another strange thing: the ...
by Kriztan
2019-02-22 21:51
Forum: Development & alpha discussions
Topic: hMailServer web-interface redesign
Replies: 162
Views: 50883

Re: hMailServer web-interface redesign

Hi coax,
thanks for your nice webinterface. I'm unsing this since some weeks and noticed, that version 1.5 creates duplicate rule actions. Can anybody confirm this?
by Kriztan
2017-07-24 08:04
Forum: General discussions
Topic: tool suggestion to filter logs and alert admin
Replies: 5
Views: 1175

Re: tool suggestion to filter logs and alert admin

Good morning, yes, you are right mattg, but if the mail server doesn't work at all, i'll will recognize this by not being able to connect to and you can send an info about a crash of hmailserver via ms event viewer. But what I'm also interested in is a notification about auto bans. I don't know how ...
by Kriztan
2017-07-21 13:48
Forum: General discussions
Topic: tool suggestion to filter logs and alert admin
Replies: 5
Views: 1175

Re: tool suggestion to filter logs and alert admin

Thanks jimimaseye, I'll try it out :)

Kriztan
by Kriztan
2017-07-21 13:17
Forum: General discussions
Topic: tool suggestion to filter logs and alert admin
Replies: 5
Views: 1175

tool suggestion to filter logs and alert admin

Hi everyone, hmailserver has a nice logging implementation and one day with a less number of active accounts produces thousands of lines in the logs. Nobody wants to look through this lines manually, so it would be nice if anybody has some tool suggestions to filter and prepare alert mails based on ...
by Kriztan
2015-08-17 19:47
Forum: Feature requests
Topic: Delete or empty folder - warning dialogue
Replies: 8
Views: 5491

Re: Delete or empty folder - warning dialogue

Hi,

I've just noticed, that this warnings are not implemented in the latest official builds yet.
I'm currently running version 5.6.4 - Build 2283.
Please add this feature into the official builds.

Thanks kriztan
by Kriztan
2014-09-03 12:23
Forum: User contributed hMailServer 5 scripts
Topic: SpamAssassin Bootcamp (sa-learn) train BAYES
Replies: 125
Views: 43612

Re: SpamAssassin Bootcamp (sa-learn)

SorenR wrote:Did you change "SPAM" in line 16 to your actual SPAM folder?
Yes I did, but I have some administrative accounts like info@domain.tld and there was the failure. Now I've created an IMAP folder called Junk and the scipt works fine.
Thanks
by Kriztan
2014-09-03 10:38
Forum: User contributed hMailServer 5 scripts
Topic: SpamAssassin Bootcamp (sa-learn) train BAYES
Replies: 125
Views: 43612

Re: SpamAssassin Bootcamp (sa-learn)

Hi,
thanks for this nice script. On my Win Server 2008 R2 this script fails, with the following failure (see attached file).
Line 45 is

Code: Select all

Set objIMAPFolder = objAccount.IMAPFolders.ItemByName(hmSPAMFolder)
Any ideas?

Thank Kriztan
by Kriztan
2014-02-13 11:19
Forum: Development & alpha discussions
Topic: No message body with active signature in hmailadmin
Replies: 13
Views: 7569

Re: No message body with active signature in hmailadmin

No, this plain text mails doesn't contain html content. Source code, working before update to latest experimental: Return-Path: info@domain.tld Delivered-To: me@domain.tld Received: from Server (localhost [127.0.0.1]) by server with ESMTP ; Thu, 13 Feb 2014 09:29:38 +0100 Message-ID: <24A0C486-B355-...
by Kriztan
2014-02-13 10:21
Forum: Development & alpha discussions
Topic: No message body with active signature in hmailadmin
Replies: 13
Views: 7569

Re: No message body with active signature in hmailadmin

After adding

Code: Select all

Content-Type: text/plain; charset=ISO-8859-1
to my PHP mail() script, all is working perfect. But why? Is this header field Content-Type not only necessary for HTML mails? Why was this working without Content-Type with the B1950?
by Kriztan
2014-02-13 09:59
Forum: Development & alpha discussions
Topic: No message body with active signature in hmailadmin
Replies: 13
Views: 7569

Re: No message body with active signature in hmailadmin

Some new tests and knowledges: It has somethis to do with my PHP mail() function. Sending mails via mail client like roundcube was working fine, and with both, plaintext and html signatures.
by Kriztan
2014-02-13 09:31
Forum: Development & alpha discussions
Topic: No message body with active signature in hmailadmin
Replies: 13
Views: 7569

Re: No message body with active signature in hmailadmin

Here are the logs: "TCPIP" 12736 "2014-02-13 08:19:55.913" "TCP - 127.0.0.1 connected to 127.0.0.1:25." "DEBUG" 12736 "2014-02-13 08:19:55.929" "Creating session 768" "DEBUG" 13220 "2014-02-13 08:19:55.929" "!m_sSTARTTLS.IsEmpty() TRUE" "DEBUG" 408 "2014-02-13 08:19:55.960" "messagesize:: 479" "DEBU...
by Kriztan
2014-02-13 09:23
Forum: Development & alpha discussions
Topic: No message body with active signature in hmailadmin
Replies: 13
Views: 7569

Re: No message body with active signature in hmailadmin

I've tested it with deactivated global rules on an account with no account rules. The message is the same, no mail body except the signature.
by Kriztan
2014-02-13 09:11
Forum: Development & alpha discussions
Topic: No message body with active signature in hmailadmin
Replies: 13
Views: 7569

Re: No message body with active signature in hmailadmin

I have a PHP script witch sends me a short mail on server errors for example error 404. So i can see, where the problem is. This works since a time of at least two years without any problems. Hmail sends this mail over an info@domain.tld account witch has a plain text and html signature, becuase thi...
by Kriztan
2014-02-13 08:43
Forum: Feature requests
Topic: Script event OnPublicFolderChange
Replies: 9
Views: 4403

Script event OnPublicFolderChange

The Problem: User A and user B have the same public folder project XYZ . User A gets a mail and moves the mail into the public folder project XYZ . The was flagged as seen. User B will get no info about this mail until he looks manually into the public folder or user A informs user B about this new...
by Kriztan
2014-02-12 12:27
Forum: Scripting
Topic: run script after changing imap folder content
Replies: 2
Views: 1613

run script after changing imap folder content

Hi, is it possible to run a VB Script directly after the content of public folders has changed? The Problem: User A and user B have the same public folder project XYZ. User A gets a mail and moves the mail into the public folder project XYZ. User B will get no info about this mail until he looks man...
by Kriztan
2014-02-12 11:37
Forum: Development & alpha discussions
Topic: No message body with active signature in hmailadmin
Replies: 13
Views: 7569

No message body with active signature in hmailadmin

Hi, I'm using the LATEST EXPERIMENTAL BUILD - 5.4-B2014020501 on my system and it's working fine. But I've found a strange behaviour: When I send a mail with an local account with the hmail built-in signature, the mail message-body is empty. After deactivating the built in signature the mails arrive...
by Kriztan
2014-02-05 14:37
Forum: Development & alpha discussions
Topic: LATEST EXPERIMENTAL BUILD - 5.4-B2014060501
Replies: 228
Views: 145651

Re: LATEST EXPERIMENTAL BUILD - 5.4-B2014020501

Hil Bill,
I've found a strange behaviour:
When I send a mail with an local account with the hmail built-in signature, the mail message-area is empty. After deactivating the built in signature the mails arrive completely.
Can you check this?
Thanks Kriztan
by Kriztan
2014-02-05 11:03
Forum: Development & alpha discussions
Topic: LATEST EXPERIMENTAL BUILD - 5.4-B2014060501
Replies: 228
Views: 145651

Re: LATEST EXPERIMENTAL BUILD - 5.4-B2014020501

Are you sure they don't support SSL/TLS vs STARTTLS? Maybe on port 465? Hi Bill, I've already asked my hoster, but this is a time ago. He said, that SSL is only supported via STARTTLS. The classic SSL is not supported and SSL via port 465 was not working at this time. I'll test it now with this rel...
by Kriztan
2014-02-05 10:12
Forum: Development & alpha discussions
Topic: LATEST EXPERIMENTAL BUILD - 5.4-B2014060501
Replies: 228
Views: 145651

Re: LATEST EXPERIMENTAL BUILD - 5.4-B2014020501

Hi,
I'm using the LATEST EXPERIMENTAL BUILD - 5.4-B2014020501 on my system. Is it possible to use STARTTLS for relaying mails to a smart relay on port 25? My hoster only supports plain text auth and STARTTLS on port 25 together.
Thanks Kriztan
by Kriztan
2013-09-22 09:47
Forum: General discussions
Topic: IMAP Synchronization Issues with em Client
Replies: 3
Views: 7169

Re: IMAP Synchronization Issues with em Client

Can you help me with this script?
Tanks a lot.
by Kriztan
2013-09-18 09:44
Forum: General discussions
Topic: IMAP Synchronization Issues with em Client
Replies: 3
Views: 7169

Re: IMAP Synchronization Issues with em Client

My VBS is bad :(
Is it a lot of work to do this?
by Kriztan
2013-09-17 10:04
Forum: General discussions
Topic: IMAP Synchronization Issues with em Client
Replies: 3
Views: 7169

IMAP Synchronization Issues with em Client

I'm running hmailserver 5.4 Build 1950 on Windows 2008 R2 with MySQL Database. For some years I've used Thunderbird and the Android IMAP clients without any problems. Now I've changed my desktop IMAP Client to em Client because it is working much faster. But I've found that there are sometimes probl...
by Kriztan
2013-03-18 10:58
Forum: Development & alpha discussions
Topic: LATEST EXPERIMENTAL BUILD - 5.4-B2014060501
Replies: 228
Views: 145651

Re: LATEST EXPERIMENTAL BUILD - 5.4-B2012093001

Hi Bill,
is it possible, that there is a delay for mails bigger than 1 MB until 7pm in the build 5.4-B2013030601?
Take a look at the screenshot, I've sended two mails bigger than 1 MB and they are in the queue until 2013-03-18 19:00:00.
Thanks
Kriztan
by Kriztan
2013-03-09 11:15
Forum: General discussions
Topic: Timeout for external virusscanner
Replies: 9
Views: 5001

Timeout for external virusscanner

Hi Bill, Hmailserver is running very well on my Windows Server 2008 R2, but sometimes I have this entry in the error-logs: "ERROR" 7808 "2013-03-07 18:58:22.738" "Severity: 3 (Medium), Code: HM5400, Source: ProcessLauncher::Launch, Description: A launched process did not exit within an expected time...
by Kriztan
2013-03-07 16:28
Forum: Feature requests
Topic: Delete or empty folder - warning dialogue
Replies: 8
Views: 5491

Re: Delete or empty folder - warning dialogue

Yes, everything is working.
Thanks Bill!
by Kriztan
2013-03-07 08:12
Forum: Feature requests
Topic: Delete or empty folder - warning dialogue
Replies: 8
Views: 5491

Re: Delete or empty folder - warning dialogue

Thanks a lot, I wil test it and give you a feedback today evening.
by Kriztan
2013-03-05 19:05
Forum: Feature requests
Topic: Delete or empty folder - warning dialogue
Replies: 8
Views: 5491

Re: Delete or empty folder - warning dialogue

Hi Bill,
yes I am using 5.4.
Thanks a lot

Kriztan
by Kriztan
2013-03-05 15:20
Forum: Feature requests
Topic: Delete or empty folder - warning dialogue
Replies: 8
Views: 5491

Delete or empty folder - warning dialogue

In the menu for public IMAP folders there is a button to delete and empty a folder. It would be nice to get a warning message before everything is deleted. A few days ago, I had to backup a lot of mails and the database because I have clicked the empty folder button accidentally. Thanks a lot. Kriztan
by Kriztan
2011-11-25 08:25
Forum: General discussions
Topic: Server Messages with content-type: multipart/report
Replies: 6
Views: 2375

Re: Server Messages with content-type: multipart/report

Hello Bill, I've already tried to change the content-type using a script and with rules, but the real message is text/plain and after changing it to multipart/report the mails have no visible content. The reason why the server reported an error could only be seen by viewing the sourcecode of the mai...
by Kriztan
2011-11-24 14:45
Forum: General discussions
Topic: Server Messages with content-type: multipart/report
Replies: 6
Views: 2375

Re: Server Messages with content-type: multipart/report

But for Server Messages for example SEND_FAILED_NOTIFICATION the client is hMailServer...
by Kriztan
2011-11-24 14:03
Forum: General discussions
Topic: Server Messages with content-type: multipart/report
Replies: 6
Views: 2375

Server Messages with content-type: multipart/report

Hi,

is it possible to change the content-type of the build-in Server Messages from text/plain to multipart/report?
My eMail-Clients have special icons for reports which were only used by multipart/report.

Thanks a lot!
by Kriztan
2011-06-23 08:30
Forum: Feature requests
Topic: Privat seen flag for public folders
Replies: 2
Views: 1934

Privat seen flag for public folders

It would be great to add a privat seen flag for each user in public folders. I often have the problem, that one user reads a mail stored in a public folder and the other users have to check all the public folders for new mails, because this new mail is marked as seen by the first user.
by Kriztan
2010-03-17 16:45
Forum: General discussions
Topic: using web.de and SSL for SMTP fails
Replies: 7
Views: 5112

Re: using web.de and SSL for SMTP fails

Okay, but in the tutorial to configure SSL i have to use port 25. Nevertheless I tested it with the other ports 465 and 587, they arent't working too. You can't use SMTP over SSL with web.de email server. smtp.web.de runs plain text service on 25 port. Their tutorial confused SSL with StartTLS. So ...
by Kriztan
2010-03-17 16:36
Forum: General discussions
Topic: using web.de and SSL for SMTP fails
Replies: 7
Views: 5112

Re: using web.de and SSL for SMTP fails

Hello, I'm using hMailServer 5.3.2-B1769 and a web.de account. I fetch my mails with SSL on port 995. Everything works great. Now I want to use SSL encryption for outging mails, but nothing happens. I can't send any mails. The logfile shows a SSL-handshake error on SMTP, while connecting to smtp.we...
by Kriztan
2010-03-17 16:26
Forum: General discussions
Topic: using web.de and SSL for SMTP fails
Replies: 7
Views: 5112

using web.de and SSL for SMTP fails

Hello, I'm using hMailServer 5.3.2-B1769 and a web.de account. I fetch my mails with SSL on port 995. Everything works great. Now I want to use SSL encryption for outging mails, but nothing happens. I can't send any mails. The logfile shows a SSL-handshake error on SMTP, while connecting to smtp.web...